Post Reply

Revolutionary - zergRush local root 2.2/2.3 [22-10: Samsung/SE update]

OP ieftm

10th October 2011, 03:31 PM   |  #1  
OP Recognized Developer
Thanks Meter: 1,754
 
289 posts
Join Date:Joined: Apr 2008
Donate to Me
More


Hello!

We would like to announce the public availability of the root exploit we use in Revolutionary, named zergRush.

This local root exploit should be Android-wide, across Froyo (2.2) and Gingerbread (2.3). However, this will not work on Android Honeycomb and up (3.0+).

Simultaneously, we're also releasing source code for this root exploit through our github.

The binary is available from here: zergRush binary.

The exploit source is available here: Revolutionary GitHub.

Usage:

You will need adb shell to execute this exploit. We need shell permissions.
Push the binary onto /data/local/ and execute these commands in a shell:

Code:
$ chmod 755 /data/local/zergRush
$ /data/local/zergRush
The resulting output should look something like this:

Code:
[**] Zerg rush - Android 2.2/2.3 local root
[**] (C) 2011 Revolutionary. All rights reserved.

[**] Parts of code from Gingerbreak, (C) 2010-2011 The Android Exploid Crew.

[+] Found a GingerBread ! 0x00017118[*] Sending 149 zerglings ...[*] Trying a new path ...[*] Sending 149 zerglings ...[*] Trying a new path ...[*] Sending 149 zerglings ...[*] Trying a new path ...[*] Sending 149 zerglings ...
[+] Zerglings caused crash (good news): 0x401219c4 0x0054[*] Researching Metabolic Boost ...
[+] Speedlings on the go ! 0xafd260a9 0xafd39f9f[*] Poping 24 more zerglings[*] Sending 173 zerglings ...

[+] Rush did it ! It's a GG, man !
[+] Killing ADB and restarting as root..enjoy!
*reconnect adb shell*

Code:
# id
uid=0 gid=0
That is all folks!

Update 20-10-2011: zergRush has been updated to include some support for Sony Ericsson phones, updates for Samsung coming soon!
Update 22-10-2011: updates for Samsung phones, get the new download (or build yourself)
Last edited by ieftm; 23rd October 2011 at 12:32 AM.
The Following 84 Users Say Thank You to ieftm For This Useful Post: [ View ]
10th October 2011, 04:34 PM   |  #2  
cdesai's Avatar
Recognized Developer
Flag IN YOUR HEAD
Thanks Meter: 4,009
 
2,281 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Cool

...
10th October 2011, 05:21 PM   |  #3  
QueNerdo's Avatar
Member
Flag Santa Barbara
Thanks Meter: 3
 
69 posts
Join Date:Joined: Sep 2011
More
Does this work on the Evo 3D with Hboot1.5?
10th October 2011, 06:57 PM   |  #4  
Senior Member
Western Australia
Thanks Meter: 176
 
620 posts
Join Date:Joined: May 2011
More
hahahaha nice script.

thank you!
10th October 2011, 07:09 PM   |  #5  
Senior Member
Thanks Meter: 9
 
111 posts
Join Date:Joined: Sep 2011
very cool script, even tough I really hate lings rush, as I'm a protoss player :P
11th October 2011, 12:47 AM   |  #6  
Member
Flag Melbourne
Thanks Meter: 19
 
68 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by QueNerdo

Does this work on the Evo 3D with Hboot1.5?

Worked for me on Evo 3D with HBOOT 1.49.0013, awesome, now to work out a downgrade.
11th October 2011, 09:17 AM   |  #7  
dapaua's Avatar
Senior Member
Barcelona
Thanks Meter: 244
 
347 posts
Join Date:Joined: Dec 2006
Donate to Me
More
Reboot?
It worked in my HTC Chacha. Then I remounted System as rw. And then after a while(about 30 secs), my device reboots.
I tried it twice, after deleting /data/local/tmp/*
Is it normal? My device is S-ON.

Edited: I found it, it is because I modified the system partition, because after reboot it was as before.
Thank you.
Last edited by dapaua; 11th October 2011 at 09:40 AM.
The Following User Says Thank You to dapaua For This Useful Post: [ View ]
11th October 2011, 09:54 AM   |  #8  
Droidyou's Avatar
Senior Member
Thanks Meter: 58
 
138 posts
Join Date:Joined: Dec 2010
More
Thanks for releasing

Send from a lightning fast Htc Sensation
11th October 2011, 01:54 PM   |  #9  
qzem's Avatar
Recognized Contributor
Thanks Meter: 988
 
1,454 posts
Join Date:Joined: Jun 2010
Donate to Me
More
It is not working on my new Samsung w i8150, with Gingerbread 2.3.5 . But thanks for your work anyway!

I've got something like (if someone might be willing to help):

Zerglings haven't found anything interesting...

I can post screenshot later.
Last edited by qzem; 11th October 2011 at 04:15 PM.
11th October 2011, 01:56 PM   |  #10  
loudaccord's Avatar
Senior Member
Thanks Meter: 28
 
434 posts
Join Date:Joined: Aug 2010
More
I'll give this a try on my hboot .98 Inc 2.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Android Software Development by ThreadRank