Post Reply

[RECOVERY][21.Feb.12] ClockworkMod Recovery v5.5.0.4

20th October 2011, 06:02 PM   |  #1  
alterbridge86's Avatar
OP Retired Recognized Developer
Flag Boston
Thanks Meter: 2,385
 
616 posts
Join Date:Joined: May 2010
Donate to Me
More
Hey Everyone! So long story short, I ended up picking up a 8.9 tab and now we have a 100% confirmed working ClockworkMod Recovery!

So, quick and dirty instructions for users WITHOUT any form of CWM recovery on their device:


1) Download the attached ClockworkMod_Recovery_v5.5.0.4.tar
2) Reboot the tab into download mode
3) Fire up Odin 1.85 and put the ClockworkMod_Recovery_v5.5.0.4.tar in the PDA field.
4) Flash!
5) Reboot into ClockworkMod Recovery

Quick and dirty instructions for users WITH some form of CWM recovery on their device:

1) Download the attached ClockworkMod_Recovery_v5.5.0.4.zip to your device
2) Reboot the tab into recovery
3) Install the zip
5) Reboot

If, for any reason, you want to return to the stock recovery, simply download the P73xx_Stock_Recovery.tar and follow the instructions above (with odin)!

DISCLAIMER: THIS WILL NOT WORK WITH LTE TABS!
Last edited by alterbridge86; 22nd February 2012 at 03:45 PM.
The Following 51 Users Say Thank You to alterbridge86 For This Useful Post: [ View ]
21st October 2011, 12:53 AM   |  #2  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2008
I kinda "bricked" my tab yesterday trying to create a recovery.

Now it just continually boots to the splash screen then restarts.

I can not get into recovery.

I can get into download.

I tried the ClockworkMod Recovery v5.0.2.6 but odin just hangs after setup connection.

Trying to download the stock recovery:

<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> recovery.img
<ID:0/003> NAND Write Start!!
<ID:0/003>
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

Any ideas?

Thanks,
-dana
21st October 2011, 01:26 AM   |  #3  
alterbridge86's Avatar
OP Retired Recognized Developer
Flag Boston
Thanks Meter: 2,385
 
616 posts
Join Date:Joined: May 2010
Donate to Me
More
Thankfully Samsung devices are notoriously hard to brick

So is the tab still booting into the OS? Or are you ONLY able to get to download mode?

Also, what did you do to try and create a recovery and what did you flash? If I can understand what has been done I can help you get up and running again

As for Odin hanging at "Setup Connection" when you tried to flash my recovery, it is likely just coincidence more than anything. Odin isn't the most dependable application...well, it is and it isn't...but getting stuck at Setup Connection is a common issue.

First tell me what you did yesterday so we can figure out how to proceed. Then we'll go from there!
21st October 2011, 04:00 AM   |  #4  
nirogu325's Avatar
Senior Member
Thanks Meter: 665
 
1,669 posts
Join Date:Joined: Oct 2010
More
I kinda want to volunteer as I am familiar with ODIN coming from a Vibrant but what's stopping me is 3 questions with all due respect. What's the related thread you were talking about at the OP? Are you sure that is the right 8.9 Stock Recovery? How did you find it as there is (at least) no American ODIN image as of today (checked Samfirmware as of this post)?
21st October 2011, 01:03 PM   |  #5  
alterbridge86's Avatar
OP Retired Recognized Developer
Flag Boston
Thanks Meter: 2,385
 
616 posts
Join Date:Joined: May 2010
Donate to Me
More
Quote:
Originally Posted by nirogu325

I kinda want to volunteer as I am familiar with ODIN coming from a Vibrant but what's stopping me is 3 questions with all due respect. What's the related thread you were talking about at the OP? Are you sure that is the right 8.9 Stock Recovery? How did you find it as there is (at least) no American ODIN image as of today (checked Samfirmware as of this post)?

Excellent -

This is the thread I was talking about in 10.1 section:
http://forum.xda-developers.com/show....php?t=1307242

The recovery is standard, regardless of region. In fact, with the exception of precompiled binary modules, the recovery is even identical to that of the 10.1 tab

What I have done here is repacked the recovery image with a vanilla build of clockworkmod. This should work on both the P7300 and the P7310.

Give it a shot and let me know how it goes!
21st October 2011, 01:25 PM   |  #6  
Bec07's Avatar
Senior Member
Thanks Meter: 90
 
722 posts
Join Date:Joined: Aug 2010
More
Neither got flashed via ODIN, but I too tried to install CWM yesterday via the market app so my recovery is messed up to start with.
After trying to flash the two the tab wouldn't boot and I got an error about a failed update.

Flashed the bootloader file below with ODIN to get it to boot.

Code:
ID:0/010> Added!!
<ID:0/010> Odin v.3 engine (ID:10)..
<ID:0/010> File analysis..
<ID:0/010> SetupConnection..
<ID:0/010> Initialzation..
<ID:0/010> Get PIT for mapping..
<ID:0/010> Firmware update start..
<ID:0/010> recovery.img
<ID:0/010> NAND Write Start!! 
<ID:0/010> 
<ID:0/010> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
Attached Files
File Type: tar BOOTLOADER_P7310_SMD_UNIFICATION.tar - [Click for QR Code] (1.86 MB, 1305 views)
21st October 2011, 03:33 PM   |  #7  
alterbridge86's Avatar
OP Retired Recognized Developer
Flag Boston
Thanks Meter: 2,385
 
616 posts
Join Date:Joined: May 2010
Donate to Me
More
Hmm ok...

So yesterday you tried the market CWM, which caused the tab not to boot at all? Then, you had to flash the bootloader to make it boot again?

I'm assuming you had a booting tab prior to trying to flash these files, but still had the borked recovery yes?
21st October 2011, 04:48 PM   |  #8  
Bec07's Avatar
Senior Member
Thanks Meter: 90
 
722 posts
Join Date:Joined: Aug 2010
More
That is correct, but the recovery was fine when i got the device, I used it to root.

I know I should do a full flash but I don't want to lose all my stuff.

Also flahing the bootloader somehow removed the cwm ?script? That was forcing the tab to try and boot into the borked recovery on each boot.
Last edited by Bec07; 21st October 2011 at 04:51 PM.
21st October 2011, 06:19 PM   |  #9  
alterbridge86's Avatar
OP Retired Recognized Developer
Flag Boston
Thanks Meter: 2,385
 
616 posts
Join Date:Joined: May 2010
Donate to Me
More
Damn that app does a number on the poor tab...unfortunately the best course of action is really to completely restock the thing - flash an entire rom through Odin with a repartition.

Since you are able to boot, you can back up all your data with Titanium backup, then move the data off your internal storage and onto your computer in case it gets wiped by the Odin flash.

Now i really wish I had an 8.9 because I'm curious if someone who hasn't got the messed up recovery tries to flash my file if it will go through or fail like yours and the Geologist.

Any takers?
21st October 2011, 08:45 PM   |  #10  
nirogu325's Avatar
Senior Member
Thanks Meter: 665
 
1,669 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by alterbridge86

Now i really wish I had an 8.9 because I'm curious if someone who hasn't got the messed up recovery tries to flash my file if it will go through or fail like yours and the Geologist.

Any takers?

That'd be me. Once I backup my apps, I will (give me some minutes and I will post the result as an EDIT post). If it fails, worst case scenario would be flashing the Asian ODIN image since it is the only one available. That one displays everything in Chinese but I can change the language. Sidenote: Damn I wonder what is taking so long to bring an American ODIN image of the 7310 live???

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes