Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,771,111 Members 47,621 Now Online
XDA Developers Android and Mobile Development Forum

Atrix ear piece not working!

Tip us?
 
Ronaldo_9
Old
#1  
Senior Member - OP
Thanks Meter 103
Posts: 1,028
Join Date: May 2010
Location: London
Default Atrix ear piece not working!

Hi guys,

I sold the atrix to a friend but some how the phone's ear piece is now working, not sure if it was dropped ( no sign of damange or water)

Anyways its a ATT one but i checked on moto UK website with IMEI and it says warranty and 0 charge to repair.

Now the phone has unlocked BL, now if I have to send it to moto, can I restore as factory?

will this lock the BL? I dont want moto to void the warranty.

Advice appreciated.
HTC Desire-->Galaxy S i9000---> Moto Atrix--->Galaxy S2-->iPhone 4--->iPhone 4s--->Galaxy Nexus--->Nexus 4--->iPhone 5-->HTC One-->Nexus 5-->HTC One m8
 
v.k
Old
#2  
Senior Member
Thanks Meter 26
Posts: 119
Join Date: Oct 2011
As a last resort, you can always buy a spare part with an earpiece speaker on ebay ($15), as I did. It seems that earpiece problem is one of the most frequent with atrix.
The Following User Says Thank You to v.k For This Useful Post: [ Click to Expand ]
 
Ronaldo_9
Old
#3  
Senior Member - OP
Thanks Meter 103
Posts: 1,028
Join Date: May 2010
Location: London
Quote:
Originally Posted by v.k View Post
As a last resort, you can always buy a spare part with an earpiece speaker on ebay ($15), as I did. It seems that earpiece problem is one of the most frequent with atrix.
Was this easy to do mate? the friend I sold the atrix to, might not be bothered about BL unlock.
HTC Desire-->Galaxy S i9000---> Moto Atrix--->Galaxy S2-->iPhone 4--->iPhone 4s--->Galaxy Nexus--->Nexus 4--->iPhone 5-->HTC One-->Nexus 5-->HTC One m8
 
v.k
Old
#4  
Senior Member
Thanks Meter 26
Posts: 119
Join Date: Oct 2011
Quote:
Originally Posted by Ronaldo_9 View Post
Was this easy to do mate? the friend I sold the atrix to, might not be bothered about BL unlock.
I haven't received the cable yet, but I've watched some take apart videos on youtube and it seems to be rather easy to replace the cable. I think I can do it myself
 
Ronaldo_9
Old
#5  
Senior Member - OP
Thanks Meter 103
Posts: 1,028
Join Date: May 2010
Location: London
I think I will go with the warranty, will try get a authorised 3rd party to repair , carphone warehouse or sent it to moto.

Cheers
HTC Desire-->Galaxy S i9000---> Moto Atrix--->Galaxy S2-->iPhone 4--->iPhone 4s--->Galaxy Nexus--->Nexus 4--->iPhone 5-->HTC One-->Nexus 5-->HTC One m8
 
jaketc
Old
#6  
jaketc's Avatar
Member
Thanks Meter 17
Posts: 85
Join Date: Sep 2009
Quote:
Originally Posted by v.k View Post
As a last resort, you can always buy a spare part with an earpiece speaker on ebay ($15), as I did. It seems that earpiece problem is one of the most frequent with atrix.
Happened to my ATRIX and my Motorola Q. Motorola quality control failure.

Sent from my MB860 using xda premium
 
JayRolla
Old
#7  
Senior Member
Thanks Meter 64
Posts: 633
Join Date: Mar 2011
I also had this issue. I flashed stock rom so unlock wouldn't pop up on reboot. Took it to att warranty center and walked out with new one in 15 min.

Sent from my MB860 using XDA App
 
pastito
Old
#8  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Nov 2011
I have the same problem. I bought an AT&T Atrix on eBay, used. I am from Argentina, so importing it was expensive and returning it to seller is not a option.

Phone has no sound at all on the earpiece. I bought the flex cable from China that has the earpiece, power switch, interface to fingerprint reader and the front camera. I replaced it really carefully but it did not Fix the problem. Front camera works, on/off button and fingerprint reader works. Earpiece does not work. By the way, the flex cable from China was the original part. Exactly the same as the one that came in the phone. Same serial numbers et all.

I connected a pair of headphones (Original Motorola) and if I turn the volume real high all I hear is noise. It is like the audio amp for the earpice is toast... also no music through the headphones. External speaker works ok.

It is really disappointing to have such a phone and that it does not work and I have no warranty at all.

Any ideas?

For what I have read, Motorola has replaced the faulty phones, so it looks like there is no fix, prolly mobo replacement? But they don't sell that.



Best Regards
 
oandarilho01
Old
#9  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Apr 2011
Hi,

My Atrix has failed on jack headphone. Then I sent it to the warranty service. It took almost 30 days to get back, because some dumbass returned it to me with a nonworking powerbutton (and it still had fingerprints INSIDE LCD).

Well, it came back, at least. But, 2 days after it, the ear piece, the call speaker stopped to work. As I use Android system info app, I get some red output (errors) when I try to call someone:

E/AudioPostProcessor
Error:Invalid accessory 18 in
am_config2coeffs_audio_device

D/AudioPostProcessor
getOutputGain(): unsupported device, set to SPEAKERPHONE!


Besides the factory reset I've already tried, there's no chance that these messages above indicates software problem?

Should the hardware replacement be the only way?

Thanks in advance
 
not.a.troll
Old
#10  
not.a.troll's Avatar
Member
Thanks Meter 10
Posts: 46
Join Date: Mar 2012
i think the right answer here would be not what kind of problem it is but what do you want to do about it. if you want to completely rule out software you could unlock, root, flash custom ROM. if you are uncertain and prefer to go for the safe route and warranty is still available then just send it back to repair, without any SW mods.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes