Project Ara Smartphone Will Run Modified Android L with Hot Swapping

Project Ara is a very exciting topic–both for hardware and … more

Streamline Android Theme Customization with Graphic Porter

I dont have a custom theme on my Android phone, and the reason for this is because … more

Boost the Brightness of Your Sony Xperia Z1’s LED

I think the last time anyone has ever used a physical torch to find their earphones, … more

XDA Xposed Tuesday: Modify the Look of Your Volume Control – XDA TV

How many screenshots have you seen with a volume status bar in the … more
Post Reply

Atrix ear piece not working!

1st November 2011, 12:40 PM   |  #1  
OP Senior Member
Flag London
Thanks Meter: 103
 
1,029 posts
Join Date:Joined: May 2010
Hi guys,

I sold the atrix to a friend but some how the phone's ear piece is now working, not sure if it was dropped ( no sign of damange or water)

Anyways its a ATT one but i checked on moto UK website with IMEI and it says warranty and 0 charge to repair.

Now the phone has unlocked BL, now if I have to send it to moto, can I restore as factory?

will this lock the BL? I dont want moto to void the warranty.

Advice appreciated.
1st November 2011, 03:00 PM   |  #2  
Senior Member
Thanks Meter: 26
 
119 posts
Join Date:Joined: Oct 2011
More
As a last resort, you can always buy a spare part with an earpiece speaker on ebay ($15), as I did. It seems that earpiece problem is one of the most frequent with atrix.
The Following User Says Thank You to v.k For This Useful Post: [ View ]
1st November 2011, 04:11 PM   |  #3  
OP Senior Member
Flag London
Thanks Meter: 103
 
1,029 posts
Join Date:Joined: May 2010
Quote:
Originally Posted by v.k

As a last resort, you can always buy a spare part with an earpiece speaker on ebay ($15), as I did. It seems that earpiece problem is one of the most frequent with atrix.

Was this easy to do mate? the friend I sold the atrix to, might not be bothered about BL unlock.
1st November 2011, 07:14 PM   |  #4  
Senior Member
Thanks Meter: 26
 
119 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by Ronaldo_9

Was this easy to do mate? the friend I sold the atrix to, might not be bothered about BL unlock.

I haven't received the cable yet, but I've watched some take apart videos on youtube and it seems to be rather easy to replace the cable. I think I can do it myself
2nd November 2011, 01:02 PM   |  #5  
OP Senior Member
Flag London
Thanks Meter: 103
 
1,029 posts
Join Date:Joined: May 2010
I think I will go with the warranty, will try get a authorised 3rd party to repair , carphone warehouse or sent it to moto.

Cheers
6th November 2011, 12:41 AM   |  #6  
jaketc's Avatar
Member
Thanks Meter: 17
 
85 posts
Join Date:Joined: Sep 2009
Quote:
Originally Posted by v.k

As a last resort, you can always buy a spare part with an earpiece speaker on ebay ($15), as I did. It seems that earpiece problem is one of the most frequent with atrix.

Happened to my ATRIX and my Motorola Q. Motorola quality control failure.

Sent from my MB860 using xda premium
6th November 2011, 12:59 AM   |  #7  
Senior Member
Thanks Meter: 65
 
634 posts
Join Date:Joined: Mar 2011
More
I also had this issue. I flashed stock rom so unlock wouldn't pop up on reboot. Took it to att warranty center and walked out with new one in 15 min.

Sent from my MB860 using XDA App
19th November 2011, 11:34 PM   |  #8  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Nov 2011
Thumbs down
I have the same problem. I bought an AT&T Atrix on eBay, used. I am from Argentina, so importing it was expensive and returning it to seller is not a option.

Phone has no sound at all on the earpiece. I bought the flex cable from China that has the earpiece, power switch, interface to fingerprint reader and the front camera. I replaced it really carefully but it did not Fix the problem. Front camera works, on/off button and fingerprint reader works. Earpiece does not work. By the way, the flex cable from China was the original part. Exactly the same as the one that came in the phone. Same serial numbers et all.

I connected a pair of headphones (Original Motorola) and if I turn the volume real high all I hear is noise. It is like the audio amp for the earpice is toast... also no music through the headphones. External speaker works ok.

It is really disappointing to have such a phone and that it does not work and I have no warranty at all.

Any ideas?

For what I have read, Motorola has replaced the faulty phones, so it looks like there is no fix, prolly mobo replacement? But they don't sell that.



Best Regards
17th April 2012, 05:01 AM   |  #9  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Apr 2011
Hi,

My Atrix has failed on jack headphone. Then I sent it to the warranty service. It took almost 30 days to get back, because some dumbass returned it to me with a nonworking powerbutton (and it still had fingerprints INSIDE LCD).

Well, it came back, at least. But, 2 days after it, the ear piece, the call speaker stopped to work. As I use Android system info app, I get some red output (errors) when I try to call someone:

E/AudioPostProcessor
Error:Invalid accessory 18 in
am_config2coeffs_audio_device

D/AudioPostProcessor
getOutputGain(): unsupported device, set to SPEAKERPHONE!


Besides the factory reset I've already tried, there's no chance that these messages above indicates software problem?

Should the hardware replacement be the only way?

Thanks in advance
19th April 2012, 04:09 AM   |  #10  
not.a.troll's Avatar
Member
Thanks Meter: 10
 
46 posts
Join Date:Joined: Mar 2012
More
i think the right answer here would be not what kind of problem it is but what do you want to do about it. if you want to completely rule out software you could unlock, root, flash custom ROM. if you are uncertain and prefer to go for the safe route and warranty is still available then just send it back to repair, without any SW mods.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes