Thread Closed

[DEV] ICS Android 4.0 Porting and Development | es209ra (X10) | alpha1 | 21/11/2011

OP zdzihu

21st November 2011, 03:11 PM   |  #1  
zdzihu's Avatar
OP Retired Recognized Developer
Thanks Meter: 5,174
 
647 posts
Join Date:Joined: Sep 2008
Donate to Me
This is a dev thread. Do not install this release unless you know what you're doing. Do not post if you have nothing to contribute.

This is very early build, we're behind other qsd8k devices but will eventually catch up

Big thanks to all qsd8k developers working on this (N1, Desire, HD2, X10).


[KERNEL]
- ol' good 2.6.29-SEMC
- fixed touchscreen driver (now backward-compatibile with Gingerbread)

[ROM]
- partially based on drewis release (thanks!) - currently I don't have access to PC that could handle compilation of the whole thing
If someone could compile clean es209ra build and upload it would be awesome.

[WORKING]
- it boots
- radio, calls, txt (sms)
- audio partially working (in-call is fine, playing mp3/ringtones leads to WLOD)
- bluetooth, GPS seem to work
- wifi almost working ("can't find wlan0 device")
- mobile data (it gets IP but disconects afterwards, needs investiagtion)

[NOT WORKING]
- most of the stuff does not work
- quite unstable

[SOURCES]
Will upload all of the useful code/fixes here.
- ICS + GB compatibile touch driver: es209ra_touch_mt.c
- compatibile ramdisk (props FXP): http://www.mediafire.com/?1n51pn1upwv79ur


[DOWNLOAD]
Alpha1 ROM (for CWM5) + corresponding kernel (flashtool) is here:

http://www.mediafire.com/?ht6p6tbpj2988d4


Cheers,
z
Last edited by zdzihu; 21st November 2011 at 03:26 PM.
The Following 283 Users Say Thank You to zdzihu For This Useful Post: [ View ]
21st November 2011, 04:40 PM   |  #2  
M_T_M's Avatar
Seņor Moderator - uoy llort ot tnaem si eltit sihT
Flag Texas
Thanks Meter: 5,474
 
17,812 posts
Join Date:Joined: Apr 2009
More
Exclamation
Just did a major clean up on this thread mates....no more "thanks" posts please. If thankful... click the thanks button.

Regards,


M_T_M
The Following 23 Users Say Thank You to M_T_M For This Useful Post: [ View ]
21st November 2011, 05:11 PM   |  #3  
silveraero's Avatar
Senior Member
Flag Ho Chi Minh City
Thanks Meter: 185
 
1,043 posts
Join Date:Joined: Jul 2011
Finally we get it. aZuZu is working on ASOP ICS 4.0.1. This may help him work easier. So with locked bootloader, can we flash cause' you wrote there CWM5?
Last edited by silveraero; 21st November 2011 at 05:13 PM.
The Following 2 Users Say Thank You to silveraero For This Useful Post: [ View ]
22nd November 2011, 12:16 AM   |  #4  
-- X10B --'s Avatar
Senior Member
Flag Antipolo
Thanks Meter: 126
 
480 posts
Join Date:Joined: Jan 2011
Donate to Me
More
VIDEO
here's a video for ics on x10 alpha build 1

http://www.youtube.com/watch?v=bsOFn4YLvZU

@frosty666 please kindly include this on your ics discussion thread.

thankz
Last edited by -- X10B --; 22nd November 2011 at 01:08 AM.
The Following 8 Users Say Thank You to -- X10B -- For This Useful Post: [ View ]
22nd November 2011, 05:38 AM   |  #5  
Senior Member
Flag Sydney
Thanks Meter: 94
 
477 posts
Join Date:Joined: Mar 2011
More
hi zdzihu, its great to see you back! is this only temporary or, are you going to be more active, like before?

mmmkay, I'm not dev, but I want to ask if you're compiling this from ground up (like Jerpelea's CM7), or you're like just mashup of current SE and ICS sources. if its a mashup, I can help. but I do very little design from ground up things.

Sent from my X10i using xda premium
22nd November 2011, 05:54 AM   |  #6  
aZuZu's Avatar
Recognized Developer
Flag Zagreb
Thanks Meter: 930
 
625 posts
Join Date:Joined: Jan 2011
More
if you have fixed audio hw sources i could recompile..
altho i have complete es209ra compile with ics hw, old cm gralloc / copybit sources and generic audio..
The Following 5 Users Say Thank You to aZuZu For This Useful Post: [ View ]
22nd November 2011, 07:46 AM   |  #7  
aZuZu's Avatar
Recognized Developer
Flag Zagreb
Thanks Meter: 930
 
625 posts
Join Date:Joined: Jan 2011
More
So for me doesn't even boot
As i came from night shift i will try later on more...

Here you are libhardware.so, libhardware_legacy.so & wpa_supplicant from my compiled ICS build so if someone can boot z rom maybe it could test this too

p.s.
it is searching ar6000.ko as normal stock one not wifi.ko as sdk port
Last edited by aZuZu; 22nd November 2011 at 07:53 AM.
The Following 4 Users Say Thank You to aZuZu For This Useful Post: [ View ]
22nd November 2011, 10:52 AM   |  #8  
zdzihu's Avatar
OP Retired Recognized Developer
Thanks Meter: 5,174
 
647 posts
Join Date:Joined: Sep 2008
Donate to Me
Quote:
Originally Posted by aZuZu

So for me doesn't even boot
As i came from night shift i will try later on more...

Here you are libhardware.so, libhardware_legacy.so & wpa_supplicant from my compiled ICS build so if someone can boot z rom maybe it could test this too

p.s.
it is searching ar6000.ko as normal stock one not wifi.ko as sdk port

Hi Azuzu, I am able to compile single libs and binaries (libhw_legacy, supplicant), it's just dex and stuff causing problems (1GB of ram + 1.6GHz). As for libaudio, I will take a look soon

Cheers,
z
The Following 29 Users Say Thank You to zdzihu For This Useful Post: [ View ]
22nd November 2011, 12:56 PM   |  #9  
DiabloBasic's Avatar
Senior Member
Thanks Meter: 19
 
107 posts
Join Date:Joined: Nov 2011
I help if u want :)
Hello guys, I'm new to the forum and I hope to see well with you.

I would be willing to help compile the source since EXCLUSIVELY use only Linux operating system and is much easier to work on programming because most of the libraries are already installed by default, I hope I was clear.

greetings

Joseph
The Following 2 Users Say Thank You to DiabloBasic For This Useful Post: [ View ]
22nd November 2011, 01:04 PM   |  #10  
DooMLoRD's Avatar
Recognized Developer
Flag Noida
Thanks Meter: 38,776
 
13,107 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by zdzihu

Hi Azuzu, I am able to compile single libs and binaries (libhw_legacy, supplicant), it's just dex and stuff causing problems (1GB of ram + 1.6GHz). As for libaudio, I will take a look soon

Cheers,
z

yaay Z!!!

glad to see back!

now i feel so bad & depressed that i dont have a working x10 with me
hope that service center guy is able to repair it again...

@aZuZu
can u please upload ur work-in-progress sources to git... i know how much fixing u have done... it might help other too

The Following 3 Users Say Thank You to DooMLoRD For This Useful Post: [ View ]
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes