Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Guide] Get Swype working without having to edit settings.db

OP MadJoe

4th December 2011, 10:31 PM   |  #1  
MadJoe's Avatar
OP Senior Member
Flag Boston
Thanks Meter: 131
 
800 posts
Join Date:Joined: Jul 2007
More
After reading the Swype thread multiple times, it seemed like I was going to have to sack-up and edit settings.db, potentially bricking my Kindle Fire. Well, ignorance, and thick-headedness and a little luck combined to allow me to get it working with what turned out to be a very simple work around.

First, you will of course need to be rooted. I used the method outlined on www.rootkindlefire.com, but others have used Super 1 click, or Zergrush. Whatever floats your particular boat.

Second you'll need the Swype.apk, and a root explorer type app.

Once you've got all that, go ahead and install Swype normally, then navigate to data/app and move the Swype.apk to system/app. Go to a text field and long press to get the input method popup and select Swype, or use Nook Tools app (Swype should start force closing), select kindle keyboard again if you like and reboot, or just reboot (without reselecting Kindle keyboard rebooting takes a while but will happen, just wait). Once you've rebooted, install Swype again. It will tell you it's a system app but your data will be saved blah blah. Once that's done, you should be good to use Swype without issue.

If you want, you can then go ahead and unroot and it should be good. Actually, the only reason you need root is for when you move the apk to system/app. After that, all should work with or without root.

If you get more force closes, just reinstall Swype again. This worked for me on two different kindles so far, so I'm confident, as long as you follow the instructions, it will work for you too.


Sent from my Digital Brick

Edit: fixed Swypeisms
Last edited by MadJoe; 4th December 2011 at 10:41 PM.
The Following 13 Users Say Thank You to MadJoe For This Useful Post: [ View ]
16th December 2011, 03:53 AM   |  #2  
movieaddict's Avatar
Senior Member
Thanks Meter: 358
 
2,105 posts
Join Date:Joined: Jul 2010
Donate to Me
More
nope didnt work!!!!! bummer
16th December 2011, 04:16 AM   |  #3  
Junior Member
Thanks Meter: 1
 
26 posts
Join Date:Joined: Feb 2011
I have made many changes to my kindle and getting swype to work is not one of them. I can never get it show up with either nook tools or long press.
16th December 2011, 05:00 AM   |  #4  
krelvinaz's Avatar
Senior Member
Flag Mesa AZ
Thanks Meter: 556
 
2,315 posts
Join Date:Joined: Feb 2008
More
Hmmmm...

Just did it to see how hard it might be. I've been using the thumb keyboard for some time now.

Starting out, I am already rooted...

1) Copied over the Swype Installer (I am a registered user)
2) Logged in.
3) Selected Beta Americas
4) Installed keyboard
5) Used root explorer and navigated to /data/apps
6) Moved the swype keyboard apk file to /system/apps
7) checked permissions to make sure it was rw-r--r-- (it was already)
8) Rebooted device
9) After the reboot, went to a program so that I could long press in the text entry area (I used Touchdown, but anything would have worked)
10) Selected Input Method
11) Selected Swype

Tried to use it, Forced Closed.

12) Went back with Root Explorer and found the /system/app swype apk
13) Clicked on it, wanted to install... let it do it.
14) Tried using the keyboard again.

See below:



The one issue I have is that the ability to minimize is not easy to get to... but if you press and hold the swype key, it will go to Preferences and you can just click the back arrow and you have done the same thing. I'm sure there is some other way to do it, but I've not played with it much. Found you can do this by swiping from the Swype key to the backspace key...

Note that I don't normally use Swype, but it seems to work okay for me on my KF.
Last edited by krelvinaz; 17th December 2011 at 04:17 AM. Reason: Updated info on minimizing the keyboard.
The Following 10 Users Say Thank You to krelvinaz For This Useful Post: [ View ]
16th December 2011, 05:10 AM   |  #5  
MadJoe's Avatar
OP Senior Member
Flag Boston
Thanks Meter: 131
 
800 posts
Join Date:Joined: Jul 2007
More
Quote:
Originally Posted by krelvinaz

The one issue I have is that the ability to minimize is not easy to get to... but if you press and hold the swype key, it will go to Preferences and you can just click the back arrow and you have done the same thing. I'm sure there is some other way to do it, but I've not played with it much.

Note that I don't normally use Swype, but it seems to work okay for me on my KF.

Swype from the Swype key to the delete key and Swype will minimize allowing you to access your bottom menu bar.

Sent from my Digital Brick
The Following 3 Users Say Thank You to MadJoe For This Useful Post: [ View ]
16th December 2011, 05:10 AM   |  #6  
MadJoe's Avatar
OP Senior Member
Flag Boston
Thanks Meter: 131
 
800 posts
Join Date:Joined: Jul 2007
More
Quote:
Originally Posted by movieaddict

nope didnt work!!!!! bummer

Strange, worked both times I did it on two different Fires.

Sent from my Digital Brick
16th December 2011, 03:01 PM   |  #7  
Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Jun 2010
Worked out fine for me.
16th December 2011, 03:34 PM   |  #8  
Junior Member
Thanks Meter: 1
 
26 posts
Join Date:Joined: Feb 2011
Ok ok for some reason after many previous attempts I got it to work easy peasy.

i can't believe i struggled with this earlier. thanks for everyone's input on this thread. i am a swype user and was missing it.
16th December 2011, 10:29 PM   |  #9  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2007
Worked for me, exactly according to krelvinaz's instructions.
17th December 2011, 03:26 AM   |  #10  
movieaddict's Avatar
Senior Member
Thanks Meter: 358
 
2,105 posts
Join Date:Joined: Jul 2010
Donate to Me
More
Quote:
Originally Posted by krelvinaz

Hmmmm...

Just did it to see how hard it might be. I've been using the thumb keyboard for some time now.

Starting out, I am already rooted...

1) Copied over the Swype Installer (I am a registered user)
2) Logged in.
3) Selected Beta Americas
4) Installed keyboard
5) Used root explorer and navigated to /data/apps
6) Moved the swype keyboard apk file to /system/apps
7) checked permissions to make sure it was rw-r--r-- (it was already)
8) Rebooted device
9) After the reboot, went to a program so that I could long press in the text entry area (I used Touchdown, but anything would have worked)
10) Selected Input Method
11) Selected Swype

Tried to use it, Forced Closed.

12) Went back with Root Explorer and found the /system/app swype apk
13) Clicked on it, wanted to install... let it do it.
14) Tried using the keyboard again.


Note that I don't normally use Swype, but it seems to work okay for me on my KF.

Ty so much!!! step , 12, 13, 14 solved my problem!! went back and installed it again and it worked, ty again! to get rid of keyboard just press swype key then home......

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes