Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,559 Members 40,490 Now Online
XDA Developers Android and Mobile Development Forum

Power Button Ends Call on BACKside-IHO CM7 Optimus V

Tip us?
 
ShuRugal
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Dec 2011
Default Power Button Ends Call on BACKside-IHO CM7 Optimus V

i have spent all evening trying to figure out how to fix this. I have looked high and low, near and far. After four hours of searching, i finally found the post in the Backside thread about manually editing qwerty.kl to change the key 107 setting from "endcall" to "power", but this has accomplished nothing.

why on earth has this issue not been fixed yet? from what i gather by google search, this has been a problem since at least june, probably sooner. is there ever going to be an update for BACKside IHO that fixes this? I was tremendously pleased when i found that i could get my OptV to 2.3 by way of CM7, but i have spent all day tracking down quirks (had to reinstall twice to get prox sensor working)... I never got into Linux because of this crap, but now i have to do it on my phone???
 
The-Captain
Old
#2  
The-Captain's Avatar
Recognized Themer / Retired Forum Moderator
Thanks Meter 3,178
Posts: 2,806
Join Date: May 2011
It would probanly be best to unroot and reroot/ or install a clean install of CM7 with a full wipe.

Hit that thank button if I helped!
 
ShuRugal
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Dec 2011
I have done a full-wipe and reinstall of CM7 (to fix prox sensor). How does one go about un/re-rooting? Does it entail restoring to factory, or can it be donr without having to remove CM7 (again)?
 
The-Captain
Old
#4  
The-Captain's Avatar
Recognized Themer / Retired Forum Moderator
Thanks Meter 3,178
Posts: 2,806
Join Date: May 2011
It will take it back to out of the box state. CM7 is a rom, roms require root to install besides stock. After you root, you will need to install it again.

Hit that thank button if I helped!
 
ShuRugal
Old
(Last edited by ShuRugal; 8th December 2011 at 02:22 AM.)
#5  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Dec 2011
still no dice, and now the prox sensor is broken again.

EDIT: it seems there was more than one file with a value of "ENDCALL" assigned to key 107. Changed all "ENDCALL" buttons i could find to "POWER" and now it works.

For some reason, though, prox sensor only works when not in bluetooth mode O.o
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes