Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

{ST15}[Xperia mini] - Decrease Touchscreen sensitivity (Overheat Issue)

OP Namidu

1st April 2012, 02:18 PM   |  #231  
Junior Member
Flag Cairo
Thanks Meter: 0
 
8 posts
Join Date:Joined: Mar 2012
More
another question
Quote:
Originally Posted by T3sla

Just go here make an account, log in, download wotanserver client and drivers, install drivers, connect your phone, let windows find your phone, run wotanserverclient and it will tell you what to do (turn off your phone, connect it while pressing volume down key i think) very easy.

I had the same problem both on 0.42 and 0.62 as many others so most propably you'll have the problem too.Rooting is pretty easy, easily can be undone, you don't loose warranty and as far as i remember there is no risk, if you follow the guide, bricking your phoneIf you finally go for a root first downgrade to 0.42 then root, and then update OTA (over the air) to maintain root.There are methods to root 0.62 but never tried them till now.

Sorry I don't know what is OTA, but I have another question, do I have to download .42 software separately? or WotanClient will ask me which version I need to choose from?
1st April 2012, 03:49 PM   |  #232  
T3sla's Avatar
Senior Member
Flag Thessaloniki
Thanks Meter: 48
 
183 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by welymans

Sorry I don't know what is OTA, but I have another question, do I have to download .42 software separately? or WotanClient will ask me which version I need to choose from?

OTA means over the air which means update directly from your phone not through your computer.You don't have to download separately just choose which version you wantPls if you have more questions open a new thread cause we are off topic and it's my fault too, i should have told you earlier
Last edited by T3sla; 1st April 2012 at 04:01 PM.
2nd April 2012, 03:42 PM   |  #233  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2009
I ran the script and all is ok now as far as the back&menu keys are concerned.
though I'm having a bit of another problem.

the accelerometer/compass is not working. it happens when I upgrade from .377 to .42 (which was necessary for the script to run)
I'm going in the service menu and the accelerometer is showing no values or the values are stuck.

maybe one of you kind gentlemen who had been poking in the config files came across anything related to the accelerometer or compass sensor and would like to point it to me. I would really appreciate it.
my sensors.conf file is
Quote:

# Setup accelerometer axis
bma150input_axis_x = 0
bma150input_axis_y = 1
bma150input_axis_z = 2

Ikbma150input_neg_x = 0
bma150input_neg_y = 0
bma150input_neg_z = 0

bma250input_axis_x = 0
bma250input_axis_y = 1
bma250input_axis_z = 2

bma250input_neg_x = 1
bma250input_neg_y = 1
bma250input_neg_z = 0


# Setup AKM897x axis
ak897xorientation_axis_map = 0,1,2
ak897xorientation_axis_sign = 1,1,-1
ak897xmagnetic_axis_map = 0,1,2
ak897xmagnetic_axis_sign = -1,-1,1

I apologize for being slightly OT.
Last edited by geolost; 2nd April 2012 at 03:51 PM.
7th April 2012, 10:22 PM   |  #234  
aftergr's Avatar
Senior Member
Flag Athens
Thanks Meter: 98
 
486 posts
Join Date:Joined: Jul 2011
I thought that it was only my phone to do that

I have it in my hand for just 3 days and it is allready rooted, unlocked bootloader, rage 2.7 kernel and HYBROM V16, o/c @1600

I had Krsh kernel but i changed to rage to do some test properly for this problem
I dont know yet, i have to ''warm'' it a bit to see
The question is: Can i run this script with rage kernel or i have to flash krsh?
8th April 2012, 01:17 AM   |  #235  
aftergr's Avatar
Senior Member
Flag Athens
Thanks Meter: 98
 
486 posts
Join Date:Joined: Jul 2011
Never mind, it didnt work on rage so i installed krsh again and after 2 attempts it seems it worked
After some minutes of gaming everything went fine, hope it fixed
8th April 2012, 08:21 AM   |  #236  
Member
Flag KARAJ
Thanks Meter: 2
 
33 posts
Join Date:Joined: Dec 2011
More
Thanks guy..
9th April 2012, 02:12 AM   |  #237  
Member
Flag Blackburn (near Manchester)
Thanks Meter: 2
 
84 posts
Join Date:Joined: Feb 2012
Donate to Me
More
Is this an issue on the XMP too or is that OK?
10th April 2012, 12:44 AM   |  #238  
aftergr's Avatar
Senior Member
Flag Athens
Thanks Meter: 98
 
486 posts
Join Date:Joined: Jul 2011
I can post again that IT WORKED

After some hours of drag racing bike edition , neither one hick up
10th April 2012, 09:51 AM   |  #239  
Member
Flag Batam
Thanks Meter: 47
 
35 posts
Join Date:Joined: Mar 2012
More
Yes, it works !
No more problem with back button whenever it gets hot

Sent from my ST15i using XDA
11th April 2012, 10:26 AM   |  #240  
Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by Kusa123

for those who is difficult to use gscript, I modified a batch file of doomlord's so you can run from windows.

1. if the device is not rooted, downgrade to 4.0.2.A.0.58 or before version using flashtool or wotanserver. (no need to unlock bootloader)

2. download DooMLoRD's Easy Rooting Toolkit
http://forum.xda-developers.com/show....php?t=1321582

3. rename the attached file (calibrate.bat.txt) to calibrate.bat and put the file to the folder same as runme.bat

4. run calibrate.bat and follow the instructon, the device will reboot. then calibration should be done.

I'm lazy to take a permission to the tool's author and test the script, so beware if this batch file really works as intended or not. :P

EDIT (5 Mar):
Fixed batch file where the reboot didn't execute correctly. Thanks gyeben pointing out to me

I think it's worked!

Last question, if I update my firmware will the fix stay in place? I dropped from .62 to .42.

Post Reply Subscribe to Thread

Tags
fix xperia mini 100%, xperia mini overheat
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes