Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,045 Members 38,449 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Very Slow Wifi (Family Edition)

Tip us?
 
Homestar1217
Old
#1  
Homestar1217's Avatar
Senior Member - OP
Thanks Meter 4
Posts: 128
Join Date: Jun 2010
Location: DFW Texas
Default [Q] Very Slow Wifi (Family Edition)

So I have a Xoom FE, obviously, and when I'm browsing the internet in the stock browser, browsing the market, watching netflix, anything that requires internet in general is incredibly slow. Like almost unusable.

I know my internet is fast enough because both of my computers and other devices (Xbox, Droid, Sony Blu-Ray) fly on my network. We use a good Netgear router that's a full a/b/g/n dual band device running on 2.4 and 5Ghz.

The browser is usually painfully slow no matter what, and any of the apps that have anything to do with video are just pathetic. No videos load quickly, mainly in the YouTube app or when browsing to a video on the web, IGN for an example. Once they load enough they rarely keep playing for very long before stopping to buffer, and that's very noticeable in Netflix especially.

I've done Google searches and tried nearly everything that's been suggested, but most of that stuff is for the original Xoom. Not many seem to have gone for the FE. If anyone has any ideas on what I can try I'm open to ideas, even including the router settings. Like I said my internet speed is fine, I can stream 4k YouTube clips without buffering on my PCs.
Past devices: Centro, HD2, Vibrant, Droid Charge, Droid 2, Droid DNA, Xoom Family Edition, Asus TF300T.

Current toys: G3, Galaxy Tab Pro 8.4.
 
Homestar1217
Old
#2  
Homestar1217's Avatar
Senior Member - OP
Thanks Meter 4
Posts: 128
Join Date: Jun 2010
Location: DFW Texas
Gosh over 100 views and no suggestions! Not even 1? Man...
Past devices: Centro, HD2, Vibrant, Droid Charge, Droid 2, Droid DNA, Xoom Family Edition, Asus TF300T.

Current toys: G3, Galaxy Tab Pro 8.4.
 
digitalr0gue
Old
#3  
digitalr0gue's Avatar
Member
Thanks Meter 10
Posts: 93
Join Date: Nov 2008
Location: California
Does this happen on other wireless networks? Or only on your own?

Sent from my Xoom using Tapatalk
- d i g i t a l r 0 g u e -
I've never met a warranty I couldn't void.

Say Hello to Your Little Friend:
 
Luda305
Old
#4  
Luda305's Avatar
Senior Member
Thanks Meter 37
Posts: 528
Join Date: May 2011
I have the family edition and I have great internet speed. I have a pc, laptop, xbox 360, evo 3d, Hp touchpad, and the xoom FE all on the same router and still the xooms internet is fast. So it might be a router problem for you

Sent from my PG86100 using xda premium
 
digitalr0gue
Old
#5  
digitalr0gue's Avatar
Member
Thanks Meter 10
Posts: 93
Join Date: Nov 2008
Location: California
That's what I was trying to isolate.

Sent from my Xoom using Tapatalk
- d i g i t a l r 0 g u e -
I've never met a warranty I couldn't void.

Say Hello to Your Little Friend:
 
Homestar1217
Old
#6  
Homestar1217's Avatar
Senior Member - OP
Thanks Meter 4
Posts: 128
Join Date: Jun 2010
Location: DFW Texas
I haven't really used it on another router for any significant length of time. Unfortunately that means I can't isolate that as a problem either. In a couple weeks I'll be staying at a house with wifi when I go skiing, I'll definitely be paying attention to the speed there.

Its definitely the worst with video, whether it be flash or the youtube app itself the video just loads incredibly slow. Flash videos are nearly unwatchable if not because of the speed because of the glitching. Something I saw hadn't been fixed in the Xoom 2 when I read Engadget's review.

Sent from my SCH-I510 using XDA App
Past devices: Centro, HD2, Vibrant, Droid Charge, Droid 2, Droid DNA, Xoom Family Edition, Asus TF300T.

Current toys: G3, Galaxy Tab Pro 8.4.
 
Luda305
Old
#7  
Luda305's Avatar
Senior Member
Thanks Meter 37
Posts: 528
Join Date: May 2011
I watch videos just fine. YouTube, netflix all that good ish with no problem

Sent from my PG86100 using xda premium
 
nswenson
Old
#8  
Senior Member
Thanks Meter 46
Posts: 241
Join Date: Jan 2008
Location: Palo Alto, CA
Run Speedtest. If it's slow compared to your laptop, then try changing the wifi router protocol. If it's using WEP, try changing to WPA. I had this issue with my nook color and changing to WPA fixed internet speed issues.
 
Homestar1217
Old
#9  
Homestar1217's Avatar
Senior Member - OP
Thanks Meter 4
Posts: 128
Join Date: Jun 2010
Location: DFW Texas
Well I ran a speed test on all the devices I have. My laptop, Droid Charge and my desktop (which is hardwired) all reached just about 5mbps. That isn't bad, my AT&T DSL is supposed to peak at 6. This stupid thing hit under .5mbps, notice that POINT. That's less than half 1mbps. Thinking it might just be the browser I downloaded the app (which doesn't have a honeycomb version apparently), it fared slightly better with about 1.5mbps. Both tests had a ping of about 400ms, while all other devices were less than 20ms.

The router is already set to WPA, so I'm not sure what else to try. I'm thinking about trying the push button connect on the router to see if it helps.
Past devices: Centro, HD2, Vibrant, Droid Charge, Droid 2, Droid DNA, Xoom Family Edition, Asus TF300T.

Current toys: G3, Galaxy Tab Pro 8.4.
 
jediman
Old
#10  
jediman's Avatar
Senior Member
Thanks Meter 16
Posts: 282
Join Date: Oct 2010
Got netgear?
Just got fed up with mine after 2 years.
Granted it was draft n, and dropped the ssid broadcast daily, but even wired it slowed to a crawl most likely due to spi (stateful packet inspection). Try without it on if you got it.

Or buy a cisco router (they bought linksys). All my phone, tablet and pc related connection issues stopped when I replaced mine.

Sent from my DROID3 using xda premium

The Following User Says Thank You to jediman For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes