Post Reply

Samsung Omnia W - SMS Problem

13th December 2011, 09:21 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2011
Dear friends, hello!

I'm new in XDA, and i migrated from Android to Windows Phone,
A 4 days a go i've bought the Samsung Omnia W (SGH-i677).

I liked too much this platform, i'm loving it. Really!

But i got a little (and serious) issue with my device. I don't know if this is a problem of my device, or a problem of Windows Phone.

This is my issue: When i send a SMS Message, sometimes the message is sent correctly, sometimes my destiny doesn't receive any message. And few minutes after, i got a error message "Couldn't send a message. Try again".

And sometimes i receive a SMS message with no problems. Sometimes my destiny tell'me that sent me a message, but i dont receive any message).


I search for any incidence about this issue in Internet. I found some friends with the same problem. And they tell about this problem after a NoDo update, but i'm already using the Mango. I couldn't find how to fix this error.

But i saw in the internet, they telling you to change the connection to 2G (Turn off the 3G). And as they say, it works to me. ALL blocked SMSs were sent correctly!

Someone here knows what can i do about it?
I dont want back to Android/iOS. I really liked the platform, and i'm very happy with WP7. But this is a serious issue, i really use the SMS service.

What can i do about it?
15th January 2012, 12:44 PM   |  #2  
Junior Member
Thanks Meter: 1
 
27 posts
Join Date:Joined: Jan 2012
More
i'm using the omnia W(GT-i8350) and even i'm facing the same issue. when i switch off the data connection, the texts can be sent. what is the fix?

model - samsung omnia w i8350( GT-I8350)
OS Version : 7.10.7720.68
Carrier : TATA DOCOMO
17th January 2012, 02:55 PM   |  #3  
Senior Member
Flag Hyderabad
Thanks Meter: 13
 
126 posts
Join Date:Joined: Dec 2011
More
It's the issue with yr operator.
17th January 2012, 05:54 PM   |  #4  
Junior Member
Thanks Meter: 7
 
23 posts
Join Date:Joined: Jul 2010
Am sure this an operator related issue. Make sure the sms center number is correct.
25th January 2012, 05:17 PM   |  #5  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2012
This problem cannot be operator-specific. I am facing the same issue with an Airtel connection.
26th January 2012, 04:11 AM   |  #6  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Mar 2011
Not an operator issue
hi. This certainly not operator specific issue. I have tried with 3 different operators and the problem persists. I have contacted samsung service center and I was told to bring the handset to service center for update which is available. I don't know exactly which update they are talking exactly but since I have updated my OS it must be firmware update. I am going to send my phone to service center in next few days. I will get back to you with their response.
28th January 2012, 08:35 AM   |  #7  
Junior Member
Thanks Meter: 1
 
27 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by benttom

hi. This certainly not operator specific issue. I have tried with 3 different operators and the problem persists. I have contacted samsung service center and I was told to bring the handset to service center for update which is available. I don't know exactly which update they are talking exactly but since I have updated my OS it must be firmware update. I am going to send my phone to service center in next few days. I will get back to you with their response.

what is your OS and firmware version number? can you please post it?
and did you send it to the service centre?

and the issue is not operator specific, i've faced it on Vodafone and DOCOMO
Last edited by SSK the Gr8; 28th January 2012 at 08:40 AM.
29th January 2012, 02:34 PM   |  #8  
Senior Member
Flag Hyderabad
Thanks Meter: 13
 
126 posts
Join Date:Joined: Dec 2011
More
Hi,

Actually I am able to send. But not to multiple persons. Using Vodafone.


I think it's problem with WP7 how it sends the messages.
Possible to discuss in WP support forums.

---------- Post added at 08:04 PM ---------- Previous post was at 08:03 PM ----------

Can any one confirm it's not a problem in Nokia/HTC and only specific to Samsung?
29th January 2012, 05:39 PM   |  #9  
Junior Member
Thanks Meter: 1
 
27 posts
Join Date:Joined: Jan 2012
More
are you able to send on 3g+/hspa network too, cause i know 3 other people on vodafone 3g who cannot

they can only send message when they switch off data

and if they are on edge then data is not a problem, even if it's on , text can be sent

btw, i have sent text to 5 people together with no issues at all right now..
Last edited by SSK the Gr8; 29th January 2012 at 05:45 PM.
30th January 2012, 10:39 AM   |  #10  
Senior Member
Flag Hyderabad
Thanks Meter: 13
 
126 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by SSK the Gr8

btw, i have sent text to 5 people together with no issues at all right now..

I am unable to send to more than 1 person when data is enabled or whatever. Silly.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes