Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Closed

[CLOSED] [ROM] [DEV] [ICS] Ice Cream Sandwich - Dev's only

OP benjamingwynn

17th December 2011, 09:00 PM   |  #1  
benjamingwynn's Avatar
OP Recognized Contributor / Recognized Developer
Flag Cardiff
Thanks Meter: 2,387
 
2,514 posts
Join Date:Joined: Nov 2011
Donate to Me
More
ICE CREAM SANDWICH
Dev's only sorry
EXPECT A TOUCH SCREEN FIX: IN NEW KERNEL *SORRY*

IF YOU WISH TO DOWNLOAD DO SO BUT PLEASE NOTE THAT THIS IS NOT FINISHED AND WILL CONTAIN BUGS! READ WHAT DOESN'T WORK FIRST!

Thanks to ALQUEZ, EOGHAN2T7, BRANDONHUN, *SE-NSEI, INSINK71 and anybody else I forgot




Download - new touch fix and cm7 kernel soon





LATEST CHANGES

Cleaned up build.prop
New atmel.c touch file (didn't fix though)
Zipalligned for speed
Overclock support (hopefully)
Better marvelc/ct SUPPORT
Newer kernel designed for all marvel* devices --- soon

THINGS THAT WORK

IT BOOTS
It boots on marvelc devices


KNOWN PROBLEMS


BLUETOOTH DOESN'T WORK
SOUND DOESN'T WORK
TOUCH SCREEN DOESN'T WORK CORRECTLY (FIX IS BEING TESTED)
GRAPHICS ACCELERATION DOESN'T WORK
LIVE WALLPAPERS ALSO DON'T WORK (GRAPHICS ACCELERATION)
HAPTIC BUTTONS / SOFTKEY BUTTONS (FIX IS BEING TESTED)



------------------------------------------

ICS Logcat

14:42:31.100 Info DEBUG 80 debuggerd: Nov 18 2011 00:24:56
14:42:31.100 Debug AK8973 87 AK8973 daemon 1.0.3 Start
14:42:31.100 Debug AK8973 87 (Library version : 1.2.1.620)
14:42:31.100 Error AK8973 87 m_hDevice= -1
14:42:31.100 Error AK8973 87 m_aDevice= 7
14:42:31.100 Error AK8973 87 Device initialization failed.
14:42:31.100 Error AK8973 87
14:42:31.100 Error AK8973 87 m_hDevice= -1
14:42:31.100 Error AK8973 87 m_aDevice= 7
14:42:31.100 Error AK8973 87 Device initialization failed.
14:42:31.101 Error AK8973 87
14:42:31.101 Info Vold 78 Vold 2.1 (the revenge) firing up
14:42:31.101 Info Netd 79 Netd 1.0 starting
14:42:31.101 Error AK8973 87 m_hDevice= -1
14:42:31.101 Error AK8973 87 m_aDevice= 7
14:42:31.101 Error AK8973 87 Device initialization failed.
14:42:31.101 Error AK8973 87
14:42:31.101 Debug Vold 78 Volume sdcard state changing -1 (Initializing) -> 0 (No-Media)
14:42:31.101 Error Netd 79 Unable to create netlink socket: Protocol not supported
14:42:31.101 Error Netd 79 Unable to open quota2 logging socket
14:42:31.101 Debug Vold 78 Volume sdcard state changing 0 (No-Media) -> 2 (Pending)
14:42:31.101 Debug Vold 78 Volume sdcard state changing 2 (Pending) -> 1 (Idle-Unmounted)
14:42:31.101 Debug AndroidRuntime 82
14:42:31.101 Debug AndroidRuntime 82 >>>>>> AndroidRuntime START com.android.internal.os.ZygoteInit
Last edited by benjamingwynn; 29th February 2012 at 11:32 PM.
The Following 20 Users Say Thank You to benjamingwynn For This Useful Post: [ View ]
17th December 2011, 09:39 PM   |  #2  
eoghan2t7's Avatar
Recognized Contributor
Flag Belfast
Thanks Meter: 2,156
 
4,190 posts
Join Date:Joined: Jan 2011
Donate to Me
More
I'm currently working on the same thing but we will need to compile it from source to get the gpu and radios to work correctly but I wont no until I get my port to boot correctly

Sent from my HTC Wildfire S using xda premium
The Following 4 Users Say Thank You to eoghan2t7 For This Useful Post: [ View ]
17th December 2011, 09:42 PM   |  #3  
benjamingwynn's Avatar
OP Recognized Contributor / Recognized Developer
Flag Cardiff
Thanks Meter: 2,387
 
2,514 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Quote:
Originally Posted by eoghan2t7

I'm currently working on the same thing but we will need to compile it from source to get the gpu and radios to work correctly but I wont no until I get my port to boot correctly

Sent from my HTC Wildfire S using xda premium

Great minds think alike I just thought I would post this so people knew that at least one person was working on this. I do need a solution to my problem however.
The Following 2 Users Say Thank You to benjamingwynn For This Useful Post: [ View ]
17th December 2011, 10:31 PM   |  #4  
Member
Thanks Meter: 24
 
75 posts
Join Date:Joined: Oct 2011
Hello , i just want to thank you all for what you are doing . Really appresiate it . Thanks A LOT for helping us( WFS user) have better experience .
17th December 2011, 11:37 PM   |  #5  
eoghan2t7's Avatar
Recognized Contributor
Flag Belfast
Thanks Meter: 2,156
 
4,190 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by benjamingwynn

Great minds think alike I just thought I would post this so people knew that at least one person was working on this. I do need a solution to my problem however.

Did you replace the ram disk?

Sent from my HTC Wildfire S using xda premium
18th December 2011, 12:05 AM   |  #6  
*se-nsei.'s Avatar
Senior Member
Flag London
Thanks Meter: 499
 
922 posts
Join Date:Joined: Sep 2011
More
Alquez managed to boot ICS on the WFS a few weeks ago. Here's the posts in case you didn't see them.

Quote:
Originally Posted by alquez


Guess what just booted. Touchscreen not working properly


Quote:
Originally Posted by alquez

i just grabbed Aria rom to test if could be booted. Looks like it can This means ICS port is definitely possible, and it's a matter of time.
http://forum.xda-developers.com/show....php?t=1368952
Now let's get back to CM7 port and cleaning up kernel sources. I have marvelc and marvelct devices to add.
OT: Reading this makes me feel nostalgic http://forum.xda-developers.com/show....php?t=1172748

18th December 2011, 01:30 AM   |  #7  
benjamingwynn's Avatar
OP Recognized Contributor / Recognized Developer
Flag Cardiff
Thanks Meter: 2,387
 
2,514 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Quote:
Originally Posted by *se-nsei.

Alquez managed to boot ICS on the WFS a few weeks ago. Here's the posts in case you didn't see them.

I saw this and I thought I could edit this with cm7 stuff. I can't. It just boot loops
18th December 2011, 01:32 AM   |  #8  
benjamingwynn's Avatar
OP Recognized Contributor / Recognized Developer
Flag Cardiff
Thanks Meter: 2,387
 
2,514 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Quote:
Originally Posted by eoghan2t7

Did you replace the ram disk?

Sent from my HTC Wildfire S using xda premium

Sorry, I've never really built a non-sense ROM before. I normally just add apps and change settings! Help me if you can to make this port possible

I may be a noob but I'm always up for a challenge.
Last edited by benjamingwynn; 2nd January 2012 at 01:00 AM.
18th December 2011, 02:14 AM   |  #9  
Member
Flag Hong Kong
Thanks Meter: 57
 
68 posts
Join Date:Joined: Nov 2010
Maybe we can ask developers in x8 or galaxy ace for help. They got an alpha version of ics.

Sent from my HTC Wildfire S A510e using XDA App
Last edited by Anthony3h18; 18th December 2011 at 03:30 AM.
18th December 2011, 02:57 AM   |  #10  
benjamingwynn's Avatar
OP Recognized Contributor / Recognized Developer
Flag Cardiff
Thanks Meter: 2,387
 
2,514 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Quote:
Originally Posted by Anthony3h18

Maybe we cab ask developers in x8 or galaxy ace for help. They got an alpha version of ics.

Sent from my HTC Wildfire S A510e using XDA App

Not a bad idea... But alquez has already booted it and the secrets appear to be locked in his mind!

Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes