5,814,797 Members 51,203 Now Online
XDA Developers Android and Mobile Development Forum

HowTo: Milestone X2 - 2.3.6 Root - UPDATED 09/05/2012

Tip us?
 
clcrawl
Old
(Last edited by clcrawl; 6th September 2012 at 12:14 AM.)
#1  
Member - OP
Thanks Meter 22
Posts: 93
Join Date: Dec 2011
Default HowTo: Milestone X2 - 2.3.6 Root - UPDATED 09/05/2012

This walks through the process of rooting a Motorola Milestone X2 running 2.3.6. First off I DID NOT come up with this solution nor did I initially post this in this thread. Many many MANY thanks to all those helped make this a reality (which seem to be Brandon15811, the2dcour, and eval-!) and to Sippi4x4man who posted this information here along with DarkFalconX who posted an addendum to help get it working, and to Tiso who made me aware someone had posted this in the thread. See the bottom for the original links that were posted.

This is the process I used it is slightly different than Dark's and the original link. The standard warning applies here, NEITHER MYSELF NOR ANYONE ELSE IS RESPONSIBLE IF YOU BRICK YOUR PHONE DOING THIS!

PREREQUISITES
  • You MUST have the ADB drivers for your phone installed which are obtained as part of the Android SDK.
  • You MUST have USB Debugging enabled on your phone.
  • You MUST have Superuser installed, which can be found on the Market.

PROCESS
  1. Download the following file (atrix-4g-moto-fastboot-win32.zip): LINK
  2. Extract the zip file to a location that is easy to get to, the original instructions suggested making a Root folder in C:\, however it is really up to you. Just make sure all the files are extracted to the same folder.
  3. Get your phone into Fastboot mode, to do this:
    • Shut the phone off.
    • Hold down the Volume Down Button while pressing the Power Button.
    • After the phone turns on you should see Fastboot at the top of the screen.
    • Press the Volume Up Button to enter Fastboot mode. Your computer may need to install drivers if this is the first time you entered Fastboot mode, so let this happen BEFORE proceeding.
  4. Start a command prompt on your computer.
  5. Type the following commands:
    • cd \<DIRECTORY> where <DIRECTORY> is the folder you created. If you created the Root folder in C:\ it would be cd \root.
    • moto-fastboot flash preinstall preinstall.img
    • moto-fastboot reboot
  6. Wait for the phone to reboot, once it does so execute the following commands (in the command prompt you should still have open):
    • adb shell
    • /preinstall/su
  7. On your phone you should see a prompt to Allow or Deny Superuser access, allow this. Then execute the following commands (in the command prompt you should still have open)
    • mount -o rw,remount -t ext3 /dev/block/mmcblk0p12 /system
    • cp /preinstall/su /system/bin/su
    • chmod 6755 /system/bin/su

Initial links Posted by Sippi4x4man
http://www.xda-developers.com/androi...orola-atrix-2/
http://briefmobile.com/motorola-atrix-4g-root

Closing
I have to again thank everyone who created this process and who made people aware of this. I take ZERO credit I am simply reposting information others have already posted. Have fun!

UPDATES
09/04/2012 - The links for the files were broken, the files needed to root the Atrix 4G are the same as we need so I have updated the link to those used for that, along with tweaking the instructions a bit to match. Thanks to Carl Parker and this post here for the working link. Do not worry that the files are labeled "for" the Atrix 4G, the files do in fact work for rooting the Milestone X2 I just used them successfully.

09/05/2012 - I modified the instructions to flash preinstall.img versus root.img, thanks to aldude999 and sd_shadow for pointing out the error as well as sd_shadow for the new link.
The Following 11 Users Say Thank You to clcrawl For This Useful Post: [ Click to Expand ]
 
clcrawl
Old
#2  
Member - OP
Thanks Meter 22
Posts: 93
Join Date: Dec 2011
I also need to make sure I give credit where credit is due, skwoodwiva and mastafunk have been extremely helpful in trying to figure out a solution for my phone. I can't thank you guys enough, I apologize in the fact that I didn't see the personal messages before I let my phone update OTA to 2.3.6. If anything I hope if I can provide the OTA update I can help the community figure some stuff out as frankly I don't have the knowledge. Thanks again guys.
 
twobrare
Old
(Last edited by twobrare; 22nd December 2011 at 04:03 AM.)
#3  
Senior Member
Thanks Meter 28
Posts: 163
Join Date: Dec 2011
Default HELP!!!

The same thing happened to my provider. I got a 2.3.6 up date and I was thinking as it was downloading.... crap I am not going to have root access. I have tried several ways. I have tried Superoneclick, the zerg method and I have also tried some other odd ways. PLEASE HELP US FIGURE THIS OUT!!!!! Maybe this will help with other problems with some of the roms I also wanted to add that I have the SBF and I tried to go back to 2.3.5 and it fails. Which means I am stuck with 2.3.6 >.< ANGRY MOOGLE.... ANGGGEERRRR Motorola unlock your bootloader!!!
 
skwoodwiva
Old
(Last edited by skwoodwiva; 22nd December 2011 at 06:01 AM.)
#4  
Senior Member
Thanks Meter 181
Posts: 1,156
Join Date: Apr 2011

 
DONATE TO ME
Sorry for the bad news. I do wish voodoo rootkeeper was was given more credit in this forum as it may have saved you in spite of it's (TO BE NOTED) problems with one custom rom, eclipse. Thanks for the recognition

---------- Post added at 10:33 PM ---------- Previous post was at 09:56 PM ----------

Did the ud negotiation give an option to dl only? tw... where did you get the sbf? Care to post it? Also give details about the rsd failure I assume you used rsd mode down rocker up rocker...

---------- Post added at 11:16 PM ---------- Previous post was at 10:33 PM ----------

Clcrawl so you saved the ota while still on 235. Drama! Man. Post it or send it to me. Change the .zip to mp3 if you have trouble on phone, boat and es file expl used to work w/ multiupload. My last ota ul would not w/ those so I opera'ed a mp3.
 
twobrare
Old
#5  
Senior Member
Thanks Meter 28
Posts: 163
Join Date: Dec 2011
i can not post the sbg . It is from ntelos. It has the 2.3.5 build from Daytona. Bassically what happens the phone I phone freezes when I try to reload the sbf. Then rsd fails. I do put the phone in RSd mode and then connect it. Is there something I am missing?
 
skwoodwiva
Old
#6  
Senior Member
Thanks Meter 181
Posts: 1,156
Join Date: Apr 2011

 
DONATE TO ME
Development forum top sticky sbf tutorial
 
ashclepdia
Old
#7  
ashclepdia's Avatar
Senior Member
Thanks Meter 1,524
Posts: 4,385
Join Date: Aug 2011
Location: under philadelphia above Delaware, beer heaven

 
DONATE TO ME
The problem with OTA root keeper it's that apparently it doesn't place superuser apk back into system properly. So when we all tried to flash eclipse it couldn't set permission correctly inn superuser apk.
it wasn't allowing the system to write to the root files of the ROM.
so basically it blocked itself.
((ooh....and I didn't figure this out lol....me an nitro had a conversation bout it....he figured out I believe while trying to mess with three razr and it's OTA update)
Off topic gone??? Mods got you down??? Visit motcher41's
Google+ Droid Friends & General Help Community
Anyone and virtually anything welcome there!
My GALAXY NEXUS(huzzah!) is running

Don't get left in the dark!
 
skwoodwiva
Old
(Last edited by skwoodwiva; 22nd December 2011 at 02:39 PM.)
#8  
Senior Member
Thanks Meter 181
Posts: 1,156
Join Date: Apr 2011

 
DONATE TO ME
Which roms are effected?
 
ashclepdia
Old
(Last edited by ashclepdia; 22nd December 2011 at 02:46 PM.)
#9  
ashclepdia's Avatar
Senior Member
Thanks Meter 1,524
Posts: 4,385
Join Date: Aug 2011
Location: under philadelphia above Delaware, beer heaven

 
DONATE TO ME
Quote:
Originally Posted by skwoodwiva View Post
Which roms are effected?
Pretty sure all of them.
Since don't they all include superuser apk and binaries in the updater scripts?

A work around would be to remove superuser things from the script and then after ROM install use root keeper again to restore superuser.
Easier to just use zergrush IMO

That is at least until we run of ways to obtain root on OTA lol
Off topic gone??? Mods got you down??? Visit motcher41's
Google+ Droid Friends & General Help Community
Anyone and virtually anything welcome there!
My GALAXY NEXUS(huzzah!) is running

Don't get left in the dark!
 
lordforex
Old
#10  
lordforex's Avatar
Senior Member
Thanks Meter 20
Posts: 154
Join Date: Aug 2011
Whoa....... wait.. there is a X2 2.3.6 OTA dropping down?!?
Droid X2 running Eclipse 2.3

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes