Post Reply

Root Huawei Mercury (M886)

OP NeoZiggy

26th December 2011, 10:22 AM   |  #1  
NeoZiggy's Avatar
OP Junior Member
Flag San Antonio, TX
Thanks Meter: 4
 
15 posts
Join Date:Joined: Jan 2011
More
All credit goes to Tilbert at UnleashedPrepaids.com for finding how to root the Mercury, and Salas from CricketUsers.com for posting this information.

I thought this should be posted on this site, as it is the main site I go to for everything Android. The Mercury is the newest Android from Cricket and is worth talking about since it has a 1.4GHz Snapdragon CPU, FFC, 8MP camera with LED flash, HD video recording, and a 4" FWVGA capacitive touch-screen. I also think that there should be a forum created for this phone.


MAKE SURE YOU READ ALL THE STEPS BEFORE STARTING!! Additional setups may be required!!
I AM NOT RESPONSIBLE FOR YOU MESSING UP YOUR PHONE BY FOLLOWING THESE INSTRUCTIONS!!!
If your not comfortable with the procedure then don't do it!!!
I'm sure it won't be long before someone smarter than me figures out a one-click method for root.

1. First download su, busybox and Superuser.apk
mediafire.com/?or723znkep9s3o3

2. Use ADB to push these 3 files to /data/local/tmp

3. In ADB shell:
$ chmod 6755 /data/local/tmp/su
$ chmod 755 /data/local/tmp/busybox
$ chmod 644 /data/local/tmp/Superuser.apk

4. Shut down phone with the power button/menu.

5. Holding the Vol+ AND Vol- AND Power together when the phone is off will put the phone into a mode that gives you a BRIGHT purple screen....
this is good! Nothing should be happening, just a static purple screen.

6. THIS NEXT STEP HAS TO BE DONE FROM A LINUX DISTRO!
Plug the phone into the computer through USB and you will notice that you can access all of the partitions of the phone with full R/W.
Browse to /data/local/tmp and move su and busybox to /system/bin/
Move Superuser.apk to /system/app/

7. Unplug the phone from USB.

8. Pull the battery out, put it back in, boot the phone normally and ENJOY YOUR NEWLY ROOTED MERCURY!!!

Some notes:
Superuser.apk will need to be updated (found on market).
From inside the Superuser app: update the su binary's.
Download the BusyBox installer from the market and update busybox to the latest version.
Last edited by NeoZiggy; 26th December 2011 at 10:43 AM.
The Following 3 Users Say Thank You to NeoZiggy For This Useful Post: [ View ]
22nd December 2012, 05:00 PM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2010
thanks, I've tried that (just that I did a "su" in ubuntu and then used mv command instead of nautilus) but then it didn't work and I found out that I had no /system/bin folder and the su file was moved as file /system/bin (file not directory). I don't think I removed the folders...

Has anyone else missing the /system/bin and /system/app folders? the phone works fine otherwise. I created the folders and redid the steps but it still doesn't work
22nd December 2012, 08:02 PM   |  #3  
Senior Member
Thanks Meter: 32
 
138 posts
Join Date:Joined: Aug 2011
More
I hate to direct you to another forum but since there is almost no Merc activity here I guess it's okay

http://www.cricketusers.com/showthread.php?t=29050

Sent from my M886 using Tapatalk 2
Last edited by burdman; 22nd December 2012 at 09:40 PM.
26th October 2013, 06:37 AM   |  #4  
Senior Member
Flag Austin, Texas
Thanks Meter: 37
 
134 posts
Join Date:Joined: Feb 2012
Donate to Me
More
Don't you need to change the permissions also before you reboot? Since Linux is very secure about permissions and all. Just a thought... I am gonna try it and post back. I just scored this phone for some work that I did. I gave it to my son, but I always root my devices, etc.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Android Software and Hacking General [Developers Only] by ThreadRank