FORUMS

XeroAsh Theme for CM12

This theme by XDA Senior Member balrajs99 features a black and slate gray UI that gives your phone a … more

Samsung Galaxy S6 To Receive Major Camera Update

When the Samsung Galaxy S6 and S6 Edge were launched, they became the prime focus for … more

Tactile: An Addicting Game with Beautiful Material Design

The game industry has been around for decades, catering to a wide … more

Android’s Consistency and The User Experience

This is a site of power users, and it is fair to say that most of us are more … more
Post Reply Subscribe to Thread Email Thread

[FIX] [DRIVER] Kernel Module Pack V4

31st January 2012, 03:52 PM |#31  
Dhyneland's Avatar
Senior Member
Flag Kansas City, Mo
Thanks Meter: 57
 
More
Quote:
Originally Posted by saturn_de

I said PC/Laptop with Linux... not on the ATP.

Crap.. My fault.. I will have to when I get home from work. Thanks!

EDIT: Files Attached
Attached Files
File Type: txt dmesg.txt - [Click for QR Code] (757 Bytes, 27 views)
File Type: txt lsmod.txt - [Click for QR Code] (2.6 KB, 27 views)
File Type: txt lsusb.txt - [Click for QR Code] (302 Bytes, 18 views)
Last edited by Dhyneland; 31st January 2012 at 11:29 PM. Reason: adding files
 
 
1st February 2012, 04:06 PM |#32  
saturn_de's Avatar
OP Senior Member
Thanks Meter: 162
 
Donate to Me
More
Put all modules in an app for easy installation and activation..

http://forum.xda-developers.com/show....php?t=1473520
3rd February 2012, 05:49 PM |#33  
Senior Member
Thanks Meter: 36
 
More
so no reply to my request?
4th February 2012, 03:32 PM |#34  
Dhyneland's Avatar
Senior Member
Flag Kansas City, Mo
Thanks Meter: 57
 
More
I have compiled some modules according to your instructions in the OP. But I am getting an error when trying to apply them.

Code:
$ su
# cd /data/local/modules/
# ls
snd-hrtimer.ko 
snd-hwdep.ko 
snd-mixer-oss.ko 
snd-page-alloc.ko 
snd-pcm-oss.ko 
snd-pcm.ko 
snd-rawmidi.ko
snd-seq-device.ko
snd-seq-dummy.ko
snd-seq-midi-event.ko
snd-seq-midi.ko
snd-seq.ko
snd-timer.ko
snd-usb-audio.ko
snd-usbmidi-lib.ko
snd.ko
usbhid.ko
# insmod snd-usb-audio.ko
insmod: init_module 'snd-usb-audio.ko' failed (No such file or directory)
What am I doing wrong here? Any tips/tricks/guides? Thanks!
Attached Files
File Type: txt config.txt - [Click for QR Code] (78.1 KB, 14 views)
5th February 2012, 02:49 PM |#35  
saturn_de's Avatar
OP Senior Member
Thanks Meter: 162
 
Donate to Me
More
Quote:
Originally Posted by Nico^APEX

I have compiled some modules according to your instructions in the OP. But I am getting an error when trying to apply them.

Code:
$ su
# cd /data/local/modules/
# ls
snd-hrtimer.ko 
snd-hwdep.ko 
snd-mixer-oss.ko 
snd-page-alloc.ko 
snd-pcm-oss.ko 
snd-pcm.ko 
snd-rawmidi.ko
snd-seq-device.ko
snd-seq-dummy.ko
snd-seq-midi-event.ko
snd-seq-midi.ko
snd-seq.ko
snd-timer.ko
snd-usb-audio.ko
snd-usbmidi-lib.ko
snd.ko
usbhid.ko
# insmod snd-usb-audio.ko
insmod: init_module 'snd-usb-audio.ko' failed (No such file or directory)
What am I doing wrong here? Any tips/tricks/guides? Thanks!

You have to take the original ASUS config and start from there and the limitation is, that with "make menuconfig" you are only allowed to switch on modules and not change from "compiled in" to "module". You only can add "M" (modules) and not change what is compiled in.
The Following User Says Thank You to saturn_de For This Useful Post: [ View ]
5th February 2012, 09:44 PM |#36  
Senior Member
Thanks Meter: 8
 
More
i cant seem to get this working.. im not too experienced with this sort of thing, but this is what im doing
- place the .ko files in the /data/local/modules folder
- open Terminal Emulator
- type 'su' -> 'cd /data/local/modules' -> 'insmod cfq-iosched.ko'
- but i get the message 'insmod: can't open 'cfq-iosched.ko'' when i do so

am i doing something wrong? (yes i am rooted)
5th February 2012, 09:56 PM |#37  
mdalacu's Avatar
Senior Member
Flag Bucharest
Thanks Meter: 194
 
Donate to Me
More
I can't mount anything from network shares using cifs.ko. I always am getting "invalid argument" in terminal emulator , also in cifs manager.

What am i doing wrong?
$su
#cd /data/local/modules
#insmod cifs.ko
#mount -t cifs -o guest //192.168.0.100/MyShare /mnt/cifs/MyShare #the folder exists

On other devices i had to insert slow-work.ko module for cifs to work, is it necessary here?
Thank you
6th February 2012, 05:06 AM |#38  
Junior Member
Thanks Meter: 1
 
More
You need to use 'busybox mount -t cifs...'.

Before mount, you also need 'insmod md4.ko'.
6th February 2012, 09:39 PM |#39  
mdalacu's Avatar
Senior Member
Flag Bucharest
Thanks Meter: 194
 
Donate to Me
More
Sorry, but still does not work. I have also inserted md4.ko and no change, 'invalid argument'.
Can you post the entire sequence of commands, to mount a share.
Thank you.
7th February 2012, 04:37 AM |#40  
Junior Member
Thanks Meter: 1
 
More
I retested. These are the commands work for me...

su
cd /system/lib/modules
insmod md4.ko
insmod cifs.ko
lsmod # make sure md4.ko cifs.ko loaded
mount -t cifs -o username=me,password=xxx //10.10.10.1/movies /mnt/cifs/movies

It is Kindle Fire's mount that does not support -t cifs, so busybox is not necessary with TP's mount. Look like it was your '-o guest' that needed to be '-o username=guest'.
The Following User Says Thank You to kachun For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
ipsec, joystick, logitech, module, vpn
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes