Post Reply

[MOD] 3 CDMA mods updated 7/11/12

26th January 2012, 09:48 PM   |  #1  
motcher41's Avatar
OP Senior Member
Flag Brainerd, Minnesota
Thanks Meter: 1,276
 
3,408 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Disclaimer: I am not responsible with what you do with your phone or anything that results from my edit/mods.

Nandroid Backup! Its your friend!

READ ENTIRE POST

Mention what rom and mods u used with results in a post please!

**If you flashed mashup and miss your data speed you need to redo mod 1**

One user that was plauged with switch to 1x being reported it being eliminated by the mods

Confirmed working on MIUI, eclipse 1.2 & 2.0.3, stock 2.3.4 and CM7

Mod 1 "may" work on any other 3G phones, mod 2 when posted "may" work on other 3G MOTO phones.

-----------------------------------------------------------------------------------------------------------------------
Mod 1

The Problem:
Since I do not have internet at home and I live in a poor service area any increase in 3G data speeds I can get is beneficial. So, I started looking into a way to increase my 3G data speeds.
Please let me know what rom you are using when you post something

Note: The first boot I did on some of these took a few minutes for 3G to first come up. Any reboots later it showed up immediately. I had no service issue and triangle once or twice while I was checking all of these. Reboot always fixed it.

The Solution:

First, nandroid backup prior to changing anything on your phone is a good policy to follow.

Most of the build.prop edits I’ve found are for GSM phones. I did find one thing that might help. I have confirmation from another source this hack works for them as well.

The line to be edited in build.prop which is in your /system/ folder by root explorer, root browser or any other editor/method of choice (make sure you backup your build.prop first):

Code:
persist.ril.uart.flowctrl=1
Change the “1” to “10”, save your build.prop, and reboot.

You can change the 1 to 1-10 and null or blank.


These are my results below in kb/s.

1=baseline 75-100 kb/s

0= no service – Don’t do this!
2-5 = 100 kb/s with some temp increases
6-9 = 150-200 kb/s
10 = 250-350 kb/s

A null value gives me 150-300 kb/s with large fluctuations.

I found that “10” gave me the best speed with most consistent results.

These speeds were clocked in actual large file downloads not a speed testing app.
I found that speed testing apps do not give accurate results. The real downloading gives real results.

Note: With this a tester was getting 500kb/s downloading a rom over 3G.

Please reply back with any results you find as I am looking for conformation of my findings.

If you try this in a different ROM please let me know your findings as well. This SHOULD work in any rooted X2.

Doesn't work on liberty for the moment. Gonna attempt it on fully stock liberty soon

Thanks to MoonShadow-NM for his assistance with the write up
----------------------------------------------------------------------------------------------------------------
Mod 2 - Can be used along with Mod1
Atrix lib replacement mod

This mod I found helped with increasing data speeds in my poor service location as well as an increase in speed in a good service location

Signal at a horrible -102 dBm I was getting a consistant 200kb/s download where I only had 100kb/s before using this in conjunction with mod 1 at a value of 10

Signal at a nice -62 dBm I got a nice 400-500kbs consistant download speed where I only had 250-300kb/s before using this in conjunction with mod 1 at a value of 10
Note: You may see a better increase as I am a huge data user and subject to network optimization by evil red.

This mod at my house also stopped my phone from jumping between two towers. One with a -130 signal and the better with a -102.

The attached file is an Atrix lib_motoril.so file. It is a different file from our stock blur file. It is about 50kb smaller in size then any X2 blurbased non-port rom file I found. It was given to me to try by a Alien port user after talking with him about his nice data speeds and connections prior to any modifications.

This is a fairly easy file swapping mod.

Download the attached atrix lib and extract wherever you want.

Navigate to the /system/lib/ folder in a file manager of choice and either backup by placing a .bak after the .so of the original libmoto_ril.so file.

Go to where you extracted the Atrix lib file. Copy and paste that file to your /system/lib folder and then set permissions to the rw-r--r-- for it..

Reboot and let me know if you had the same good results as me.

Thanks to kinevil for the atrix lib and idea to try this file!


I make sure BSR is installed before I try anything so I can do a battery pull and get into BSR. Wipe cache and dalvik if any issues come up first then you can always nandroid after that if needed.
-----------------------------------------------------------------------------------------------------------------

Mod 3 - May help with connection stability. Not speed.

Easy build.prop addtion

In a fike manager such as root browser and root manager got to /system/ and open your build.prop to edit.
Add the following line.

Code:
ro.mot.eri.losalert.delay=
The standard mod for this us 1000. Feel free to play around with it. Please post your results.

Happy modding!
Attached Files
File Type: zip Atrix libmoto_ril.zip - [Click for QR Code] (122.2 KB, 3540 views)
Last edited by motcher41; 16th July 2012 at 09:57 PM.
The Following 42 Users Say Thank You to motcher41 For This Useful Post: [ View ]
26th January 2012, 10:10 PM   |  #2  
UbuntuBrandon's Avatar
Member
Flag Augusta
Thanks Meter: 20
 
73 posts
Join Date:Joined: Nov 2011
More
Confirmed not working on MIUI. Causes data refusal, and system force close.
26th January 2012, 10:19 PM   |  #3  
Senior Member
Thanks Meter: 23
 
118 posts
Join Date:Joined: Apr 2011
Worked for me, doubled the speed. Thanks for the tip!

Sent from my MB870 using xda premium
26th January 2012, 10:24 PM   |  #4  
motcher41's Avatar
OP Senior Member
Flag Brainerd, Minnesota
Thanks Meter: 1,276
 
3,408 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Quote:
Originally Posted by lbroksle

Worked for me, doubled the speed. Thanks for the tip!

Sent from my MB870 using xda premium

Thanks for letting me know.

Sent from my Cyanocrack using Xparent Blue Tapatalk
The Following User Says Thank You to motcher41 For This Useful Post: [ View ]
26th January 2012, 10:25 PM   |  #5  
Senior Member
Thanks Meter: 15
 
274 posts
Join Date:Joined: Oct 2011
Below are my results using speedtest:

Before mod/reboot: .50 down. .55 up
1 min after mod/reboot: .70 down. .14 up
6 min after mod/reboot: 1.13 down. .52 up

So it seems better. Not sure on the fluctuations after mod though. I'm sitting at my desk at work and haven't moved and all this was completed in a 10 min window. Thoughts?

Stock ROM, 2.3.4, rooted, build.prop mashup v5b

Sent from my DROID X2 using Tapatalk
Last edited by viskey; 26th January 2012 at 10:27 PM.
26th January 2012, 10:26 PM   |  #6  
motcher41's Avatar
OP Senior Member
Flag Brainerd, Minnesota
Thanks Meter: 1,276
 
3,408 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Quote:
Originally Posted by viskey

Below are my results using speedtest:

Before mod/reboot: .50 down. .55 up
1 min after mod/reboot: .70 down. .14 up
6 min after mod/reboot: 1.13 down. .52 up

So it seems better. Not sure on the fluctuations after mod though. I'm sitting at my desk at work and haven't moved and all this was completed in a 10 min window. Thoughts?

Sent from my DROID X2 using Tapatalk

Use a real download from the web and watch it. This app works well to watch download rate https://market.android.com/details?i...afficIndicator

Looks to me like it doubled what's your app says on a before and after

Sent from my Cyanocrack using Xparent Blue Tapatalk
Last edited by motcher41; 26th January 2012 at 11:40 PM.
The Following 3 Users Say Thank You to motcher41 For This Useful Post: [ View ]
26th January 2012, 10:45 PM   |  #7  
maggard5's Avatar
Senior Member
Thanks Meter: 72
 
239 posts
Join Date:Joined: Dec 2011
This mod crashed my service. After rebooting, I received the triangle and dialed *228 and *22899 with no luck. It failed to activate and update my phone and gave me a "no network" message.

Reset value and phone works again.

Update: Went back and reread OP just to make sure. Noticed 0 was no service and thought I'd better try again just to make sure. Set value to 10 and had the same result. Set value to 9 and it worked. So tried 10 again and it worked. Not sure why but...
Last edited by maggard5; 26th January 2012 at 10:59 PM.
The Following User Says Thank You to maggard5 For This Useful Post: [ View ]
26th January 2012, 10:48 PM   |  #8  
Elite49's Avatar
Senior Member
Thanks Meter: 58
 
735 posts
Join Date:Joined: Jul 2011
More
Changed it on Eclipse 1.2 with everything listed in my sig. No clue if its actually helping since I'm downloading a 9 MB update from the App Store and its going at 20 - 25 Kbps.

Edit: Testing with the Speed Test app getting just 400 Kbps instead of what you stated the usual 1200 - 2000. Websites seem the same but downloads are worse. Will keep using it for a day or so but every other 3G boost mod had never worked or made it worse on my phone. Especially 3G Turbo Booster.
Last edited by Elite49; 26th January 2012 at 11:16 PM.
26th January 2012, 11:06 PM   |  #9  
Senior Member
Down South were we drink beer not water and southern comfort not pepsi.
Thanks Meter: 13
 
126 posts
Join Date:Joined: Oct 2011
More
Tried this on CM7 lost data connectin and had the roaming triangle. After several reboots and *228 2 it Finally came up. Im not noticing a huge difference yet, but I believe Im be throttled like crazy now. I'll know for sure if it make a difference when I get home.

Edit

Im seeing the difference now, and yep it is faster.
Last edited by pacman377; 26th January 2012 at 11:30 PM.
The Following User Says Thank You to pacman377 For This Useful Post: [ View ]
26th January 2012, 11:30 PM   |  #10  
motcher41's Avatar
OP Senior Member
Flag Brainerd, Minnesota
Thanks Meter: 1,276
 
3,408 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Quote:
Originally Posted by Elite49

Changed it on Eclipse 1.2 with everything listed in my sig. No clue if its actually helping since I'm downloading a 9 MB update from the App Store and its going at 20 - 25 Kbps.

Edit: Testing with the Speed Test app getting just 400 Kbps instead of what you stated the usual 1200 - 2000. Websites seem the same but downloads are worse. Will keep using it for a day or so but every other 3G boost mod had never worked or made it worse on my phone. Especially 3G Turbo Booster.

3 g turbo is made for gsm. They're all gsm settings as best I can tell


Sent from my Cyanocrack using Xparent Blue Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes