5,603,591 Members 36,009 Now Online
XDA Developers Android and Mobile Development Forum

Fix for bricked nooks from CM7 "formatted sd"

Tip us?
 
Indirect
Old
(Last edited by Indirect; 5th February 2012 at 09:26 PM.)
#1  
Recognized Contributor - OP
Thanks Meter 2940
Posts: 2,317
Join Date: Mar 2011
Location: Florida

 
DONATE TO ME
Default Fix for bricked nooks from CM7 "formatted sd"

for this fix, you will need to have a CWM sdcard ready and waiting followed by and drivers properly installed for your tablet.

YOU MUST have CWM running from sdcard to fix this issue. Otherwise nothing will happen.
instructions to install to sdcard are here (I suggest using windows)

Needed files for download:
just download this zip and run the script while booted into cwm from sdcard.
download it here.

Instructions: Boot from sd (don't worry, it will work), ensure sdcard is mounted, and then you just run the fix.bat from the computer after extracting.

Credits: Succulent for the xloader image
Fattire for the idea that it might have formatted mmcblk0p1 (which it dead instead of mmc1)



My Google Plus account
My Twitter
Shiftless evo shift developer
Nook Tablet developer-found root (here)

Quote:
Without developers this place would not be called XDA-Developers but something else, e.g Mobile Phone User Support Services For Ungrateful Nerds.
Developed on the following devices: Evo View, Nook Tablet, Evo Shift, Nexus S 4G (private), Evo 4G (private), Mytouch 4g Slide, Evo LTE, HTC One (In Progress), Moto X
The Following 8 Users Say Thank You to Indirect For This Useful Post: [ Click to Expand ]
 
fattire
Old
(Last edited by fattire; 5th February 2012 at 09:24 PM.)
#2  
fattire's Avatar
Recognized Developer
Thanks Meter 4371
Posts: 1,517
Join Date: Oct 2010
You're welcome.

Might want to add that the cause of the "brick" appears to be that CM7 is confusing mmc1 and mmc0 and instead of wiping the first partition of the SD card, it's presumably wiping the first partition of the emmc, which contains the x-loader.
The Following 8 Users Say Thank You to fattire For This Useful Post: [ Click to Expand ]
 
Indirect
Old
#3  
Recognized Contributor - OP
Thanks Meter 2940
Posts: 2,317
Join Date: Mar 2011
Location: Florida

 
DONATE TO ME
I already have said it.



My Google Plus account
My Twitter
Shiftless evo shift developer
Nook Tablet developer-found root (here)

Quote:
Without developers this place would not be called XDA-Developers but something else, e.g Mobile Phone User Support Services For Ungrateful Nerds.
Developed on the following devices: Evo View, Nook Tablet, Evo Shift, Nexus S 4G (private), Evo 4G (private), Mytouch 4g Slide, Evo LTE, HTC One (In Progress), Moto X
 
fattire
Old
#4  
fattire's Avatar
Recognized Developer
Thanks Meter 4371
Posts: 1,517
Join Date: Oct 2010
Ah okay... well glad everything is fixed now.
 
CelticWebSolutions
Old
#5  
CelticWebSolutions's Avatar
Senior Member
Thanks Meter 2021
Posts: 736
Join Date: May 2011

 
DONATE TO ME
Quote:
Originally Posted by fattire View Post
You're welcome.

Might want to add that the cause of the "brick" appears to be that CM7 is confusing mmc1 and mmc0 and instead of wiping the first partition of the SD card, it's presumably wiping the first partition of the emmc, which contains the x-loader.

Bowing head in shame here...... Rookie mistake!


Looks like we have to make a bit of a tweak to the system then do some testing.
If I've helped you out, no need to post saying thanks. Just click the button to thank me.

Thank you for your donations, They'll be used towards buying another device to play with

If you'd like to donate to Team-B (Thatís Myself and Goncezilla)
 
Indirect
Old
#6  
Recognized Contributor - OP
Thanks Meter 2940
Posts: 2,317
Join Date: Mar 2011
Location: Florida

 
DONATE TO ME
New download link due to a small scripting error.



My Google Plus account
My Twitter
Shiftless evo shift developer
Nook Tablet developer-found root (here)

Quote:
Without developers this place would not be called XDA-Developers but something else, e.g Mobile Phone User Support Services For Ungrateful Nerds.
Developed on the following devices: Evo View, Nook Tablet, Evo Shift, Nexus S 4G (private), Evo 4G (private), Mytouch 4g Slide, Evo LTE, HTC One (In Progress), Moto X
The Following 2 Users Say Thank You to Indirect For This Useful Post: [ Click to Expand ]
 
Fatos
Old
#7  
Member
Thanks Meter 30
Posts: 91
Join Date: Nov 2011
Default Need help

Hi Indirect. I see that you have fixed your NT. I did not use sd i did install cm7 internally but i did format all the mounts . And now it just restarts in CWM. What should i do. Any idea please
 
scsione889
Old
(Last edited by scsione889; 5th February 2012 at 11:37 PM.)
#8  
scsione889's Avatar
Senior Member
Thanks Meter 150
Posts: 110
Join Date: Aug 2010
Location: Chicago-ish

 
DONATE TO ME
Well guys, I'm still having problems. I ran the brick fix before you updated it - didn't work. I then re-ran after you updated it - still didn't work. It'll boot to CWM from SD, but won't boot to any ROM. Tried re-installing CM7 (didn't work), then I tried the Nook141root.zip which supposedly installs the BN 1.4.1 from CWM (also didn't work). Tried re-running the brick fix a handful of times after and before installing each ROM with no luck. Then I tried running it without installing a ROM. Tried the brick fix then I tried the BN 1.4.0 restore file. I tried on multiple freshly formatted SD cards and I even tried on a computer I was working on with a fresh install of Win7 with a fresh install of the drivers just to rule that out.

Before all this I had CWM and CM7 installed internally - if that makes a difference. Ideas?

Edit: More info. When trying to wipe data/factory reset in CWM I get the errror "E:format_volume: make_ext4fs failed on /dev/block/mmcblk1p2"...this occurs right after rebooting from the brick fix.

Edit 2: More info yet...in the brick fix I'm getting the text "error: device not found" twice right after entering "y" then again a handful of times later. Is there anything special I have to do in CWM to get it to detect it? I have sdcard mounted...
HTC Droid Incredible 2
S-OFF, CM7

Nook Tablet
CM7 Alpha 1
 
Fatos
Old
#9  
Member
Thanks Meter 30
Posts: 91
Join Date: Nov 2011
Im geting this and then my nt restarts by itself and then im back in cwm again so nothing is fixed.
Attached Thumbnails
Click image for larger version

Name:	nook.jpg
Views:	421
Size:	69.9 KB
ID:	889198  
 
scsione889
Old
#10  
scsione889's Avatar
Senior Member
Thanks Meter 150
Posts: 110
Join Date: Aug 2010
Location: Chicago-ish

 
DONATE TO ME
Quote:
Originally Posted by Fatos View Post
Im geting this and then my nt restarts by itself and then im back in cwm again so nothing is fixed.
What do you have mounted to get it the fix to detect the tablet? Does it matter?
HTC Droid Incredible 2
S-OFF, CM7

Nook Tablet
CM7 Alpha 1

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes