Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,635 Members 38,712 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] EU GT-P1000 w/ CM9 RC0: "Signature verification failed"

Tip us?
 
knowledgeworker
Old
(Last edited by knowledgeworker; 14th February 2012 at 03:50 PM.) Reason: solved
#1  
knowledgeworker's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Feb 2012
Location: Seoul, Korea
Question [SOLVED] EU GT-P1000 w/ CM9 RC0: "Signature verification failed"

Dear valued Android and Samsung experts,

it is my first post in this forum. I waited until the flashable ROM etc. was released, so today I tried humbertOS' CM9 (RC0) from 02.02.2012. It is only my second time doing this, after initially upgrading von Android 2.0 or so to 2.3.3.

My Device Info (after wiping, while stuck now)
European SAMSUNG GALAXY TAB (GT-P1000)
Android 2.3.3
Current baseband version: P1000XXJPZ
Current kernel version: 2.6.35.7-se.infra@SEP-52#2
Build No : GINGERBREAD.XXJQ1
  • Rooted with Super One Click (Maybe. Can't remember anymore, but it is rooted.)
  • Installed ROM Manager Pro.
  • Backed up with TitaniumBackup (Premium I think) to my Dropbox (via Wifi). I hope that is correct this way.

I get the following error:

Quote:
Finding update package...
Opening update package...
Verifying update package...
E: Signature verification failed
Installation aborted.
What did I try to solve the issue?

I redownloaded the ROM.zip, but it didn't help. As there are no md5 hashes available (why?) for the online files, I couldn't compare if there is a problem on my download side. But I used Google Chrome, Internet Explorer 9 and jDownloader now, they can't all be faulty. Of course I re-wiped the cache every time after I had to start the phone or transfer the files!

I read 3+ threads that I found via search, but there was no solution. By the way I was unable to find this forum (Samsung Galaxy Tab) in the forum scroll-down list? Am I blind? I triple-checked! ... In one of the threads I read there I should go go back to the stock version (2.1 or so), is that true? How do I force my Tab to do so?


Now what I think could be the problem source is that I'm wondering why the path /sdcard is showing all the other folders and stuff and why before I put the files on the flash partition of the Galaxy Tab it didn't initially show up! What I try to say is: It seems to me the bootloader accesses NOT the SD-card, but the Tab's flash (all while calling it /sdcard), how can that be!
My SD card is basically empty asides of the ROM, kernel and GApps, but (how) can it even happen that the bootloader choses the internal flash over the SD card?

The last time (2.1 to 2.33) I upgraded I used Odin. This time this is not an option? I only follow the procedure you outlined and ask no questions. I mean in the other thread I read "you will need to flash via odin first because stock rom of gtp1000 have limited options in the recovery mode." (source) - well why is this then not mentioned in this thread or on humberos website? As said, I just followed the directions, thus avoided Odin this time!

And here I read a lot about "Clockwork Recovery", do I really need it? *confused* I mean I already own and payed for ROM Manager and Titanium Backup, should be fine right? I mean it is almost absurd how much I read about it...I can assure you I bought the above tools because back then those were the ones in the talk!

I also heard about "disabling of signature verification", but as it involves a lot of steps, is it really necessary?

I also read about "3e Recovery" but what is that? I would be happy if everyone could stop throwing around with abbreviations that yield no helpful Google results and instead write out and describe what tool or method they use exactly. For the above example my open question is obviously if this recovery method also applies to me with a different brand (Samsung) and model (Galaxy Tab "classic") compared to where I found this method....

Finally do I need to / should I replace my bootloader / recovery menu with another one maybe? ... In conclusion I hope you see I did my research, but there are so many ways to get a solution, so right now I simply need a hint from more experienced pro's about in which direction I have to go!

Thank you for your help in advance!
 
knowledgeworker
Old
(Last edited by knowledgeworker; 12th February 2012 at 05:13 PM.) Reason: Typo
#2  
knowledgeworker's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Feb 2012
Location: Seoul, Korea
Exclamation ClockworkMod Recovery

Ok, I noticed now my mistake probably is that I was missing an installed "ClockworkMod Recovery".

But: When I try to install CWM from within the ROM Manager (v.5.0.0.6, Premium) it only displays a choice of two models - "Samsung Epic4G" and "Samsung GalaxyS i9000" - in the list and not my model (Galaxy Tab EU) or any other model! What is going on there, why does ROM Manager Premium not display an array of other devices?

And is there any alternative way to download and install CWM on my Tab?

PS: The "Euro bootstrap recovery" app mentioned in other threads is not available anymore in the market either.
PPS: I also found this directory full of clockwork builds: http*//download.clockworkmod*com/recoveries/, which one of those would be right for the GT-P1000? The "recovery-clockwork-tab.img" & "*.zip" from 04-Jun-2011 17:37?
 
priyana
Old
#3  
Senior Member
Thanks Meter 1,257
Posts: 3,136
Join Date: Jul 2007
The commonly known method is to restock according to Overcome 4.1 rom thread
Then install overcome kernel.
That gives you cwm recovery and it also converts your filesystem to ext4.
Then flash the cm9.

Sent from my GT-P1000 using XDA App
"Use overcome method to restock your GT-P1000"
Overcome files are alive.
[ROM][2.3.6] Overcome Rom 4.1.0 new links
http://forum.xda-developers.com/show....php?t=1881981
The Following User Says Thank You to priyana For This Useful Post: [ Click to Expand ]
 
knowledgeworker
Old
(Last edited by knowledgeworker; 14th February 2012 at 01:42 AM.) Reason: Android Market
#4  
knowledgeworker's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Feb 2012
Location: Seoul, Korea
Default Thanks priyana

Thanks priyana, that hint really made it for me!

Successfully made it through!
Now only the GApps don't show up even though I installed them.
Will browse the forum here and Google for solutions...
 
priyana
Old
#5  
Senior Member
Thanks Meter 1,257
Posts: 3,136
Join Date: Jul 2007
reset to factory default and re-install gapps once more?
seems to happen now and then to some flashes
 
knowledgeworker
Old
#6  
knowledgeworker's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Feb 2012
Location: Seoul, Korea
Hey priyana, I didn't update the thread, yes I'm done with that already!

A question though: Is it normal that the internal + external storage show "as one" drive or is the SD card actually not mounting on my Windows laptop? (I assume.)

The problem is, even though I activated UMS with the toggle, I can only put the data on the "12,8 GB" drive, from which I also installed GApps.

But it seems I can't install *.apk files from this location and I also have difficulties restoring my Titanium backup files from there (I put them in the TB subfolder).

So far my progress. I only want my backup back and mount my SD card, then I'm done.
 
priyana
Old
#7  
Senior Member
Thanks Meter 1,257
Posts: 3,136
Join Date: Jul 2007
can't help you there yet. I am not yet on ICS
But in slimdizzy's latest built he confirms that both cards visible from windows.
remember one is on /sdcard (internal) and the other is /mnt/emmc (external) because that is CM standard.
One of these days I will follow you guys into ICS.
Tried once earlier before the wifi speed was fixed and didn't like it.
 
knowledgeworker
Old
#8  
knowledgeworker's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Feb 2012
Location: Seoul, Korea
I mean looking from the Windows / PC perspective.

There, I have neither of those paths. I hope that is not unusual.

Another point maybe: As I can't use Kies now, how to manage music? I succeeded in putting videos into the "video" folder, but the same doesn't work for music files (in "Music" as *.mp3 files). Probably I'm lacking the basics (I self-teach them to myself ), so a link to a tutorial about all this is more than welcome. But as said, asides from restoring my backup (I'm still looking for a solution...) and the music issue, all is fine. I even managed to install the apps from within the internal storage with the pre-installed file-manager.
 
priyana
Old
#9  
Senior Member
Thanks Meter 1,257
Posts: 3,136
Join Date: Jul 2007
Dont know much about the kies and music.
For TB, there is a setting in there for backup folder.
Have you explore the options?
I can put my my backups anywhere and point TB to it and restore.

Sent from my GT-P1000 using XDA App
"Use overcome method to restock your GT-P1000"
Overcome files are alive.
[ROM][2.3.6] Overcome Rom 4.1.0 new links
http://forum.xda-developers.com/show....php?t=1881981
 
knowledgeworker
Old
(Last edited by knowledgeworker; 14th February 2012 at 04:21 PM.) Reason: wording
#10  
knowledgeworker's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Feb 2012
Location: Seoul, Korea
Actually, now after another restart it did recognize both the music and the missing TB backup files! I'm really a bit sloppy. Now I'm actually restoring successfully.

Now I will only try to find how to remove a few apps (not selected for restore!) from the backup (job). Apps that I actually don't ever want to see on my tablet again.
I'm sure I'll be able to find out myself...

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes