Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

How to Root the Sony Tablet S

OP djrbliss

8th February 2012, 06:53 PM   |  #11  
obicom's Avatar
Senior Member
Flag Cologne
Thanks Meter: 80
 
283 posts
Join Date:Joined: Nov 2010
More
Works great ... full respect from my side .... well done ... !!

YOU ARE MY HERO !!!!
8th February 2012, 07:28 PM   |  #12  
Senior Member
Thanks Meter: 92
 
591 posts
Join Date:Joined: Jun 2010
My adb was being funky. I found a post somewhere else through Google where someone had to rename their adb.exe file to adb.exe.exe, reboot their computer, and rename the file back to adb.exe. I did this as a stab in the dark, and my command prompt suddenly began working for me. Tablet is currently rebooting for a third time. I'm keeping my fingers crossed.

EDIT: SUCCESS! Thank you, djrbliss.
Last edited by ejchis; 8th February 2012 at 07:32 PM.
8th February 2012, 07:41 PM   |  #13  
ALF@be's Avatar
Senior Member
Flag Arlon
Thanks Meter: 8
 
167 posts
Join Date:Joined: Aug 2007
More
Red face
Great, thank you for this !
8th February 2012, 07:56 PM   |  #14  
Member
Thanks Meter: 12
 
79 posts
Join Date:Joined: Dec 2010
I tried to use the exploit after a factory reset, and I can't get it to work.

Code:
F:\Desktop\Sony_Tablet_S_Root_Windows>run.bat[*][*] Sony Tablet S root script (Windows version)[*] by Dan Rosenberg (@djrbliss)[*][*] Before continuing, ensure USB debugging is enabled, that ADB[*] is working properly, and that your tablet is connected via USB.[*][*] WARNING: This exploit may result in wiping your /data partition,[*] causing you to lose any applications and data on your tablet.[*] There should be no risk of permanent damage to your device, but[*] by running this script you accept all responsibility.[*][*] Press enter to root your tablet...
Press any key to continue . . .[*][*] Waiting for device...
* daemon not running. starting it now *
* daemon started successfully *[*] Device found.[*] Pushing log flooder to device...
583 KB/s (5382 bytes in 0.009s)[*] Preparing to append to packages.list...[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attempting to move system package library directory...
[+] System package com.google.android.location has uid 10029
[+] Flooding log...[*] If you received any errors in the previous step, abort the exploit[*] and try again.  Otherwise, press any key to continue.
Press any key to continue . . .[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attempting to insert fake local.prop entry...
[+] Flooding log...[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attemping persistence...
remount failed: Operation not permitted
failed to copy 'su' to '/system/bin/su': Read-only file system
Unable to chmod /system/bin/su: No such file or directory
failed to copy 'busybox' to '/system/xbin/busybox': Read-only file system
Unable to chmod /system/xbin/busybox: No such file or directory
/system/xbin/busybox: not found
failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
stem[*] Cleaning up...
failed on '/data/data/com.google.android.location/lib.bak' - Permission denied[*] Rebooting...[*] Exploit complete![*] Press any key to exit.
Press any key to continue . . .
ADB works and debugging is enabled.
The Following User Says Thank You to rjsmith2007 For This Useful Post: [ View ]
8th February 2012, 07:58 PM   |  #15  
HKboy92's Avatar
Member
Flag Den Helder
Thanks Meter: 10
 
79 posts
Join Date:Joined: Feb 2011
More
Got it working. Next step is CWM and then a nice fresh cup of awesomeness. Thanks Dan. Expect a donation your way.

Quote:
Originally Posted by Judah001

Is anyone able to make a YouTube video for people like me who canít seem to figure it out? That would be totally appreciated not only by me but Iím sure the rest of our tablet S community. Thanks for root!

OKay
The Following User Says Thank You to HKboy92 For This Useful Post: [ View ]
8th February 2012, 08:10 PM   |  #16  
Member
Flag Northridge
Thanks Meter: 9
 
82 posts
Join Date:Joined: Jun 2008
More
Quote:
Originally Posted by rjsmith2007

I tried to use the exploit after a factory reset, and I can't get it to work.

Code:
F:\Desktop\Sony_Tablet_S_Root_Windows>run.bat[*][*] Sony Tablet S root script (Windows version)[*] by Dan Rosenberg (@djrbliss)[*][*] Before continuing, ensure USB debugging is enabled, that ADB[*] is working properly, and that your tablet is connected via USB.[*][*] WARNING: This exploit may result in wiping your /data partition,[*] causing you to lose any applications and data on your tablet.[*] There should be no risk of permanent damage to your device, but[*] by running this script you accept all responsibility.[*][*] Press enter to root your tablet...
Press any key to continue . . .[*][*] Waiting for device...
* daemon not running. starting it now *
* daemon started successfully *[*] Device found.[*] Pushing log flooder to device...
583 KB/s (5382 bytes in 0.009s)[*] Preparing to append to packages.list...[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attempting to move system package library directory...
[+] System package com.google.android.location has uid 10029
[+] Flooding log...[*] If you received any errors in the previous step, abort the exploit[*] and try again.  Otherwise, press any key to continue.
Press any key to continue . . .[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attempting to insert fake local.prop entry...
[+] Flooding log...[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attemping persistence...
remount failed: Operation not permitted
failed to copy 'su' to '/system/bin/su': Read-only file system
Unable to chmod /system/bin/su: No such file or directory
failed to copy 'busybox' to '/system/xbin/busybox': Read-only file system
Unable to chmod /system/xbin/busybox: No such file or directory
/system/xbin/busybox: not found
failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
stem[*] Cleaning up...
failed on '/data/data/com.google.android.location/lib.bak' - Permission denied[*] Rebooting...[*] Exploit complete![*] Press any key to exit.
Press any key to continue . . .
ADB works and debugging is enabled.

Try running the .bat file again, it happened to me first time, but when I tried it second time it worked.
8th February 2012, 08:13 PM   |  #17  
Member
Thanks Meter: 12
 
79 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by 05081983

Try running the .bat file again, it happened to me first time, but when I tried it second time it worked.

When I run the bat file the second time, I get an error related to the files that the exploit handles:

Code:
[+] System package com.google.android.location has uid 10029
[+] Flooding log...
failed on '/data/data/com.google.android.location/lib' - Permission denied
link failed File exists[*]
Code:
F:\Desktop\Sony_Tablet_S_Root_Windows>run.bat[*][*] Sony Tablet S root script (Windows version)[*] by Dan Rosenberg (@djrbliss)[*][*] Before continuing, ensure USB debugging is enabled, that ADB[*] is working properly, and that your tablet is connected via USB.[*][*] WARNING: This exploit may result in wiping your /data partition,[*] causing you to lose any applications and data on your tablet.[*] There should be no risk of permanent damage to your device, but[*] by running this script you accept all responsibility.[*][*] Press enter to root your tablet...
Press any key to continue . . .[*][*] Waiting for device...
* daemon not running. starting it now *
* daemon started successfully *[*] Device found.[*] Pushing log flooder to device...
656 KB/s (5382 bytes in 0.008s)[*] Preparing to append to packages.list...[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attempting to move system package library directory...
[+] System package com.google.android.location has uid 10029
[+] Flooding log...
failed on '/data/data/com.google.android.location/lib' - Permission denied
link failed File exists[*] If you received any errors in the previous step, abort the exploit[*] and try again.  Otherwise, press any key to continue.
Press any key to continue . . .[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attempting to insert fake local.prop entry...
[+] Flooding log...[*] Rebooting device...[*] Waiting for tablet to reboot.[*] Attemping persistence...
remount failed: Operation not permitted
failed to copy 'su' to '/system/bin/su': Read-only file system
Unable to chmod /system/bin/su: No such file or directory
failed to copy 'busybox' to '/system/xbin/busybox': Read-only file system
Unable to chmod /system/xbin/busybox: No such file or directory
/system/xbin/busybox: not found
failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
stem[*] Cleaning up...
failed on '/data/data/com.google.android.location/lib.bak' - Permission denied[*] Rebooting...[*] Exploit complete![*] Press any key to exit.
Press any key to continue . . .

F:\Desktop\Sony_Tablet_S_Root_Windows>
8th February 2012, 08:14 PM   |  #18  
obicom's Avatar
Senior Member
Flag Cologne
Thanks Meter: 80
 
283 posts
Join Date:Joined: Nov 2010
More
I guess it is not so "easy" to get CWM on the tablet. As I know, CWM is part of kernel and this is signed on the Sony Tablet S ....

@Dan:
Is it right and do you see a opportunity to get CWM on Tablet S?
8th February 2012, 08:20 PM   |  #19  
OP Recognized Developer
Thanks Meter: 2,623
 
136 posts
Join Date:Joined: Aug 2011
Donate to Me
Quote:
Originally Posted by rjsmith2007

When I run the bat file the second time, I get an error related to the files that the exploit handles:

Code:
[+] System package com.google.android.location has uid 10029
[+] Flooding log...
failed on '/data/data/com.google.android.location/lib' - Permission denied
link failed File exists[*]

I just uploaded a new version of the exploit that should fix this problem. Just unzip it, execute "run.bat", and let me know how it goes.

If anyone has been having any problems with the exploit, please try the new version here:
http://vulnfactory.org/public/Sony_T...ot_Windows.zip
The Following 2 Users Say Thank You to djrbliss For This Useful Post: [ View ]
8th February 2012, 08:22 PM   |  #20  
Member
Thanks Meter: 12
 
79 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by djrbliss

I just uploaded a new version of the exploit that should fix this problem. Just unzip it, execute "run.bat", and let me know how it goes.

If anyone has been having any problems with the exploit, please try the new version here:
http://vulnfactory.org/public/Sony_T...ot_Windows.zip

Thanks. I'll try it out now!

Edit: I'm still getting the same end result. Should I wait for the device to boot fully to the launcher, when it asks me to press a button before it continues?
Last edited by rjsmith2007; 8th February 2012 at 08:26 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes