Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

The application Gallery (process com.cooliris.media) has stopped unexpectedly

OP acem77

9th February 2012, 06:10 PM   |  #1  
OP Senior Member
Thanks Meter: 0
 
127 posts
Join Date:Joined: Nov 2006
More
This is so annoying,
I have tried everything I could find online,

I removed the SD card to eliminate that as an option related to a corrupt image/ card.

I cleared Gallery the data under manage applications.

With ES file explorer

I deleted the com.cooliris.media folder multiple times

I renamed all dirs to hide them from the Gallery indexing.
Example renamed “DCIM” to ”.DCIM”

I opened and examined the file chunk_0 in
/com.cooliris.media/cache/local-album-cache
I was hoping i could see how far or were it crashed by the last dir it indexed.
After hiding all the dirs. I got it to this.

Data in “chunk_0(this file will grow as dirs are scanned and files are found)” opened in a hex editor.

..US..en............./...........4.......4...........b..intro..video/mp4.......................4.........O.{.....O.u... w..............:.............../

Not sure if this is a hit on what is crashing the gallery?
9th February 2012, 06:34 PM   |  #2  
Kaleptik's Avatar
Recognized Developer
Thanks Meter: 1,233
 
3,787 posts
Join Date:Joined: Jun 2009
More
I'm guessing a factory reset didn't work either?
9th February 2012, 07:23 PM   |  #3  
OP Senior Member
Thanks Meter: 0
 
127 posts
Join Date:Joined: Nov 2006
More
Have not done that, dont want to reconfigure the phone from scratch.
I always like to know the root of the real issue. seems kind of common.
9th February 2012, 07:25 PM   |  #4  
Kaleptik's Avatar
Recognized Developer
Thanks Meter: 1,233
 
3,787 posts
Join Date:Joined: Jun 2009
More
I never use Gallery. Ever. So I wouldn't have an exact idea why it was going crazy.
Are you rooted and do you have Titanium Backup Free/Pro?
If so, back up the gallery app. Then delete it from the /system.
Restart your phone and restore the Gallery app and make it a system app again.
9th February 2012, 07:40 PM   |  #5  
OP Senior Member
Thanks Meter: 0
 
127 posts
Join Date:Joined: Nov 2006
More
its rooted and i have Titanium Backup Pro.
i did not know you can delete the gallary.

I did download another gallery like app for now.
but i may give that a try.
9th February 2012, 07:52 PM   |  #6  
Kaleptik's Avatar
Recognized Developer
Thanks Meter: 1,233
 
3,787 posts
Join Date:Joined: Jun 2009
More
Yeah. Wipe the data first then uninstall it.
10th February 2012, 04:33 AM   |  #7  
OP Senior Member
Thanks Meter: 0
 
127 posts
Join Date:Joined: Nov 2006
More
i made the back up of the gallery, uninstalled it, when i try to recover/install it from the back up the phone stays in an install loop.
I have to reboot the phone.

now i deleted it how do i reinstall it?
I have gallery apk from the backup and the original is still under /system/app/com.cooliris.media.apk

when run the apk i get an error, application not installed.

I tried to use adb with no luck.

F:\~droid\root backup restore files\SuperOneClickv2.1.1-ShortFuse\ADB>adb instal
l gal.apk
993 KB/s (458660 bytes in 0.451s)
pkg: /data/local/tmp/gal.apk
Failure [INSTALL_FAILED_DEXOPT]


any pointers?
10th February 2012, 05:04 AM   |  #8  
Kaleptik's Avatar
Recognized Developer
Thanks Meter: 1,233
 
3,787 posts
Join Date:Joined: Jun 2009
More
Follow the exact steps.
  1. Open Titanium Backup
  2. Wipe Gallery data (From Titanium Backup)
  3. Uninstall Gallery (From Titanium Backup)
  4. Restart phone
  5. Restore App of Gallery (From Titanium Backup)
  6. Restart phone
  7. Try using gallery
10th February 2012, 03:02 PM   |  #9  
OP Senior Member
Thanks Meter: 0
 
127 posts
Join Date:Joined: Nov 2006
More
I don’t think titanium is an option now.

as it never finishes installing. i let it go all night.
The Gallery has been deleted and i only have the option to restore. My only options are to restore App only or App+Data. both don’t finish.

so i have been reading you can force/push installs. i must be doing something wrong as it seems a restriction is preventing the other install methods,

at this point the only reason i care is i cant view images in 3d.
10th February 2012, 04:05 PM   |  #10  
Kaleptik's Avatar
Recognized Developer
Thanks Meter: 1,233
 
3,787 posts
Join Date:Joined: Jun 2009
More
Quote:
Originally Posted by acem77

I don’t think titanium is an option now.

as it never finishes installing. i let it go all night.
The Gallery has been deleted and i only have the option to restore. My only options are to restore App only or App+Data. both don’t finish.

so i have been reading you can force/push installs. i must be doing something wrong as it seems a restriction is preventing the other install methods,

at this point the only reason i care is i cant view images in 3d.

Using adb

adb shell
su
mount -o remount,rw /dev/block/stl9 /system
exit
exit
adb push Gallery.apk /system/app

Reboot the phone.

Sent from my Samsung Galaxy S II

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes