Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Themeing Help (Gimp problems)

OP luke1987

22nd February 2012, 06:25 AM   |  #11  
luke1987's Avatar
OP Senior Member
Flag ND
Thanks Meter: 51
 
356 posts
Join Date:Joined: Nov 2010
More
Didn't quite get her for me...here's my steps

1)decompile
2)delete res/values/public.xml
3)recompile (system apk? N)
4)sign

This apk installed fine and worked...except one weird thing I noticed is the keyboard works fine, but the cute little instructions you get when clicking the app in the app drawer would cause a force close.

5)replace qwerty.png by dropping it into apk (res/raw-hdpi) (7zip)

Install fails

here is my result as of step 4

here is my result as of step 5

Edit: After talking to my bro (funkencool) tonight I'm getting real convinced it's OS related. We have the identical PB cracked OS and both are encountering this same issue (with much different hardware specs).I know it doesn't seem logical but it doesn't seem to be happening to anyone else. I'm just hitting my head against a wall now. By the way thanks for the help Synisterwolf, I know your a master of the trade. Next I'll try all editing on a live version of linux, and if that doesn't work...I don't know

Edit2: Or like N-forced said, resign apk after the nifty 7zip drop... regular PNGs have never been an issue... I can edit smali and install but PNGs ruin everything, I dont get it
Last edited by luke1987; 22nd February 2012 at 08:12 AM.
22nd February 2012, 04:07 PM   |  #12  
synisterwolf's Avatar
Recognized Contributor
Thanks Meter: 2,237
 
6,511 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by luke1987

Didn't quite get her for me...here's my steps

1)decompile
2)delete res/values/public.xml
3)recompile (system apk? N)
4)sign

This apk installed fine and worked...except one weird thing I noticed is the keyboard works fine, but the cute little instructions you get when clicking the app in the app drawer would cause a force close.

5)replace qwerty.png by dropping it into apk (res/raw-hdpi) (7zip)

Install fails

here is my result as of step 4

here is my result as of step 5

Edit: After talking to my bro (funkencool) tonight I'm getting real convinced it's OS related. We have the identical PB cracked OS and both are encountering this same issue (with much different hardware specs).I know it doesn't seem logical but it doesn't seem to be happening to anyone else. I'm just hitting my head against a wall now. By the way thanks for the help Synisterwolf, I know your a master of the trade. Next I'll try all editing on a live version of linux, and if that doesn't work...I don't know

Edit2: Or like N-forced said, resign apk after the nifty 7zip drop... regular PNGs have never been an issue... I can edit smali and install but PNGs ruin everything, I dont get it

dont hate me. but it worked for me. decompile replace the png compile and sign.



i am getting an fc when trying to go into settings. dont know what is causing that. i need my home pc to figure that out

Fixed the FC problem. so use mine and try to change a png with 7zip. it should be good to go for you.

Edit: nvm fc is back after a reboot.
Going to try without the tracer edit. Maybe that's the cause.

what tools are you using to decompile the apk?
Last edited by synisterwolf; 4th June 2013 at 07:55 PM.
22nd February 2012, 04:15 PM   |  #13  
synisterwolf's Avatar
Recognized Contributor
Thanks Meter: 2,237
 
6,511 posts
Join Date:Joined: Sep 2010
More
also i was wondering if you would share how you edited the tracer for another memeber.

http://forum.xda-developers.com/show....php?t=1438135

we couldnt figure that out for the life of us. if you could do that. that would be most excellent.

edit: looks like your brother already did. -_- to early here i need coffee.
22nd February 2012, 04:50 PM   |  #14  
synisterwolf's Avatar
Recognized Contributor
Thanks Meter: 2,237
 
6,511 posts
Join Date:Joined: Sep 2010
More
ok so this is a fresh shapewriter with only the png change. no FC or anything. works just fine. take this and try your tracer edit. let me know what you come up with.
Last edited by synisterwolf; 4th June 2013 at 07:55 PM.
The Following User Says Thank You to synisterwolf For This Useful Post: [ View ]
22nd February 2012, 08:18 PM   |  #15  
luke1987's Avatar
OP Senior Member
Flag ND
Thanks Meter: 51
 
356 posts
Join Date:Joined: Nov 2010
More
Well I kinda feel like a fool after all the struggling, but you got me thru it synister, thanks alot. I was using apk manager, but this time around I used MultiTool. I must have been deleting the images before replacing and compiling last time, or something. I gave up on 7zip trick. But here's what I have so far. I still need to fine tune.

ICSshapewriter
Attached Thumbnails
Click image for larger version

Name:	icsshape.png
Views:	17
Size:	91.6 KB
ID:	914868  
The Following User Says Thank You to luke1987 For This Useful Post: [ View ]
22nd February 2012, 08:22 PM   |  #16  
luke1987's Avatar
OP Senior Member
Flag ND
Thanks Meter: 51
 
356 posts
Join Date:Joined: Nov 2010
More
BTW, the tracer color is in SWI_KeyboardViewTrace.smali ... we were stuck with red green or blue for awhile, but funkencool had a stroke of genius and added a few variables to give us any color we want.
The Following User Says Thank You to luke1987 For This Useful Post: [ View ]
22nd February 2012, 08:34 PM   |  #17  
synisterwolf's Avatar
Recognized Contributor
Thanks Meter: 2,237
 
6,511 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by luke1987

Well I kinda feel like a fool after all the struggling, but you got me thru it synister, thanks alot. I was using apk manager, but this time around I used MultiTool. I must have been deleting the images before replacing and compiling last time, or something. I gave up on 7zip trick. But here's what I have so far. I still need to fine tune.

ICSshapewriter

i was using apk manager for the png swap. do you get an fc when going into settings?
22nd February 2012, 09:02 PM   |  #18  
luke1987's Avatar
OP Senior Member
Flag ND
Thanks Meter: 51
 
356 posts
Join Date:Joined: Nov 2010
More
Seems to be running fine so far. Rebooted once
22nd February 2012, 09:16 PM   |  #19  
synisterwolf's Avatar
Recognized Contributor
Thanks Meter: 2,237
 
6,511 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by luke1987

Seems to be running fine so far. Rebooted once

wonder what i did to break it lol :P but anyways im glad you got it working.
23rd February 2012, 05:14 AM   |  #20  
luke1987's Avatar
OP Senior Member
Flag ND
Thanks Meter: 51
 
356 posts
Join Date:Joined: Nov 2010
More
Noticed this today, gonna take some serious digging to find the culprit. Atleast the tracer was half identifiable by the filename. I don't know what you'd call this, or even why it happens. I'll find her though

Edit: Think I found where key (character) color and that green highlight are defined. Wish I didn't have a mountain of homework to start so I could test!
Attached Thumbnails
Click image for larger version

Name:	problem.jpg
Views:	14
Size:	40.2 KB
ID:	915419  
Last edited by luke1987; 23rd February 2012 at 06:58 AM.

Post Reply Subscribe to Thread

Tags
corrupt png, gimp, png, themeing
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes