Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,303 Members 53,066 Now Online
XDA Developers Android and Mobile Development Forum

[NAND] IceDroid V8 with BEATS [FINAL] [10/7/12]

Tip us?
 
Elibl
Old
(Last edited by Elibl; 1st March 2012 at 11:51 PM.)
#81  
Senior Member
Thanks Meter 362
Posts: 598
Join Date: Dec 2011

 
DONATE TO ME
v3 is again pretty good work jerry thanks

btw the carhome update is still incompatible in market but doesn't really matter cause it's the only one i noticed


could you have a look at that apk?
http://forum.xda-developers.com/show...3&postcount=10
maybe you can find out the reason why booting with sdcard doesn't work...
but be careful unrooting messes up system, wifi etc

btw i looked in some files located in /d/mmc0/mmc1 they have all the same content about can't open file or something like that maybe helpful... don't know


and still another thing could you also have a look at the usb stuff maybe it's also rom related that mass storage in android isn't working because it works every time on first boot after installation but never afterwards...

therefore i also noticed that android sometimes doesn't detect right if it's charged by usb or ac, sometimes it still shows usb connected although it's unplugged and the strange fast reconnects in standby mode while plugged (usb)

but i don't know what's kernel and what's rom related just some things for you when you've got time

thanks again for your works on this rom
 
squallvai
Old
#82  
squallvai's Avatar
Member
Thanks Meter 33
Posts: 91
Join Date: Apr 2009
Location: Yogyakarta
Default Error playing Music Using HF

Quote:
Originally Posted by mahmoodifar View Post
I have a problem with headphones
every time I attach a headphone, the phone start to play music randomly, just few seconds from each songs
Do you have the same problem
How can I disable this
Quote:
Originally Posted by neoofoox View Post
For Headphones. When you disable music before you plug it in, it doesn't play/pause all the time (I got that when I started music and plug the headphone (in my case speakers) in)

And after removing the Icon on the statusbar doesn't disapear but it does after reboot.
I Have The Same Problem Like this...
and its also happen even if I disable music player before plug Headphone

Here I Attach the Log Cat...
*Open Using Browser

I Hope This help for dev
Attached Files
File Type: zip Log Cat Music Player + HF.zip - [Click for QR Code] (6.6 KB, 8 views)
Device : HTC7 Mozart
ROM : Dynamics7 v2.0 by Ultrashot

Device : SE Xperia X1 Black [HTC Kovsky]
ROM : Dynamics 2.4.5 by Ultrashot
The Following User Says Thank You to squallvai For This Useful Post: [ Click to Expand ]
 
jerrytan93
Old
(Last edited by jerrytan93; 2nd March 2012 at 09:33 AM.)
#83  
jerrytan93's Avatar
Recognized Themer - OP
Thanks Meter 6261
Posts: 2,008
Join Date: Oct 2010

 
DONATE TO ME
Quote:
Originally Posted by Elibl View Post
......
btw the carhome update is still incompatible in market but doesn't really matter cause it's the only one i noticed


could you have a look at that apk?
http://forum.xda-developers.com/show...3&postcount=10
..............


and still another thing could you also have a look at the usb stuff maybe it's also rom related that mass storage in android isn't working because it works every time on first boot after installation but never afterwards...

therefore i also noticed that android sometimes doesn't detect right if it's charged by usb or ac, sometimes it still shows usb connected although it's unplugged and the strange fast reconnects in standby mode while plugged (usb)
.............................................

Attached Car Home at Mod + Download section..

SD card booting seems like kernel side MAYBE, btw this ROM was actually FULLY rooted and I don't know why we need to 'un-root' it and then 're-root'.. from my experience improper rooting & unrooting will messed up whole system and worstly.. affecting the device too, but don't worry we won't reach that worst level..

A logcat will give me better information for the mass storage.. can you attach a logcat when the time you successful to connect USB and when second time unable to connect? I will like to see the difference

Hmm.. no idea for this...



Quote:
Originally Posted by squallvai View Post
I Have The Same Problem Like this...
and its also happen even if I disable music player before plug Headphone

Here I Attach the Log Cat...
*Open Using Browser

I Hope This help for dev

Yes this give me a better information really..

looks like something wrong with 3.5mm_headset.kcm.bin file

Can you please try with another music player with headset plugged in and see will the problem occur?
~~ DON'T FORGET TO CLICK THE THANKS BUTTON ~~


~~ SUPPORT MY WORK BY BUYING ME A COFFEE ~~

 
mahmoodifar
Old
(Last edited by mahmoodifar; 2nd March 2012 at 10:39 AM.)
#84  
Member
Thanks Meter 2
Posts: 68
Join Date: Nov 2010
Quote:
Originally Posted by squallvai View Post
I Have The Same Problem Like this...
and its also happen even if I disable music player before plug Headphone

Here I Attach the Log Cat...
*Open Using Browser

I Hope This help for dev
Sorry I don't understand that
Is it gonna fix headphone problem ?
could you explain more about that
thanks
 
squallvai
Old
#85  
squallvai's Avatar
Member
Thanks Meter 33
Posts: 91
Join Date: Apr 2009
Location: Yogyakarta
Quote:
Originally Posted by mahmoodifar View Post
Sorry I don't understand that
could you explain more about that
thanks
That Logcat is for Developers to see what is wrong when error happen

Quote:
Originally Posted by jerrytan93 View Post
Yes this give me a better information really..

looks like something wrong with 3.5mm_headset.kcm.bin file

Can you please try with another music player with headset plugged in and see will the problem occur?
I already did two test..
Before test I uninstall the Original music player from ROM

1. I Use Walkman Themed Music Player ( Forgot where i get this file)
when headphone Pluged in..
the player is not automatic open & not playing anything (thats good)
And when i play Music everything is just play as it should be

2. I use Google Music Player v3.0.336 (Beta version)
when headphone Pluged in.. the player is automaticly open but not playing anything (thats good)
And when i play a Music everything is just play as it should be

so the Both player are works OK


Here I Attach the Both Files
Attached Files
File Type: apk walkman.apk - [Click for QR Code] (1.05 MB, 9 views)
File Type: apk android.music.3Beta.apk - [Click for QR Code] (3.76 MB, 10 views)
Device : HTC7 Mozart
ROM : Dynamics7 v2.0 by Ultrashot

Device : SE Xperia X1 Black [HTC Kovsky]
ROM : Dynamics 2.4.5 by Ultrashot
The Following User Says Thank You to squallvai For This Useful Post: [ Click to Expand ]
 
jerrytan93
Old
#86  
jerrytan93's Avatar
Recognized Themer - OP
Thanks Meter 6261
Posts: 2,008
Join Date: Oct 2010

 
DONATE TO ME
Quote:
Originally Posted by squallvai View Post
That Logcat is for Developers to see what is wrong when error happen


I already did two test..
Before test I uninstall the Original music player from ROM

1. I Use Walkman Themed Music Player ( Forgot where i get this file)
when headphone Pluged in..
the player is not automatic open & not playing anything (thats good)
And when i play Music everything is just play as it should be

2. I use Google Music Player v3.0.336 (Beta version)
when headphone Pluged in.. the player is automaticly open but not playing anything (thats good)
And when i play a Music everything is just play as it should be

so the Both player are works OK
Yea that's good.. your report shows that it's the default CM7 music player problem.. will replace it with another music player.. thanks for report..
~~ DON'T FORGET TO CLICK THE THANKS BUTTON ~~


~~ SUPPORT MY WORK BY BUYING ME A COFFEE ~~

 
jerrytan93
Old
#87  
jerrytan93's Avatar
Recognized Themer - OP
Thanks Meter 6261
Posts: 2,008
Join Date: Oct 2010

 
DONATE TO ME
Teaser for IceDroid V4:

- Beats audio effect implant into the ROM!! credits to RockoDev for the Beats mod and fuss132 for porting
-Beats + DSP Manager 'bass enabled'.. now the bass sounds like a BOOM!
- FIXED no sound with music when headset plugged in problem
- Using Zargloub latest kernel ( 1/3 ) which improved battery accuracy and performance and also light value
- Updated Go Launcher EX 2.8.1
- Updated Car Home 2.2.1.4


Will be uploaded tomorrow after making a proper testing with my friend's X1 (Yeah the phone is on my hand now).. STAY TUNED!!
~~ DON'T FORGET TO CLICK THE THANKS BUTTON ~~


~~ SUPPORT MY WORK BY BUYING ME A COFFEE ~~

The Following 3 Users Say Thank You to jerrytan93 For This Useful Post: [ Click to Expand ]
 
Elibl
Old
(Last edited by Elibl; 2nd March 2012 at 05:04 PM.)
#88  
Senior Member
Thanks Meter 362
Posts: 598
Join Date: Dec 2011

 
DONATE TO ME
Quote:
Originally Posted by jerrytan93 View Post
Attached Car Home at Mod + Download section..

SD card booting seems like kernel side MAYBE, btw this ROM was actually FULLY rooted and I don't know why we need to 'un-root' it and then 're-root'.. from my experience improper rooting & unrooting will messed up whole system and worstly.. affecting the device too, but don't worry we won't reach that worst level..

A logcat will give me better information for the mass storage.. can you attach a logcat when the time you successful to connect USB and when second time unable to connect? I will like to see the difference

Hmm.. no idea for this...
thanks jerry your great, guy!

i will create an logcat about mass storage when i found out how but i currently have no time maybe this evening or tomorrow...

about sdcard boot i thought it must be rom related cause it works after unrooting with this z4.apk but i could also be wrong with this...

and the system is messed up afterwards! and also reroot doesn't work

EDIT: okay not that difficult just run logcat in shell

EDIT2: here's already the not working:

I/ActivityManager( 99): Starting: Intent { flg=0x10000000 cmp=com.android.syst
emui/.usb.UsbStorageActivity bnds=[0,216][480,312] } from pid -1
D/VoldCmdListener( 65): volume shared /mnt/sdcard ums
W/InputManagerService( 99): Window already focused, ignoring focus gain of: co
m.android.internal.view.IInputMethodClient$Stub$Pr oxy@40552460
W/ResourceType( 99): Skipping entry 0x7f04001a in package table 0 because it i
s not complex!
W/ResourceType( 99): Skipping entry 0x7f040019 in package table 0 because it i
s not complex!

the working later...
 
squallvai
Old
#89  
squallvai's Avatar
Member
Thanks Meter 33
Posts: 91
Join Date: Apr 2009
Location: Yogyakarta
Quote:
Originally Posted by jerrytan93 View Post
Teaser for IceDroid V4:

- Beats audio effect implant into the ROM!! credits to RockoDev for the Beats mod and fuss132 for porting
as I expected... Beats Audio... yeaah!!!
Device : HTC7 Mozart
ROM : Dynamics7 v2.0 by Ultrashot

Device : SE Xperia X1 Black [HTC Kovsky]
ROM : Dynamics 2.4.5 by Ultrashot
 
ady_95
Old
#90  
Senior Member
Thanks Meter 52
Posts: 122
Join Date: Feb 2011
Location: Bacau
Quote:
Originally Posted by jerrytan93 View Post
Teaser for IceDroid V4:

- Beats audio effect implant into the ROM!! credits to RockoDev for the Beats mod and fuss132 for porting
-Beats + DSP Manager 'bass enabled'.. now the bass sounds like a BOOM!
- FIXED no sound with music when headset plugged in problem
That "sounds" good
Current device: HTC Kovsky (SE Xperia X1) BROKEN (need help)
Radio: 1.14.25.55

Tags
android 2.3.7, ice cream sandwich
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes