FORUMS

Analysis & Opinion

Top Forum Discussions

How to change default theme in a Cyanogenmod Rom?

3,387 posts
Thanks Meter: 617
 
By adolfo778, Senior Member on 20th February 2012, 05:41 PM
Post Reply Subscribe to Thread Email Thread
Currently making a rom and would like to change the default theme to another theme. Any ideas?
 
 
20th February 2012, 07:40 PM |#2  
jonas2295's Avatar
Recognized Contributor
Flag Bavaria
Thanks Meter: 2,702
 
Donate to Me
More
Cyanbread and/or androidian. apk in system/app folder.
Press the thanks button

Sent from my HTC HD2 using xda premium
20th February 2012, 08:01 PM |#3  
mDroidd's Avatar
Recognized Contributor
Thanks Meter: 1,386
 
Donate to Me
More
Quote:
Originally Posted by jonas2295

Cyanbread and/or androidian. apk in system/app folder.
Press the thanks button

Sent from my HTC HD2 using xda premium

Wrong answer...

You could be right, but no...

That are not the default themes...

I think you should drag and drop the files from your theme into the framework file and compile and sign. That should do it.

Or do you mean a theme enabled by default but not default theme?

Greets!
20th February 2012, 08:06 PM |#4  
jonas2295's Avatar
Recognized Contributor
Flag Bavaria
Thanks Meter: 2,702
 
Donate to Me
More
Quote:
Originally Posted by mDroidd

Wrong answer...

You could be right, but no...

That are not the default themes...

I think you should drag and drop the files from your theme into the framework file and compile and sign. That should do it.

Or do you mean a theme enabled by default but not default theme?

Greets!

Really lol?
It worked for me when I tried my own cm7 rom but probably I simply gave the wrong answer sry!

Sent from my HTC HD2 using xda premium
21st February 2012, 12:51 AM |#5  
adolfo778's Avatar
OP Senior Member
Flag Garden Grove, CA
Thanks Meter: 617
 
Donate to Me
More
ya I dont even have those apks in the rom
I'll try what he said
21st February 2012, 02:54 PM |#6  
Senior Member
Thanks Meter: 5
 
More
Hi guys,,,
I am cooking a new ROM for my galaxy tab 10.1 and I want to change the theme..
I fount the perfect one that consist of many files:
framework-res
systemui
system
fonts
bootanimation

when I put the files in my ROM I always get stuck at bootanimation screen.
but if I flash the them with recovery after I flash the ROM then everything boot correct.

please help me guys..
21st February 2012, 03:02 PM |#7  
jonas2295's Avatar
Recognized Contributor
Flag Bavaria
Thanks Meter: 2,702
 
Donate to Me
More
Check the updater script.

Sent from my HTC HD2 using xda premium
21st February 2012, 03:24 PM |#8  
mDroidd's Avatar
Recognized Contributor
Thanks Meter: 1,386
 
Donate to Me
More
Quote:
Originally Posted by logic5

Hi guys,,,
I am cooking a new ROM for my galaxy tab 10.1 and I want to change the theme..
I fount the perfect one that consist of many files:
framework-res
systemui
system
fonts
bootanimation

when I put the files in my ROM I always get stuck at bootanimation screen.
but if I flash the them with recovery after I flash the ROM then everything boot correct.

please help me guys..

Try wipe cache and dalvik, and sign correctly. I admit that it is strange.

Greets!
21st February 2012, 03:24 PM |#9  
mDroidd's Avatar
Recognized Contributor
Thanks Meter: 1,386
 
Donate to Me
More
Edit: did you sign, compile?

Greets!
21st February 2012, 03:26 PM |#10  
Senior Member
Thanks Meter: 5
 
More
Hi,
check for what exactly ?
there is nothing special .. as I said .. if I flash the ROM and the theme separately then every thing is ok ...
all I did was replace the files in the zip..and then I get stucj at bootanimation.

I didn't sign or compile...

I have a theory : the SystemUI has a battery percentage and the apk has new files in it... could it be the problem ?
Last edited by logic5; 21st February 2012 at 03:31 PM.
21st February 2012, 04:00 PM |#11  
mDroidd's Avatar
Recognized Contributor
Thanks Meter: 1,386
 
Donate to Me
More
Quote:
Originally Posted by logic5

Hi,
check for what exactly ?
there is nothing special .. as I said .. if I flash the ROM and the theme separately then every thing is ok ...
all I did was replace the files in the zip..and then I get stucj at bootanimation.

I didn't sign or compile...

I have a theory : the SystemUI has a battery percentage and the apk has new files in it... could it be the problem ?

First: to clarify;

you have a couple APKs for your Tab.

You place them in a flashable zip, flash, bootblock

you have a ROM for your Tab,

you grab the .zip, and replace the theme APKs, flash, and it works?

THat is really strange...

Read More
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes