5,596,784 Members 48,061 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Phone infected, Tried everything, nothing worked

Tip us?
 
galaxyi7500
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Feb 2012
Unhappy [Q] Phone infected, Tried everything, nothing worked

Guyz,

I recently lost my samsung guru on my way to office and then I had to switch back the old galaxy i7500 lying around for months. It was still alive and had recently been services(the touchscreen) by the authorized service centre.

I am comfortable with recovery/rom and before sending it to service I had galaxo 1.6(the latest stable back then) on my phone. I even had some(3 to be exact) nandroid backups on my phone. After it returned from the service centre it started acting strange. Now the problem begins.

It looks & works completely fine until I call somebody. Then something just starts running in the background, random keypresses, some random application starts, and I see the volume bar all the time as some continuous volume up command is given, I presume. It just goes on like this during the entire call and even a few seconds after the call. Another problem is it silents my phone every time someone calls me, so no matter what I set in the settings I never ever hear a ring when someone calls me, even the vibration gets off.

Solutions I tried: Obviously I tried formatting the storage(it doesn't have any external storage). Flashing the ROM, changing the ROM, drakaz 2.1, recovery 6.6 etc. Nothing helped, I even tried(with some workaround) and got the old nandroid backup restored . .. but to no avail. I have currently Kaspersky installed on my phone but even it can not detect anything. I have not given odin a try yet as I am on Mac and currently not very comfortable with heimdall.

I must thank you for reading this long post of mine & appreciate any little help any of you can offer, even some sympathy will do.

Thanks in advance,

Abhinav
 
Lesicnik1
Old
#2  
Recognized Contributor
Thanks Meter 725
Posts: 2,232
Join Date: Feb 2011
Location: Slovenj Gradec
It's probably not a virus if you completely reflashed your phone, unless it nestled itself in the recovery (or other partitions that don't get wiped).
 
aawillma
Old
#3  
Senior Member
Thanks Meter 54
Posts: 143
Join Date: Feb 2012
Location: Phoenix
Have you tried flashing a new radio? If the problem starts when calling maybe the radio is corrupt or fried or somehow busted. Also, the radio isn't affected when you switch ROMs so it would explain why reflashing/wiping/restoring backups doesn't help.

Since your phone isn't officially supported I have no idea how you would go about finding alternative radios though.
 
lufc
Old
#4  
lufc's Avatar
Senior Moderator / Resident Priest
Thanks Meter 1446
Posts: 9,504
Join Date: Oct 2007
Location: Blackpool UK

 
DONATE TO ME
Please use the Q&A Forum for questions &
Read the Forum Rules Ref Posting

Moving to Q&A
Pay attention and participate,Encourage,
not discourage, Listen to advice and accept instruction,
and in the end you will be wise.......... Prov. 19:20
 
plainjane
Old
#5  
plainjane's Avatar
Senior Member
Thanks Meter 461
Posts: 1,675
Join Date: Jan 2011
Location: Charlotte, NC
Sounds more like an issue with the screen rather than a software issue. I'd take it back to the service center and have them take another look, it could've been improperly fixed.

Supersonic Evo 4G | MIUI | Tapatalk
HTC Supersonic (EVO 4G)
HW 003
Hboot 2.02 S-Off
Amon Ra recovery
More stuff that I'm too lazy to figure out and type.
MIUI 2.3.2_b1 ES (by Swiperat)
Extended Settings Mod
Tiamat 4.1.0 SBC

My wallpaper collection
GTalk: ohhhgeez@gmail.com

If you think I can help you with something or need me to elaborate on a post then feel free to pm me. I'll try my best to help you out.

Oh, and I have a vagina. Fear me :P
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes