Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

YU Yureka: Indian Handset with CyanogenMod

Thesoap opera involving Cyanogen Inc., OnePlus, and Micromax is one of the most talked about … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

black screen during/after call fix

OP brezzz

26th February 2012, 08:48 PM   |  #1  
OP Senior Member
Thanks Meter: 14
 
147 posts
Join Date:Joined: Dec 2010
Hi guys

I know this question has come up quite a few times, but i have just spend the last hour searching all the threads and not really come up with any results. Does anyone know how to get rid of the black screen during/after call issue? I have tried adding ro.lge.proximity.delay=25 and mot.proximity.delay=25 to build.prop but this does not get rid of the issue properly. There is only ever been 1 rom that i have used that managed to get rid of this problem, but they wont tell me how they did it :P and i cant fidure it out lol. Anyone?

thanks

brezzz
27th February 2012, 12:01 PM   |  #2  
sinkster's Avatar
Senior Member
Flag Glasgow
Thanks Meter: 351
 
1,216 posts
Join Date:Joined: Aug 2010
More
I'm not 100% certain what causes it, there seem to be various reasons. I found it was cured by ram management, something like the supercharger script and/or a cache cleaner resolved it. Most, if not all, custom roms don't have the problem due to being stripped of bloatware.
27th February 2012, 08:53 PM   |  #3  
OP Senior Member
Thanks Meter: 14
 
147 posts
Join Date:Joined: Dec 2010
ah ok, everytime i used v6 it seemed to cause problems, just seems weird that it only causes problems when in-call. SE-Tweaked is the only rom that seemed to completely fix the problem but it seems weird that some roms only do it now and again. I used to think its was proximity sensor that caused the problem but it seems worse in sunlight so maybe light sensor?
27th February 2012, 10:12 PM   |  #4  
sinkster's Avatar
Senior Member
Flag Glasgow
Thanks Meter: 351
 
1,216 posts
Join Date:Joined: Aug 2010
More
There's a few things that can cause it, sometimes grease on the sensor or a cover. The fix you used works, but I found it was more like the phone hanging on the call process. Tried increased cpu frequency during call and even an app on the market, but decent ram management does the trick.

sinksterę
The Following User Says Thank You to sinkster For This Useful Post: [ View ]
28th February 2012, 12:37 AM   |  #5  
OP Senior Member
Thanks Meter: 14
 
147 posts
Join Date:Joined: Dec 2010
brilliant, thanks for your help buddy
18th May 2012, 11:38 AM   |  #6  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2007
Hi, Which ROM has the problem solved. I would like to try this, please name the ROM. Thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes