FORUMS

Download Sony’s new AOSP-like concept for Xperia Z3

Over in our forums, Recognized Contributor Jozinek has posted a very … more

OnePlus 2 vs Moto X Style: Which is The Better Flagship?

Two big industry names have announced their newest flagship phones within the … more

Making Your Own Xposed Modules Is Easier Than You Think

Close to the heart of XDA is the Xposed Framework by Rovo89. Most of … more

ZenFone 2 Lolliflash and ZenPower Giveaway!

We recently did an in-depth review of the Asus Zenfone 2 but one of the things people may … more

Cant perm root Mytouch 4G please help before you move my thread

44 posts
Thanks Meter: 5
 
By michael.racelli, Member on 5th March 2012, 11:33 PM
Post Reply Subscribe to Thread Email Thread
I have spent hours on xda, downloading gfree, trying to downgrade, trying taco root. I even unlocked bootloader at htc dev and cannot get my phone perm rooted

I have 2.3.4
software 2.32.531.1

i used the guide on how to downgrade to 2.2.1 for the visionary exploit

i keep getting permission denied
Potential exploit area found at address fbb80e00:200.

I am sorry for sounding like "noob" but i wasted the day trying to do this and have given up

Someone please help me, ill even donate a cup of coffee to whoever helps me fix this. No joke from 9 am to 530 pm, i have been going in circles, i downloaded the htc easy root tool all failed


the farthest i made it was getting temp root with taco root, but there are no clear cut instructions for what to do after, these guides are over a year old prior to my version of android
Last edited by michael.racelli; 5th March 2012 at 11:39 PM.
 
 
5th March 2012, 11:39 PM |#2  
DylanTheVillian's Avatar
Senior Member
Flag Conroe, TX
Thanks Meter: 170
 
More
I'm not sure where your going wrong but the guides work fine. I used them to downgrade, perm root, and flash the engineering bootloader. Have you tried asking in the q and a section? I'm sure you will find a solution, if you ask in the proper place.

Sent from my HTC Glacier using Tapatalk
5th March 2012, 11:41 PM |#3  
cnote74's Avatar
Senior Member
Flag oklahoma city
Thanks Meter: 2,579
 
Donate to Me
More
I would try this guide http://forum.xda-developers.com/show...php?p=15851661

Sent from my HTC Glacier using xda premium
5th March 2012, 11:42 PM |#4  
OP Member
Thanks Meter: 5
 
More
i have been on here for 9 hours going through the q/a this is a brand new str8 from t-mobile mytouch 4g with the newest possible rom, a year ago i successfully did this dozens of time with visionary, its this new rom thats the problem, i put virtuous rom successfully on my first mytouch a year ago, and ive rooted my hd2 for friends and family, so i know my way around xda, this is the first time im truly stuck
5th March 2012, 11:46 PM |#5  
OP Member
Thanks Meter: 5
 
More
cnote 74 i tried that guide my expolit area "fbb80e00:200" is not covered by that guide, if you look at the 5 or 6 lines

$ /data/local/tmp/fre3vo -debug -start 10000000 -end 1FFFFFFF
$ /data/local/tmp/fre3vo -debug -start 20000000 -end 2FFFFFFF
$ /data/local/tmp/fre3vo -debug -start 30000000 -end 3FFFFFFF
$ /data/local/tmp/fre3vo -debug -start F0000000 -end FFFFFFFF
$ /data/local/tmp/fre3vo -debug -start E0000000 -end EFFFFFFF

mine is different than all of these
5th March 2012, 11:59 PM |#6  
OP Member
Thanks Meter: 5
 
More
this is what ive been getting, i followed the guide to the T


C:\AndroidSDK\platform-tools>adb shell cat /dev/msm_rotator
adb server is out of date. killing...
* daemon started successfully *
/dev/msm_rotator: invalid length

C:\AndroidSDK\platform-tools>adb push fre3vo /data/local/tmp
869 KB/s (9796 bytes in 0.011s)

C:\AndroidSDK\platform-tools>adb shell
$ chmod 777 /data/local/tmp/fre3vo
chmod 777 /data/local/tmp/fre3vo
$ /data/local/tmp/fre3vo -debug -start FAA90000 -end FFFFFFFF
/data/local/tmp/fre3vo -debug -start FAA90000 -end FFFFFFFF
fre3vo by #teamwin
Please wait...
Attempting to modify ro.secure property...
fb_fix_screeninfo:
id: msmfb
smem_start: 802160640
smem_len: 3145728
type: 0
type_aux: 0
visual: 2
xpanstep: 0
ypanstep: 1
line_length: 1920
mmio_start: 0
accel: 0
fb_var_screeninfo:
xres: 480
yres: 800
xres_virtual: 480
yres_virtual: 1600
xoffset: 0
yoffset: 800
bits_per_pixel: 32
activate: 16
height: 80
width: 48
rotate: 0
grayscale: 0
nonstd: 0
accel_flags: 0
pixclock: 0
left_margin: 0
right_margin: 0
upper_margin: 0
lower_margin: 0
hsync_len: 0
vsync_len: 0
sync: 0
vmode: 0
Buffer offset: 00000000
Buffer size: 8192
Scanning region faa90000...
Scanning region fab80000...
Scanning region fac70000...
Scanning region fad60000...
Scanning region fae50000...
Scanning region faf40000...
Scanning region fb030000...
Scanning region fb120000...
Scanning region fb210000...
Scanning region fb300000...
Scanning region fb3f0000...
Scanning region fb4e0000...
Scanning region fb5d0000...
Scanning region fb6c0000...
Scanning region fb7b0000...
Scanning region fb8a0000...
Scanning region fb990000...
Scanning region fba80000...
Potential exploit area found at address fbb6c400:c00.
Exploiting device...

C:\AndroidSDK\platform-tools>adb shell
adb server is out of date. killing...
* daemon started successfully *
# exit
exit

C:\AndroidSDK\platform-tools>adb push misc_version /data/local/tmp/misc_version
1718 KB/s (15837 bytes in 0.009s)

C:\AndroidSDK\platform-tools>adb shell chmod 777 /data/local/tmp/

C:\AndroidSDK\platform-tools>adb shell
# cd /data/local/tmp
cd /data/local/tmp
# ./misc_version -s 1.00.000.0
./misc_version -s 1.00.000.0
./misc_version: permission denied
#
6th March 2012, 12:07 AM |#7  
invasion2's Avatar
Senior Member
Flag Space, the ONLY Frontier
Thanks Meter: 1,291
 
More
1st off.......THIS IS THE DEVELOPMENT SECTION! NOT Q&A! THATS WHAT THE Q&A IS FOR!
2nd....its because you unlocked via htcdev, which we have warned users multiple times if you did read the Q&A and General forums.
Htcdev method makes it harder to root/flash a ROM. We warned you. And then you complain and post in the wrong section!
Edit: also.....If you knew to put "DON'T MOVE THREAD", why did you post it here in the first place?

Sent from my HoneySmartDroid Port using XDA Premium.
Last edited by invasion2; 6th March 2012 at 12:33 AM.
6th March 2012, 12:14 AM |#8  
DylanTheVillian's Avatar
Senior Member
Flag Conroe, TX
Thanks Meter: 170
 
More
Edit: I like that better /\

Sent from my HTC Glacier using Tapatalk
Last edited by DylanTheVillian; 6th March 2012 at 12:17 AM.
6th March 2012, 12:46 AM |#9  
ferlogan's Avatar
Senior Member
Flag houston
Thanks Meter: 17
 
More
Chek this out bro hope it help ;) http://forum.xda-developers.com/show....php?p=9551846

Sent from my HTC Mytouch 4G using xda premium
6th March 2012, 12:56 AM |#10  
OP Member
Thanks Meter: 5
 
More
still stuck invasion2 you have a solution
6th March 2012, 01:11 AM |#11  
invasion2's Avatar
Senior Member
Flag Space, the ONLY Frontier
Thanks Meter: 1,291
 
More
Quote:
Originally Posted by michael.racelli

still stuck invasion2 you have a solution

Sorryf for flaming.....anyway I did find something... http://www.forum.xda-developers.com/...php?p=21563546

Sent from my HoneySmartDroid Port using XDA Premium.
Last edited by invasion2; 6th March 2012 at 01:33 AM.

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes