Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,180 Members 39,039 Now Online
XDA Developers Android and Mobile Development Forum

Weirdest Xperia X10i problem

Tip us?
 
Cardotso
Old
#1  
Cardotso's Avatar
Member - OP
Thanks Meter 12
Posts: 41
Join Date: May 2010
Location: Portugal
Exclamation Weirdest Xperia X10i problem

good evening everyone, i have a Xperia X10i in my hands.

here are the problems, the phone was given to me with a usb problem, it doesn't said nothing about mounting usb and on PC it gives always ' unknown device '

the phone had a 2.1 bitsnacker rom. i have made a reset to all data in the phone by doing ' Definitions - privacy - replace .. '

the phone now doesn't vibrate when i press power button, but it showed light in the LED's and vibrated but it's always on boot animation ..

and if i take out the battery, past 5 minutes i put the battery and the phone starts itself !!!

if anyone know something to do with this problem, i would aprecciate any help ..
or i will send it to warranty ..
Device history: Samsung H1; Sony Ericsson Xperia X8; Sony Ericsson Xperia X10; iPhone 3GS; iPhone 4 (the black model and the white model ); Samsung Galaxy S II Black ; Nexus S ; HTC 7 Trophy ; Nokia N8 ; HTC HD2 ; Nokia Lumia 800 ; Galaxy S ; White Xperia Arc S ; now using White Galaxy SII running :

 
XDroidie626
Old
#2  
Senior Member
Thanks Meter 37
Posts: 135
Join Date: Jan 2012

 
DONATE TO ME
Quote:
Originally Posted by Cardotso View Post
good evening everyone, i have a Xperia X10i in my hands.

here are the problems, the phone was given to me with a usb problem, it doesn't said nothing about mounting usb and on PC it gives always ' unknown device '

the phone had a 2.1 bitsnacker rom. i have made a reset to all data in the phone by doing ' Definitions - privacy - replace .. '

the phone now doesn't vibrate when i press power button, but it showed light in the LED's and vibrated but it's always on boot animation ..

and if i take out the battery, past 5 minutes i put the battery and the phone starts itself !!!

if anyone know something to do with this problem, i would aprecciate any help ..
or i will send it to warranty ..
Maybe change back to 2.1 stock and redo the whole root/ROM process if problem still persists stock it again and send it to SE, after all, u dont want any traces of void warrenty.

(Wont be held responsible for any damages, as always )
 
Dauragon
Old
#3  
Junior Member
Thanks Meter 0
Posts: 13
Join Date: Jan 2011
Location: Istanbul
If you don't have anything to loose on your phone (like sms, contact,...)
Don't hesitate to format your phone.
I usually use Sony ericsson Update programme, just plug in your phone to your computer and SE update will do the rest. you can find it in google very easily.
You come back to the stock rom and will be in 2.3 android version.

Good luck
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes