Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Closed

wtf just happened to my phone's usb port?

OP Dioscorus

21st March 2012, 01:53 PM   |  #21  
Senior Member
Thanks Meter: 451
 
1,406 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by sleshepic

If nothing else, its good to learn/confirm from this thread that Sprint will tell you one thing, and completely do another once you deal with someone else, I have had this multiple times. So annoying ...

Sent from my SPH-D710 using xda premium

Sent from my SPH-D710 using xda premium

The issue here is the customer service reps setting wrong expectations. It happens on a daily basis and is a thorn in my side.

A CSR isn't able to visually inspect and triage a device, so I don't see how it can be expected that the CSR can make the absolute decision that a device needs exchanged. Hence, why we need to confirm issues in store.

Sent from my SPH-D710 using xda premium
21st March 2012, 02:42 PM   |  #22  
Member
Thanks Meter: 10
 
32 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by Dioscorus

just washed it off with a little soap and water and it went haywire. red LED came up. no water entered the port. moved connector around and LED went off. went to plug in and physically wouldn't connect to the charger. played around with it more and now it appears the connector is entirely damaged/not present. wtf? how can I get this replaced?

I get what everyone is saying about the whole soap and water thing ruining the phone, but how would the charger physically not connect anymore? That sounds like a lot of corrosion. As in the E4GT is not dishwasher safe level of corrosion, not just a casual wipe down.
Last edited by rdsnyder; 21st March 2012 at 02:51 PM.
21st March 2012, 02:52 PM   |  #23  
jfcooley's Avatar
Senior Member
Flag Charlottesville Va
Thanks Meter: 170
 
578 posts
Join Date:Joined: Jul 2011
More
Sounds more like the op exaggerating to make a case that it wasnt his doing. Chargers do'tt stop connecting overnight (never heard of a charger warping at all) and I seriously doubt there is anything wrong with his device other than user error/water damage.

I thought it was common knowledge soap and water don't mix with electronics.
21st March 2012, 02:58 PM   |  #24  
gronimo21's Avatar
Senior Member
Flag WINTER PARK,FL
Thanks Meter: 146
 
529 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Quote:
Originally Posted by Dioscorus

I don't have insurance. The phone is covered by a one-year warranty. The port failed to connect to a USB cable. see where I'm coming from?

Why don't you have insurance on a phone you must have a awesome job


Sent from my SPH-D710 using XDA
21st March 2012, 03:17 PM   |  #25  
OP Member
Thanks Meter: 6
 
93 posts
Join Date:Joined: Sep 2008
there is no way that water permeated the device and reached the moisture indicators. I wiped the phone down with the case on. no water came near the port. It was somehow damaged, really have no clue as to how.
21st March 2012, 03:20 PM   |  #26  
jfcooley's Avatar
Senior Member
Flag Charlottesville Va
Thanks Meter: 170
 
578 posts
Join Date:Joined: Jul 2011
More
So it would be a coincidence that this happened after cleaning?
21st March 2012, 03:24 PM   |  #27  
xST4T1K's Avatar
Senior Member
Thanks Meter: 219
 
372 posts
Join Date:Joined: Jan 2012
More
Well whether or not they replace it, if the phone works fine besides that, consider getting an external charger
21st March 2012, 03:32 PM   |  #28  
Account currently disabled
Flag phoenix
Thanks Meter: 1,036
 
2,634 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by Dioscorus

just washed it off with a little soap and water and it went haywire. red LED came up. no water entered the port. moved connector around and LED went off. went to plug in and physically wouldn't connect to the charger. played around with it more and now it appears the connector is entirely damaged/not present. wtf? how can I get this replaced?

I read that part when He says he moved it around and then went to plug it in and it's not there ie he broke it
Sent from my SPH-D710 using xda premium
Last edited by Epix4G; 21st March 2012 at 03:34 PM.
21st March 2012, 03:35 PM   |  #29  
OP Member
Thanks Meter: 6
 
93 posts
Join Date:Joined: Sep 2008
I have done so before, when the phone always acted like it was plugged in when I first got it. never malfunctioned like this.
21st March 2012, 03:48 PM   |  #30  
Whosdaman's Avatar
Retired Forum Mod / Recognized Developer / Contributor
Flag Gainesville, Florida
Thanks Meter: 1,426
 
5,650 posts
Join Date:Joined: May 2008
Donate to Me
More
If your liquid indicator isn't tampered with and is still white, and you remove all signs of liquid contact. You can have a replacement done at a Sprint store for $35, or you can send it to Samsung for repair for free. Unfortunately Samsung will take apart the phone and see there is probably liquid damage. Sprint stores won't take apart your phone for a charging port malfunction due to it being a board level issue.

The Following User Says Thank You to Whosdaman For This Useful Post: [ View ]
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes