Post Reply

[Q] Bricked Moto Defy

OP novaproject

21st March 2012, 07:58 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: Feb 2012
HI there. First i want to excuse for my bad english.
So, right into the question. Week ago i tried to flash CM9 on my moto defy. I flashed it, it ran well, when suddenly, after 2-3 days the trebuchet luncher crashed. I reboot my phone and all i got is boot loop. So, i'm a noob , but i tried to fix the problem whit installing one of the SBF's for moto defy+ (didn't notice that, the sbf is for Defy+ not for Defy). Actually the rom ran great, but the camera don't work. So i have a NANDROID backup but the moto defy original recovery, doesn't flash it (it says: "E: failed to verify whole-file signature"). I can't instal clockworkmod, couse i can't root the rom. So, the question is: is there any chance to root my rom and instal clockworkmod or can i fix the original recovery error, so i can apply my backup and downgrade to 2.2 froyo.
The rom that i flashed is ->
4.5.1-134-DFP-231 - retail, vodafon, tmobile, O2, full Blur

I tried to flash other SBF's but they dont work, or can't root either.
I tried to root the rom with everyone possible root exploits posted in this forum... but they doesen't work. I noticed that, there are some SBF's wich are rootable, but the download links doesen't work.
So, what is the exit of this ****ty situation?
Last edited by novaproject; 21st March 2012 at 08:06 PM.
21st March 2012, 10:35 PM   |  #2  
Senior Member
Thanks Meter: 25
 
159 posts
Join Date:Joined: Mar 2011
More
no way out
21st March 2012, 10:42 PM   |  #3  
OP Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: Feb 2012
No way at all???
21st March 2012, 10:54 PM   |  #4  
Senior Member
Thanks Meter: 25
 
159 posts
Join Date:Joined: Mar 2011
More
wait for a miracle.
21st March 2012, 11:00 PM   |  #5  
Senior Member
Thanks Meter: 25
 
159 posts
Join Date:Joined: Mar 2011
More
meanwhile read this :
http://forum.xda-developers.com/show....php?t=1542956

DFP-188, DFP-231, DFP-2311 BL7 Root
22nd March 2012, 07:06 AM   |  #6  
Senior Member
Flag Pune
Thanks Meter: 128
 
380 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Quote:
Originally Posted by novaproject

HI there. First i want to excuse for my bad english.
So, right into the question. Week ago i tried to flash CM9 on my moto defy. I flashed it, it ran well, when suddenly, after 2-3 days the trebuchet luncher crashed. I reboot my phone and all i got is boot loop. So, i'm a noob , but i tried to fix the problem whit installing one of the SBF's for moto defy+ (didn't notice that, the sbf is for Defy+ not for Defy). Actually the rom ran great, but the camera don't work. So i have a NANDROID backup but the moto defy original recovery, doesn't flash it (it says: "E: failed to verify whole-file signature"). I can't instal clockworkmod, couse i can't root the rom. So, the question is: is there any chance to root my rom and instal clockworkmod or can i fix the original recovery error, so i can apply my backup and downgrade to 2.2 froyo.
The rom that i flashed is ->
4.5.1-134-DFP-231 - retail, vodafon, tmobile, O2, full Blur

I tried to flash other SBF's but they dont work, or can't root either.
I tried to root the rom with everyone possible root exploits posted in this forum... but they doesen't work. I noticed that, there are some SBF's wich are rootable, but the download links doesen't work.
So, what is the exit of this ****ty situation?

Okay dude. First thing:
Calm down. If you already are then read on! :P
Since Defy and Defy+ are more than 90% similar in hardware flashing SBF should not be a problem until you don't want downgradability! So from the name of the SBF I guess its for 2.3.6(GB) So now no way can you downgrade to Froyo kernel or for that matter any ROM using Froyo kernel. Am not sure about your ROM but I use the Asia retail SBF (4.5.1-134-DFP-1321 - retail-asia full Blur multilanguage) and I have rooted it using latest superoneclick and modded, rooted and installed CWM recovery umpteen times! So, what you can do is:
1.) Find out version of Android(2.3.4 or 2.3.6) in your phone at present.
2.) Case a:If it is 2.3.4: You can get any kernel and downgradeability is
preserved. There should be no prob faced!
Case b: If you have 2.3.6: You should try the SBF I have since it is rootable.
3.) Now I presume your phone should be working fine with Android 2.3.6.

Let me know if it works and than we can proceed further..

You can also give a try with Walter's fixed SBF and Nandroid backup

PS: A Defy as I understand is almost impossible to Brick!!! Y? Since its bootloader is locked
Last edited by pranks1989; 22nd March 2012 at 07:27 AM. Reason: Added more info
The Following User Says Thank You to pranks1989 For This Useful Post: [ View ]
22nd March 2012, 06:17 PM   |  #7  
OP Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: Feb 2012
HI there, thx for the help
Yes, the installed rom is 2.3.6. I want to change it, couse the battery drain too fast (one day and it's gone) and there's no camera.

I flashed the rom that you said me (4.5.1-134-DFP-1321 - retail-asia full Blur multilanguage), but it's not working.. Doesn't boot at all. After the rom is flashed, the phone reboot and nothing, black screen. Only the white LED light on the upper left corner is activated. I'm giving a try with Walter's fixed SBF now.
Last edited by novaproject; 22nd March 2012 at 06:23 PM.
23rd March 2012, 05:32 PM   |  #8  
OP Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: Feb 2012
Walter's fixed SBF doesen't work too. Same blackscreen...
23rd March 2012, 07:18 PM   |  #9  
Senior Member
Flag Pune
Thanks Meter: 128
 
380 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Quote:
Originally Posted by novaproject

Walter's fixed SBF doesen't work too. Same blackscreen...

Oh! I think similar thing happened with me once when I installed CM9 kernel! This is what I did:

1.) Flash SBF. (Full)
2.) Boot to stock android recovery.
3.) Wipe data and wipe cache.
4.) Reboot.

Well since you already installed a full SBF of 2.3.6 you cannot downgrade! And from what I have seen till now from users experience(and mine) 2.3.6 gives much better battery life. So from now on whenever u use a nightly or ROM use the one for GB(Defy+) builds
24th March 2012, 03:47 PM   |  #10  
OP Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: Feb 2012
This means, that i cannot change the rom anymore?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes