Updated Android Lollipop Preview Images – XDA TV

The Android Lollipop Preview Images are now available! That and much more news is … more

Get a Complete Set of Logs with Andy Log

The importance of proper logging is undeniable. No, we’re not talking about lumberjack work. … more

Try Some Android Lollipop Applications on Your Device

Android 5.0 Lollipop has been officially announced and lucky users of Google Nexus 5 … more

AutoCon Manages Your Connections to Perserve Battery Life

As we’ve talked about in the past, battery life is still somewhat of a sore … more
Post Reply

[Q] SOD when talking on the phone

OP brogdonbr

28th March 2012, 04:13 PM   |  #1  
OP Member
Thanks Meter: 7
 
59 posts
Join Date:Joined: Apr 2007
I hope this is a simple fix, but I've been googling to no avail...

After bringing back my Atrix from the dead (see an earlier post if interested), my phone seems to suffer a SOD when I talk on the phone. This is the only time. I did see a similar problem on another site that gave me some insight. I don't have to do a battery pull--if I simply plug the phone into a power source, it comes right back. But, for some reason, when I talk on the phone, the conversation continues without problems, but the screen won't come back. Needless to say, I can't hang up on someone. If I plug in, suddenly all is well. If I cam away from a power source, a battery pull works.

Does anyone have any idea what would cause the phone dialer to go to sleep and not come back unless I plug in?

To be fair, I realize this isn't exactly a SOD, as it comes back to life when I plug in. But, I don't know if it is useful to describe my Atrix as narcoleptic...
28th March 2012, 04:47 PM   |  #2  
Senior Member
Flag Manchester
Thanks Meter: 36
 
172 posts
Join Date:Joined: Feb 2012
More
What rom are using? cm9?

Sent from my MB860 using XDA
28th March 2012, 04:55 PM   |  #3  
OP Member
Thanks Meter: 7
 
59 posts
Join Date:Joined: Apr 2007
Quote:
Originally Posted by giqbal

What rom are using? cm9?

Sent from my MB860 using XDA

Not anymore. I am waiting for something more stable. I am using CM7...specifically "update-cm-7.2.0-RC1-olympus-signed.zip"
29th March 2012, 11:49 PM   |  #4  
OP Member
Thanks Meter: 7
 
59 posts
Join Date:Joined: Apr 2007
Minor update...
So, the problem still isn't solved, but I found a setting that lets me use the power button to end a call. So, when I get to the end of a phone call, if I hit the power button to end the call first (going to make me popular with friends and family), the call is ended and the phone wakes up normally. If I don't end the call first by hitting the power off, then I have to either do a battery pull or plug in.

Any clues???
30th March 2012, 12:10 AM   |  #5  
Dark9781's Avatar
Senior Member
Thanks Meter: 218
 
689 posts
Join Date:Joined: Apr 2009
It might be an issue from flashing the CM7 rom over the previous rom. Did you try clearing the davik cache and reflashing the rom?
31st March 2012, 01:44 AM   |  #6  
OP Member
Thanks Meter: 7
 
59 posts
Join Date:Joined: Apr 2007
I've tried clearing the Dalvik cache, but I just got all of my apps and settings the way I like them...I'd hate to re-flash unless I absolutely have to.
31st March 2012, 02:53 AM   |  #7  
Senior Member
Thanks Meter: 65
 
341 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by brogdonbr

I've tried clearing the Dalvik cache, but I just got all of my apps and settings the way I like them...I'd hate to re-flash unless I absolutely have to.

Try clearing the cache partition too. Titanium Backup may be worthwhile if you decide to reflash (which would be the best way to solve your problem).

Sent from my MB860 using XDA App

Post Reply Subscribe to Thread

Tags
atrix, dialer, sod
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes