Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,193 Members 36,476 Now Online
XDA Developers Android and Mobile Development Forum

ICS Skyrocket Port: Call Echo Issue

Tip us?
 
Darmokk
Old
#1  
Darmokk's Avatar
Senior Member - OP
Thanks Meter 33
Posts: 242
Join Date: Jun 2011
Location: DFW, TX
Default ICS Skyrocket Port: Call Echo Issue

Flashed the Skyrocket ICS port from Racing, and in addition to the minor issues we've all read about already (screen auto rotation, gallery issues, etc.), This thread is to track the only deal-breaker that can keep this port from being a daily driver IMO, the call echo issue.

If you don't know (or maybe the people you've talked to are too polite to tell you lol) some people are experiencing caller echo on voice calls. Usually the person who is talking to you on the phone hears their own voice echoing back to them, as if you were on a bad cellular connection.

I have got around the issue (somewhat) by using the speakerphone, but obviously that's not a viable longterm fix. I believe if you use a bluetooth headset you can also get around this bug.

Anyone else experiencing this, and if so does anyone know of any work-arounds we could try? Maybe from the play store, or something that's worked on another device?
Samsung Galaxy SIII (Rooted)
Samsung Galaxy Nexus GSM
Apple iPad 3 (jb)
-------------------------------
T-989 Galaxy SII (Retired)
ROM: ICS-Hercules-UCLD2-Racing19969
 
scuzzbag87
Old
#2  
scuzzbag87's Avatar
Senior Member
Thanks Meter 113
Posts: 604
Join Date: Jul 2011
Location: Tustin
Yea I have this issue. Everyone says they hear an echo from my phone

Sent from my SAMSUNG-SGH-I727 using XDA
 
dave2metz
Old
#3  
dave2metz's Avatar
Senior Member
Thanks Meter 173
Posts: 1,141
Join Date: Oct 2010
Location: Clearwater, Florida
Same problem....its almost a deal breaker! Really annoying for people I talk to.

Sent from my SAMSUNG-SGH-T989 using xda premium
ADDICTED TO XDA SINCE 2010

- NEXUS 5 -
 
Darmokk
Old
(Last edited by Darmokk; 30th March 2012 at 10:26 PM.)
#4  
Darmokk's Avatar
Senior Member - OP
Thanks Meter 33
Posts: 242
Join Date: Jun 2011
Location: DFW, TX
Also after some research looks like some people experienced this Call echo bug on their own stock AT&T Skyrockets when they were released.

Many people reported that they could fix the issue by enabling "Noise reduction" in the settings, but I haven't been able to find that option on the T-989.

EDIT: The reason the "noise reduction" option is unable to be found, is because google has removed the feature from ICS. Lots of Galaxy Nexus guys have had issues with call echo and voice quality in general.

Interestingly, a lot of people also got rid of the bug by NOT using their phone cases which seems strange to me. So anyone that has the bug, please try it with and without your case present to see if that helps clear it up.

There are also reports that if turn OFF (uncheck) USB debugging that helps in some cases. I'll test myself and report back
Samsung Galaxy SIII (Rooted)
Samsung Galaxy Nexus GSM
Apple iPad 3 (jb)
-------------------------------
T-989 Galaxy SII (Retired)
ROM: ICS-Hercules-UCLD2-Racing19969
 
minotauri
Old
#5  
Senior Member
Thanks Meter 122
Posts: 507
Join Date: Jun 2008
Location: Seattle, WA

 
DONATE TO ME
i dont think i have this issue. was on the phone with girlfriend for long time as well as tmobile 611 for a while today and no one had issues. i also tried to leave myself a voicemail and it sounded fine. i dont use a case though. i use a ghost armor-like clear film.
PHONE: Google LG Nexus 5, iPhone
TABLET: iPad (3rd Gen)

Twitter: http://www.twitter.com/antnguyen
 
Darmokk
Old
#6  
Darmokk's Avatar
Senior Member - OP
Thanks Meter 33
Posts: 242
Join Date: Jun 2011
Location: DFW, TX
Quote:
Originally Posted by minotauri View Post
i dont think i have this issue. was on the phone with girlfriend for long time as well as tmobile 611 for a while today and no one had issues. i also tried to leave myself a voicemail and it sounded fine. i dont use a case though. i use a ghost armor-like clear film.
I'm not using a case at all and still get the echo issue.

As a temporary fix, I've found you can turn speakerphone on and then off real quick and that helps quite a bit (although it doesn't go away completely). the only annoying thing is you'd have to do that each time you made a call or answered the phone.
Samsung Galaxy SIII (Rooted)
Samsung Galaxy Nexus GSM
Apple iPad 3 (jb)
-------------------------------
T-989 Galaxy SII (Retired)
ROM: ICS-Hercules-UCLD2-Racing19969
 
capcanuck
Old
#7  
capcanuck's Avatar
Senior Member
Thanks Meter 427
Posts: 1,034
Join Date: May 2011
Just tried the usb debugging unchecked, no dice.

Sent from my SAMSUNG-SGH-T989 using Tapatalk
 
Darmokk
Old
#8  
Darmokk's Avatar
Senior Member - OP
Thanks Meter 33
Posts: 242
Join Date: Jun 2011
Location: DFW, TX
Yeah USB debugging has no effect for me either, nor does using a particular case or not using one at all. Same result.
Samsung Galaxy SIII (Rooted)
Samsung Galaxy Nexus GSM
Apple iPad 3 (jb)
-------------------------------
T-989 Galaxy SII (Retired)
ROM: ICS-Hercules-UCLD2-Racing19969
 
GreggoryD502
Old
#9  
GreggoryD502's Avatar
Senior Member
Thanks Meter 215
Posts: 1,889
Join Date: Sep 2010
Location: Louisville
I have this issue if I have q case on it. The d30 case was horrible. With out a case tho its fine.

Sent from my SGH-T989 using xda premium
Oneplus One





Use my dropbox link and get us both 250mb extra free
http://db.tt/48zDulPV
The Following User Says Thank You to GreggoryD502 For This Useful Post: [ Click to Expand ]
 
capcanuck
Old
#10  
capcanuck's Avatar
Senior Member
Thanks Meter 427
Posts: 1,034
Join Date: May 2011
Quote:
Originally Posted by GreggoryD502 View Post
I have this issue if I have q case on it. The d30 case was horrible. With out a case tho its fine.

Sent from my SGH-T989 using xda premium
Sure enough. I had the d30 case, just traded for body glove, no more echo. Thanks man

Sent from my SAMSUNG-SGH-T989 using Tapatalk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes