Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[UPDATED 5/22][AT&T DATA FIX] AT&T's HSPA+ APN's

OP Ghstudent

1st April 2012, 05:16 PM   |  #1  
Ghstudent's Avatar
OP Senior Member
Thanks Meter: 378
 
814 posts
Join Date:Joined: Mar 2012
Donate to Me
More
My First Guide!
Flashable Zips at the bottom!
Okay, so i have seen a post claiming to fix the APN settings, however this is the only true one i have found (credits to shoman for these, i picked them out of his rom!).
it is pretty self explanatory, any field that requires you to put something in it has something in it, otherwise it has a -. underlined means that it is a new apn (settings->more->mobile networks->access point names->"menu" button->new apn)
MAKE SURE YOU SAVE THEM!!
Code:
Name: ATT MMS
APN: wap.cingular
Proxy: wireless.cingular.com
Port: 80
Username: -
Password: -
Server: -
MMSC: http://mmsc.cingular.com/
MMS Proxy: wireless.cingular.com
MMS Port: 80
MCC: 310
MNC: 410
Authentication Type: -
APN Type: mms,supl
APN Protocol: ipv4

Name: ATT PHONE
APN: phone
Proxy: -
Port: -
Username: -
Password: -
Server: -
MMSC: -
MMS Proxy: -
MMS Port: -
MCC: 310
MNC: 410
Authentication Type: -
APN Type: default,internet
APN Protocol: ipv4
then, once all of these have been entered, make sure that the one labeled "ATT PHONE" has the tick to the right of the name filled in (this is your default!) reply with any questions and i will try my best to help!
MIUI currently will not send MMS with these settings. Looking for a solution!
EDIT: Some ROMs require you to flash your modem manually!
-->click here for modem links<--
Last edited by Ghstudent; 23rd May 2012 at 02:28 AM.
The Following 45 Users Say Thank You to Ghstudent For This Useful Post: [ View ]
1st April 2012, 05:45 PM   |  #2  
Senior Member
Thanks Meter: 34
 
199 posts
Join Date:Joined: Aug 2008
There's a typo in your MMS settings. The MMSC should read http://mmsc.cingular.com.
The Following User Says Thank You to MacAlert For This Useful Post: [ View ]
1st April 2012, 05:46 PM   |  #3  
Ghstudent's Avatar
OP Senior Member
Thanks Meter: 378
 
814 posts
Join Date:Joined: Mar 2012
Donate to Me
More
Quote:
Originally Posted by MacAlert

There's a typo in your MMS settings. The MMSC should read http://mmsc.cingular.com.

good eye, thanks, the sad thing is i actually corrected that once before...
1st April 2012, 05:52 PM   |  #4  
sykoj82's Avatar
Senior Member
Flag Merrimack, NH
Thanks Meter: 443
 
1,084 posts
Join Date:Joined: Jan 2012
More
Yeah these settings really do work, I was averaging 3-4 mbps download before with the old settings and now its a constant 5-7 mbps in Merrimack NH

Sent from my SGH-I777 using XDA
1st April 2012, 06:23 PM   |  #5  
MattMJB0188's Avatar
Senior Member
Flag Chicago, IL
Thanks Meter: 205
 
1,346 posts
Join Date:Joined: Apr 2011
More
I'm assuming this is for ICS? I'm on a stock rom and don't have the option to add anything under APN. ):
1st April 2012, 07:19 PM   |  #6  
Ghstudent's Avatar
OP Senior Member
Thanks Meter: 378
 
814 posts
Join Date:Joined: Mar 2012
Donate to Me
More
Quote:
Originally Posted by MattMJB0188

I'm assuming this is for ICS? I'm on a stock rom and don't have the option to add anything under APN. ):

yes it is, and are you sure? go under your settings to more (should be under data usage) -> mobile networks -> access point names.
1st April 2012, 07:21 PM   |  #7  
Ghstudent's Avatar
OP Senior Member
Thanks Meter: 378
 
814 posts
Join Date:Joined: Mar 2012
Donate to Me
More
Quote:
Originally Posted by sykoj82

Yeah these settings really do work, I was averaging 3-4 mbps download before with the old settings and now its a constant 5-7 mbps in Merrimack NH

Sent from my SGH-I777 using XDA

glad that they helped!
1st April 2012, 09:03 PM   |  #8  
MattMJB0188's Avatar
Senior Member
Flag Chicago, IL
Thanks Meter: 205
 
1,346 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by Ghstudent

yes it is, and are you sure? go under your settings to more (should be under data usage) -> mobile networks -> access point names.

Yea, Gingerbread must be different. That's ok because what ever APN settings Ryude is using in UnOriginal works just fine. Though coming from an iPhone 4s, data speeds on the GSII are faster when your closer to the tower. I was able to get faster speeds with 2-3 bars on the 4s. Oh well. Uploads speeds don't seem as great on the GSII. With the 4s I could get 7 down and 4 up. See my attachment for GSII results.

The Following User Says Thank You to MattMJB0188 For This Useful Post: [ View ]
1st April 2012, 09:27 PM   |  #9  
Galaxy_Cat's Avatar
Senior Member
Flag San Francisco
Thanks Meter: 53
 
156 posts
Join Date:Joined: Mar 2012
More
Download Tweakker, run, enjoy. For CM7 folks, this fixes the default APN setting.

CM7.2
UCKJ4
SIYAH 2.6.14
ExTweaks, Tweakker

Sent from my SGH-I777 using XDA
2nd April 2012, 04:40 PM   |  #10  
Junior Member
Flag Dallas, TX
Thanks Meter: 1
 
11 posts
Join Date:Joined: Oct 2011
More
Thumbs up Working OK in Dallas
Thanks for the TIP! This is working well in Dallas, TX area.

Post Reply Subscribe to Thread

Tags
apn, slow data speeds
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes