Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Anyone else notice the amazon app store being a battery hog recently?

OP R1ptide

7th April 2012, 01:46 AM   |  #1  
OP Senior Member
Thanks Meter: 130
 
463 posts
Join Date:Joined: Sep 2011
More
Ever since the latest update, well actually since the old version started asking me to update, the amazon appstore has been in the top 2 apps for battery usage. I don't remember this being the case before.

Just me?
7th April 2012, 01:52 AM   |  #2  
Member
Thanks Meter: 8
 
52 posts
Join Date:Joined: Jun 2007
Disable notifications and automatic updates, seems to have no effect after that

Sent from my SPH-D710 using Tapatalk
8th April 2012, 03:54 AM   |  #3  
rwilco12's Avatar
Forum Moderator / Recognized Developer / AndroidFileHost Rep
Thanks Meter: 11,790
 
3,345 posts
Join Date:Joined: Feb 2012
Donate to Me
More
Quote:
Originally Posted by R1ptide

Ever since the latest update, well actually since the old version started asking me to update, the amazon appstore has been in the top 2 apps for battery usage. I don't remember this being the case before.

Just me?

I haven't had it with Amazon Appstore but I've had it with random apps here and there. Generally something gets hung up in the app and keeps it running in the background. I've found that clearing the cache (and in some cases clearing data) will fix it.

Good luck!
9th April 2012, 09:21 PM   |  #4  
OP Senior Member
Thanks Meter: 130
 
463 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by rwilco12

I haven't had it with Amazon Appstore but I've had it with random apps here and there. Generally something gets hung up in the app and keeps it running in the background. I've found that clearing the cache (and in some cases clearing data) will fix it.

Good luck!

Thanks
I cleared cache, uninstalled, and reinstalled fresh and that fixed it.

The app itself is much more responsive now, was really really laggy before so something was definitely off.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes