Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,510 Members 55,292 Now Online
XDA Developers Android and Mobile Development Forum

[REQ] Gtalk with Video over 3G/H+ AT&T

Tip us?
 
zanef7
Old
(Last edited by zanef7; 11th April 2012 at 06:28 PM.) Reason: FIX FOUND
#1  
zanef7's Avatar
Senior Member - OP
Thanks Meter 7
Posts: 216
Join Date: Apr 2007
Location: DC/MD/VA Metro Area

 
DONATE TO ME
Default [REQ] Gtalk with Video over 3G/H+ AT&T

Looking for a modded version of Gtalk that allows video over 3G/H+. I can make Skype video calls on the connection so there's no reason its not possible on Gtalk. If anyone has the know how it would be highly appreciated!

I'm assuming some code would have to be modified that allows AT&T to block the connection when its being made. That or Gtalk has code blocking connections without Wi-Fi. Either way I'm sure it can be changed, just don't have the know how.

Thanks
Zane

SQLITE didn't work for me - But gtalkenabler in the Play store works!
HTC One X - AT&T Viper XL ROM ---> HTC One - AT&T (on US release day)
 
Raspster
Old
#2  
Raspster's Avatar
Senior Member
Thanks Meter 14
Posts: 1,029
Join Date: Jun 2007
I beleive this is a restriction thru at&t. I don't remember EVER seeing a modded version of gtalk that will allow video calling over at&t's 3g/4g HSPA network. Even with the modded version for gingerbread, it never worked 100% with video over 3g for at&t. Someone told me it's something with at&t that is blocking this. Also, you need to be rooted for a modded version of gtalk to be installed.
 
krohnjw
Old
#3  
krohnjw's Avatar
Recognized Developer
Thanks Meter 527
Posts: 1,980
Join Date: Jul 2007
Location: Plainfield
Quote:
Originally Posted by Raspster View Post
I beleive this is a restriction thru at&t. I don't remember EVER seeing a modded version of gtalk that will allow video calling over at&t's 3g/4g HSPA network. Even with the modded version for gingerbread, it never worked 100% with video over 3g for at&t. Someone told me it's something with at&t that is blocking this. Also, you need to be rooted for a modded version of gtalk to be installed.
There's no reason to mod the APK. Just override it in the gservices DB (root needed)

http://forum.xda-developers.com/show...5&postcount=24
 
Raspster
Old
#4  
Raspster's Avatar
Senior Member
Thanks Meter 14
Posts: 1,029
Join Date: Jun 2007
FYI - Last update to one x is now allowing GTalk video over wifi with no root needed. It must have been the 1.28 update because I was NOT able to get this working until I just tried it again after the update. I am NOT rooted also. This is real good news. - FYI - This is NOT working in other phones from at&t as it's still not working on my friends vivid with ICS update. Atleast for non-rooted people.
 
Crappyvate
Old
#5  
Crappyvate's Avatar
Senior Member
Thanks Meter 207
Posts: 662
Join Date: Jul 2011
Location: Isla de Vieques
Quote:
Originally Posted by krohnjw View Post
There's no reason to mod the APK. Just override it in the gservices DB (root needed)

http://forum.xda-developers.com/show...5&postcount=24
the gservices.db seems to have changed with gtalk 4.0.4 the 'gtalk_vc_wifi_only' entry is no longer there ?

Any thoughts on being able to activate video over data ?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes