5,598,938 Members 30,657 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia Play Won't Turn On

Tip us?
 
bluetoon
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2012
Default [Q] Xperia Play Won't Turn On

I am currently trying to fix a friend's Xperia Play r800a. It seems to be having a few different problems and together they are making it all difficult to get it going again. First off I have no real knowledge of toying with an Android phone. I browsed some threads on here, used Google and tried to use Flashtool to get the original operating system on it but all were a no go. I'll try and describe the problems to the best of my abilities and maybe someone can offer some help.

This is what I know from what he remembers he did to the phone. He said that the phone started t only boot to the Sony logo and then it would hang until the battery died or the phone was reset. If plugged in with a wall charger then it would allow him to get to the screen where he would enter his password but the touch screen wouldn't work. He then flashed it using Flashtool and at that point it would boot to a black screen and that's it.

-It hangs on a black screen, no logo or anything is present and it happens regardless of whether it is plugged into a wall charger or not.

-It is not found when plugged into the USB port (Windows 7 PC) and shows up as an unknown device. After a few minutes it is found by the PC but sometimes will randomly go back to an unknown device.

-I sometimes get a red light which blinks three times when I press the power button on the phone. I am currently charging it to see if it was a matter of being a dead battery or something worse (I heard it could be a hardware failure).

Any suggestions would be appreciated.
 
Xperia4life
Old
#2  
Senior Member
Thanks Meter 41
Posts: 226
Join Date: Apr 2012
Location: Hitchin
My Xperia Play has done This I asked a Mate (Jinx13) He said Il do a hardcore Testpoint process. After I have done this My Phone will Vibrate and Nothing I was Playing Rayman today and it Locks and Hardware Keys Do Not respond.
Then Touchscreen Stopped Working. Indeed This is a Hardware Failure I have got this and Re-Flashing with Blinking SETOOL2 and Resseting it Wouldn't work. I Then Re-Locked By fastboot SIM and Bootloader (Maintained DRM) and Now Dowloading R800i O2-UK From SETOOL Support and 3-UK one and I will Upload them for US people for Warranty they Become indeed handy . I now Am Going to O2 shop I was Running 2.3.4 .42 GENERIC.But I am Not allowed to Give you the FW's Only by Re-Uploading I Can. Anyway My Brave Soldier Died (Hardware Failure) Its the Screen Components.Im Not Rooted anymore and Re-locked with S1-Tool.
If this happens to you My advice is Dont Flash Alpha ROM's They can make Your device Coo Coo. And OC can Damage.
Basically I boot My phone with a 3600MAH Mugen Battery 89% Battery From the Last time It was on. Im afraid your friends Phone is Dead Maybe a Hardware Failure Most Likly and I am now Officialy Out of the Game.
But O2 Gave me 3 Year warranty!!!!! For 100 When I Purchased it. So I am Going to O2 in Stevenage and Say this What actually happend:
"I Purchased My Xperia Play on August 17th Through Online Store ; I have never had a Problem With My device Untill This week : I have had these Issues:
*Touchscreen Wont respond Cleaned Several Times.
*Random Reboots
*Red Light when Phone had 50%+ Battery
*Would Take 6 Battery Pulls to Turn on (Would Only turn on Earlier during the week)
*Lagged In games.
*Running O2 Branded Software
*No Screen Brightness or Signs of Working Screen.
*Would Not charge Unless turned On
*Camera Would Not work Unless Wifi Was not on I dont know why?
So Basically This Phone had a A fault since Day one I always had Camera Fails.

Like my work please donate!
USD (US dollar)
https://www.paypal.com/cgi-bin/websc...=GXZXW5THXS7AY

 
biggyhead
Old
(Last edited by biggyhead; 11th April 2012 at 07:11 AM.)
#3  
Senior Member
Thanks Meter 19
Posts: 114
Join Date: Mar 2012
Quote:
Originally Posted by bluetoon View Post
I am currently trying to fix a friend's Xperia Play r800a. It seems to be having a few different problems and together they are making it all difficult to get it going again. First off I have no real knowledge of toying with an Android phone. I browsed some threads on here, used Google and tried to use Flashtool to get the original operating system on it but all were a no go. I'll try and describe the problems to the best of my abilities and maybe someone can offer some help.

This is what I know from what he remembers he did to the phone. He said that the phone started t only boot to the Sony logo and then it would hang until the battery died or the phone was reset. If plugged in with a wall charger then it would allow him to get to the screen where he would enter his password but the touch screen wouldn't work. He then flashed it using Flashtool and at that point it would boot to a black screen and that's it.

-It hangs on a black screen, no logo or anything is present and it happens regardless of whether it is plugged into a wall charger or not.

-It is not found when plugged into the USB port (Windows 7 PC) and shows up as an unknown device. After a few minutes it is found by the PC but sometimes will randomly go back to an unknown device.

-I sometimes get a red light which blinks three times when I press the power button on the phone. I am currently charging it to see if it was a matter of being a dead battery or something worse (I heard it could be a hardware failure).

Any suggestions would be appreciated.

okay lol i don't know if that second post helped but is the phone unlocked? by any chance if it is, you can never really brick your xperia, from experience i kept flashing re flashing cusom kernal all day i get the same loops etc, but always fixable, also flash tool should fix your phone if that is you got the right ftf file for the brand like i have verizon and it have a verizon.ftf file, other than that i need more info about the phone not how it bricked, like what was it running at first etc. Try sony software reflashing repairing if that doesn't work use flashtool and see if you get an error with that
 
Xperia4life
Old
#4  
Senior Member
Thanks Meter 41
Posts: 226
Join Date: Apr 2012
Location: Hitchin
I cant enter fastboot or recovery lol

Like my work please donate!
USD (US dollar)
https://www.paypal.com/cgi-bin/websc...=GXZXW5THXS7AY

The Following User Says Thank You to Xperia4life For This Useful Post: [ Click to Expand ]
 
biggyhead
Old
#5  
Senior Member
Thanks Meter 19
Posts: 114
Join Date: Mar 2012
Quote:
Originally Posted by Xperia4life View Post
I cant enter fastboot or recovery lol
lol xD oh danm only possible way i think is to try flash tool and downloading the ftf file for your phone and let me know if you get any errors
 
NevErSn0w
Old
#6  
Member
Thanks Meter 1
Posts: 35
Join Date: Sep 2012
Quote:
Originally Posted by biggyhead View Post
lol xD oh danm only possible way i think is to try flash tool and downloading the ftf file for your phone and let me know if you get any errors
my phone is having the exact same problem, it wont recover through pc companion and flashtool wont even work cause I cant get my phone into flashmode.
are there any other tricks that might get my beast running again?
 
Solar.Plexus
Old
#7  
Senior Member
Thanks Meter 321
Posts: 1,279
Join Date: Jan 2012
Quote:
Originally Posted by NevErSn0w View Post
my phone is having the exact same problem, it wont recover through pc companion and flashtool wont even work cause I cant get my phone into flashmode.
are there any other tricks that might get my beast running again?
How are you trying to get into Flashmode?

Sent from my Slider SL101
R800x: Stock ROM, modified
NOOK Tablet 16GB: LiquidSmooth ROM
Eee Pad SL101 32GB White: need to get rid of
TF700T 64GB Champagne: also need to get rid of
TF701T 32GB Gray: Full Stock

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...