Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,035 Members 40,796 Now Online
XDA Developers Android and Mobile Development Forum
Announcement from Diamondback: Check out the new 3.x Beta version with the all new script system

[IDE][3.6.30.14100] Virtuous Ten Studio - Advanced Reverse Engineering Solution

Tip us?
 
movelbit
Old
#11  
movelbit's Avatar
Senior Member
Thanks Meter 89
Posts: 454
Join Date: Nov 2008
Location: Valongo
installing right now.

looks great. been subscribed to the preview topic waiting for this day

setup wants to download aditional files such as .net framework 4.

cant those be included in a more complete / advanced setup?
The Following User Says Thank You to movelbit For This Useful Post: [ Click to Expand ]
 
Diamondback
Old
#12  
Diamondback's Avatar
Developer Committee / Senior Moderator / Recognized Developer - OP
Thanks Meter 6,338
Posts: 4,383
Join Date: Jan 2010
Quote:
Originally Posted by bitmovel View Post
installing right now.

looks great. been subscribed to the preview topic waiting for this day

setup wants to download aditional files such as .net framework 4.

cant those be included in a more complete / advanced setup?
Why exactly would you want that? What's the advantage over letting the installer download the files?

Contact the Developer Committee with any questions or concerns regarding
the Recognized Developer program.
Mention my name with @Diamondback in any post to easily get my attention.
Please use BB Codes to format your posts.
The Following User Says Thank You to Diamondback For This Useful Post: [ Click to Expand ]
 
Diamondback
Old
#13  
Diamondback's Avatar
Developer Committee / Senior Moderator / Recognized Developer - OP
Thanks Meter 6,338
Posts: 4,383
Join Date: Jan 2010
Also, if something doesn't work directly from the start (can always happen) feel free to come to #vts-dev on freenode, it's much easier to troubleshoot things via IRC.

Contact the Developer Committee with any questions or concerns regarding
the Recognized Developer program.
Mention my name with @Diamondback in any post to easily get my attention.
Please use BB Codes to format your posts.
The Following User Says Thank You to Diamondback For This Useful Post: [ Click to Expand ]
 
Alex-V
Old
#14  
Alex-V's Avatar
Recognized Developer
Thanks Meter 4,180
Posts: 7,980
Join Date: Aug 2008
5 stars..for this and many thx

with kind regards..Alex
 
Dunc001
Old
#15  
Dunc001's Avatar
Recognized Developer
Thanks Meter 1,334
Posts: 2,610
Join Date: Apr 2010
Location: Hiding out south of the border...
Faaaaaaaaark! Downloading now. Ben waiting so long... am I dreaming Any news on m10?
HTC One
ViperOne 6.2.1+ Beta Sense 6.0 with Kangaroo Kernel

HTC One Mini
Completely stock and staying that way...

Google Nexus 7 Gen 2
MIUI 5-09

First HTC HD2
Tytung 4.4.2 DataOnExt

Second HTC HD2
MIUI JB DataOnExt
The Following User Says Thank You to Dunc001 For This Useful Post: [ Click to Expand ]
 
lyon21
Old
#16  
Account Currently Disabled
Thanks Meter 201
Posts: 750
Join Date: Feb 2011
Location: Chicago
Thanks a lot man! I will definitely be checking this out tonight or tomorrow night!
 
Ghost
Old
#17  
Ghost's Avatar
Forum Moderator / Retired Recognized Developer
Thanks Meter 4,025
Posts: 5,844
Join Date: Jul 2010
Location: XDA MODERATOR
This is an awsome tool! Hopefully you can help me. I am using an ICS sense 3.6 rom for the sensation. 3.32.401.5_R.

I have taken the framework-res.apk file from it and used V10 studio to decompile. It decompiles fine and I was able to edit a couple of apk files as a test. I then tried to compile and got apktool failed exit code 1.

Now interestingly I took the same framework-res.apk file and ran it through UOT kitchen to make the battery mod. I then used it on V10, decompiled and recompiled with out any errors. Any idea why the origional apk wont recompile?
 
Diamondback
Old
#18  
Diamondback's Avatar
Developer Committee / Senior Moderator / Recognized Developer - OP
Thanks Meter 6,338
Posts: 4,383
Join Date: Jan 2010
Quote:
Originally Posted by GhostXSeries View Post
This is an awsome tool! Hopefully you can help me. I am using an ICS sense 3.6 rom for the sensation. 3.32.401.5_R.

I have taken the framework-res.apk file from it and used V10 studio to decompile. It decompiles fine and I was able to edit a couple of apk files as a test. I then tried to compile and got apktool failed exit code 1.

Now interestingly I took the same framework-res.apk file and ran it through UOT kitchen to make the battery mod. I then used it on V10, decompiled and recompiled with out any errors. Any idea why the origional apk wont recompile?
Most likely because the kitchen uses another ApkTool version.

sometimes older/newer versions fix issues with other versions. It might sound strange but that's the way it works
If you get apktool errors you need to play around with the different versions to get optimal results. Unfortunately there is no versions which fixes every issue

Remember that you can set the ApkTool binary in the project settings.

Contact the Developer Committee with any questions or concerns regarding
the Recognized Developer program.
Mention my name with @Diamondback in any post to easily get my attention.
Please use BB Codes to format your posts.
The Following User Says Thank You to Diamondback For This Useful Post: [ Click to Expand ]
 
Ghost
Old
#19  
Ghost's Avatar
Forum Moderator / Retired Recognized Developer
Thanks Meter 4,025
Posts: 5,844
Join Date: Jul 2010
Location: XDA MODERATOR
Cool, I'm actually starting to think it may be an issue with the rom not being deodexed properly. I will play arround with it and see how it goes!
 
Ghost
Old
#20  
Ghost's Avatar
Forum Moderator / Retired Recognized Developer
Thanks Meter 4,025
Posts: 5,844
Join Date: Jul 2010
Location: XDA MODERATOR
When compiling the framework-res.apk I am getting a weird error. It says:

Multiple substitutions sepesified in non-positional format; did you mean to add the formatted-"false" attribute?

In in each of the values folders it has an issue with the plurals.xml file and has entires

data\res\values\plurals.xml:79 error Found tag </item. were </plurals> is expected.

I had a look and the plurals.xml file is ok. Is there any reason for these errors?

Tags
adb, all in one, apk, apk manager, apk multi tool, apktool, dex2jar, draw9patch, dsixda, ide, java, logcat, m10 files, m10 images, m10 tools, resources, sense, sense skins, smali, super powerful, syntax highlighting, theming, visual studio, vts, xml
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes