Post Reply

Proposal to set dalvik-vm optimizing all code

OP hunderteins

14th May 2012, 05:17 PM   |  #31  
Senior Member
Flag Tarsus
Thanks Meter: 130
 
569 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Quote:
Originally Posted by _n0p_

128-1344, ondemand.

Which kernel did you use Sergei?
14th May 2012, 05:21 PM   |  #32  
_n0p_'s Avatar
Senior Member
Flag Kiev
Thanks Meter: 1,827
 
2,557 posts
Join Date:Joined: Apr 2009
More
DSC Team Phoenix Universal
14th May 2012, 05:50 PM   |  #33  
Senior Member
Flag Tarsus
Thanks Meter: 130
 
569 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Quote:
Originally Posted by _n0p_

DSC Team Phoenix Universal

Is it capable over 1267 MHz for overclocking?
14th May 2012, 06:01 PM   |  #34  
_n0p_'s Avatar
Senior Member
Flag Kiev
Thanks Meter: 1,827
 
2,557 posts
Join Date:Joined: Apr 2009
More
Quote:
Originally Posted by sinan33

Is it capable over 1267 MHz for overclocking?

You see, in previous kernel builds I made an error in stepping table values, so 1267 was actually 1344, and 998 was 1075.
Now I fixed it.
Sorry
14th May 2012, 06:26 PM   |  #35  
Senior Member
Flag Tarsus
Thanks Meter: 130
 
569 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Quote:
Originally Posted by _n0p_

You see, in previous kernel builds I made an error in stepping table values, so 1267 was actually 1344, and 998 was 1075.
Now I fixed it.
Sorry

So how can i set it from init.postboot.streak.sh?
14th May 2012, 06:41 PM   |  #36  
_n0p_'s Avatar
Senior Member
Flag Kiev
Thanks Meter: 1,827
 
2,557 posts
Join Date:Joined: Apr 2009
More
Quite simple.
Code:
 #CPU
echo "conservative" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo 70 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/up_threshold
echo 30 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/down_threshold
echo 200000 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/sampling_rate
echo 1 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/sampling_down_factor
echo 128000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
#echo 245760 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
echo 998400 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
echo 50 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/freq_step
in postboot.

Change "conservative" to "ondemand", 998400 to 1344000.
Reboot.
Note that I personally find overclock more stable with undervoltage on.
Refer to Phoenix Universal kernel in DSC thread on enabling UV manually.
More, kernel sets high frequencies using 384 and 768 MHz as middle values, so it may be safe using ondemand - TPS chip should handle it.

Also, let's move this discussion elsewhere, as it's off topic here. Thank you.
Last edited by _n0p_; 14th May 2012 at 06:59 PM.
The Following User Says Thank You to _n0p_ For This Useful Post: [ View ]
14th May 2012, 06:55 PM   |  #37  
Senior Member
Flag Tarsus
Thanks Meter: 130
 
569 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Quote:
Originally Posted by _n0p_

Quite simple.

Code:
 #CPU
echo "conservative" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo 70 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/up_threshold
echo 30 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/down_threshold
echo 200000 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/sampling_rate
echo 1 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/sampling_down_factor
echo 128000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
#echo 245760 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
echo 998400 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
echo 50 > /sys/devices/system/cpu/cpu0/cpufreq/conservative/freq_step
in build.prop.

Change "conservative" to "ondemand", 998400 to 1344000.
Reboot.
Note that I personally find overclock more stable with undervoltage on.
Refer to Phoenix Universal kernel in DSC thread on enabling UV manually.
More, kernel sets high frequencies using 384 and 768 MHz as middle values, so it may be safe using ondemand - TPS chip should handle it.

Also, let's move this discussion elsewhere, as it's off topic here. Thank you.

Thank you Sergei,i was using these settings Just changed 1267200 to 1344000
22nd May 2012, 04:15 PM   |  #38  
(InsertNameHere)'s Avatar
Senior Member
Thanks Meter: 284
 
956 posts
Join Date:Joined: Jan 2010
Quote:
Originally Posted by hunderteins

LuckyPatcher and other programs have a problem with optimized dalvik-cache for classes that aren't verified. So I set up

dalvik.vm.dexopt-flags=v=a,o=v,u=y,m=y

it is like: verify=all dexopt=verified uniprocessor=yes registermaps=yes

Now LuckyPatcher works again, the boot takes not really more time, cache-size is the same as before and this uses register mapping. I'll give it a try a week or two.

have a nice weekend,
hunderteins

Thanks for all your work, is this now confirmed as a definitive tweak that doesn't break anything?

The Following User Says Thank You to (InsertNameHere) For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
dalvik-vm, optimize
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes