Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Damn Captivate

OP UMGixxer

1st May 2012, 01:16 PM   |  #1  
OP Senior Member
Thanks Meter: 14
 
380 posts
Join Date:Joined: Jun 2008
Well all has been fairly well with my cappy up until yesterday. Out of nowhere my freaking power button stopped working, so when I get a text message I cant unlock the phone to view it. I had to plug it into the charger or wait for an incoming call to unlock the phone which sucks. Good news is that the custom rom I have installed allowed me to use my volume keys to unlock the phone but still no power button to reboot or anything. Even with a battery pull the phone just automatically boots up when I put the battery back in but oh well. On the good side, I will have my HOX very soon, on the bad side I wont be able to sell my cappy since the power button is tripping. Hopefully it will fix itself over the next few days so I can sell it. Even more reason that I need my HOX asap.
1st May 2012, 02:10 PM   |  #2  
Senior Member
Flag Shepherdstown, WV
Thanks Meter: 31
 
316 posts
Join Date:Joined: Aug 2009
More
Quote:
Originally Posted by UMGixxer

Well all has been fairly well with my cappy up until yesterday. Out of nowhere my freaking power button stopped working, so when I get a text message I cant unlock the phone to view it. I had to plug it into the charger or wait for an incoming call to unlock the phone which sucks. Good news is that the custom rom I have installed allowed me to use my volume keys to unlock the phone but still no power button to reboot or anything. Even with a battery pull the phone just automatically boots up when I put the battery back in but oh well. On the good side, I will have my HOX very soon, on the bad side I wont be able to sell my cappy since the power button is tripping. Hopefully it will fix itself over the next few days so I can sell it. Even more reason that I need my HOX asap.

Funny thing, I gave my old Captivate to my mother since she never uses the GPS anyways, and last night she texted me about the same thing. She said it has been doing this for a month at least... funny two of them would start acting up at about the same time- nearing upgrade time (but not quite there yet , and shortly before the announcement for the GSIII...
I'm not one for conspiracy theories, but it is notable...
1st May 2012, 02:18 PM   |  #3  
OP Senior Member
Thanks Meter: 14
 
380 posts
Join Date:Joined: Jun 2008
Oh I am one to believe that things tend to run out of juice on purpose. Just like cars, they tend to mess up right as the warranty expires lol
1st May 2012, 02:31 PM   |  #4  
x3phyr's Avatar
Senior Member
Flag Saranac, Michigan
Thanks Meter: 46
 
270 posts
Join Date:Joined: Jul 2010
More
this happened to me as well, in mid january. This is why my captivate is now officially retired. Thrown at the cement as hard as I possibly could retired. The charging port also stopped working so it was useless and I felt like taking out the anger it caused rather than parting it out.

I took mine apart, and blew out the lock button with compressed air and that worked alright for a bit, until it ended up stopping working completely and I mapped the volume up rocker to wake the phone. That worked for awhile.
1st May 2012, 02:44 PM   |  #5  
OP Senior Member
Thanks Meter: 14
 
380 posts
Join Date:Joined: Jun 2008
Happen to have a guide to open this thing up?
1st May 2012, 03:59 PM   |  #6  
Member
Thanks Meter: 2
 
34 posts
Join Date:Joined: Oct 2010
I actually had something similar happen to me. My power button magically stopped working back about six months ago. It was somehow still under warranty, so I sent it in for repair. They repaired it and flashed it with their latest version of Froyo and I've never been able to flash a ROM since I've gotten it back.

It's been slowing down and crashing more lately and it's been driving me crazy. I really do believe in the conspiracies.

Sent from my SAMSUNG-SGH-I897 using Tapatalk 2
1st May 2012, 04:05 PM   |  #7  
x3phyr's Avatar
Senior Member
Flag Saranac, Michigan
Thanks Meter: 46
 
270 posts
Join Date:Joined: Jul 2010
More
http://forum.xda-developers.com/showthread.php?t=740022

That's the teardown my brother put up. It was his captivate, and he sent it down to me after he moved to verizon.

It's also the teardown I used, lol.
The Following User Says Thank You to x3phyr For This Useful Post: [ View ]
2nd May 2012, 01:34 AM   |  #8  
goob1284's Avatar
Senior Member
Thanks Meter: 17
 
701 posts
Join Date:Joined: Nov 2010
I have the same issue... What I tried was to resolder the button to the board. I wish I had a heat gun though, that would definitely have made it work.
2nd May 2012, 09:38 AM   |  #9  
connexion2005's Avatar
Senior Member
Flag Texas
Thanks Meter: 717
 
995 posts
Join Date:Joined: Feb 2009
Donate to Me
More
I fix these buttons every day. Contact me if you need yours fixed.
The Following 2 Users Say Thank You to connexion2005 For This Useful Post: [ View ]
9th May 2012, 02:56 AM   |  #10  
Member
Flag Bakersfield
Thanks Meter: 0
 
32 posts
Join Date:Joined: Jan 2012
My wifes button stopped working yesterday. It's there a diy fix for this? Sounds like it is becoming a common problem.

Sent from my GT-I9000 using xda premium

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes