FORUMS

Analysis & Opinion

Top Forum Discussions

Browser

115 posts
Thanks Meter: 19
 
By ryzilla23, Senior Member on 9th May 2012, 04:50 AM
Post Reply Subscribe to Thread Email Thread
Is it just me or does the ICS browser suck?

I installed chrome, but it has the same issue where it takes awhile for it to be responsive.

ICS+ browser is a bit better, but not leaps and bounds.

Dolphin is ok, certainly better than above. Still doesn't feel very responsive or fluid though.

Is there any decent tablet browser available?


Sent from my ASUS Transformer Pad TF300T using XDA Premium HD app
 
 
9th May 2012, 07:39 AM |#2  
UndisputedGuy's Avatar
Senior Member
Thanks Meter: 214
 
More
Opera mobile labs (I think that's what it's called)
Overskreen
boat browser

Sent from my R800i using XDA
9th May 2012, 08:41 AM |#3  
Member
Flag RJ
Thanks Meter: 4
 
More
I'm having no love with the browser. Feels like browsing on a 56k modem using some ancient linux distro. I tried all of them, with Maxthon being the fastest. Unfortunately Maxthon became unstable within a day.

The browser is turning into a dealbreaker. Maybe my expectations were too high.
9th May 2012, 09:34 AM |#4  
Senior Member
Thanks Meter: 43
 
More
please tell me that they fix this!! a quadcore and browser cant run smooth?!?
9th May 2012, 12:16 PM |#5  
jblah's Avatar
Senior Member
Flag Washington DC
Thanks Meter: 104
 
More
i'm using chrome and dolphin HD and it seems to be working fine. why would you all use stock browser anyways?
The Following User Says Thank You to jblah For This Useful Post: [ View ]
9th May 2012, 12:54 PM |#6  
rj88's Avatar
Member
Thanks Meter: 5
 
More
From what i've read, the browser is handled using the Tegra 3's "companion core."
Because it's clocked at such a slow speed, it has some lag.
The Following User Says Thank You to rj88 For This Useful Post: [ View ]
9th May 2012, 04:04 PM |#7  
Junior Member
Thanks Meter: 9
 
More
I have been using Dolphin on both my TF300 and TF101. I really can't tell any difference in the time is takes to load a page on both tablets.
I have tried other browsers but keep coming back to Dolphin.
9th May 2012, 04:10 PM |#8  
jblah's Avatar
Senior Member
Flag Washington DC
Thanks Meter: 104
 
More
Quote:
Originally Posted by amcplus5

I have been using Dolphin on both my TF300 and TF101. I really can't tell any difference in the time is takes to load a page on both tablets.
I have tried other browsers but keep coming back to Dolphin.

i just miss not having no-script and adblock. firefox does have adblock for their mobile browser but firefox runs so slow on this tablet for me.
9th May 2012, 08:41 PM |#9  
Member
Thanks Meter: 6
 
More
Totally disappointing experience. Browsing is a nightmare on my tf300t device. it's slightly better than tegra 2 devices (acer a500 and asus tf100), however still not ready for prime time.
The Following User Says Thank You to jrsalda For This Useful Post: [ View ]
9th May 2012, 11:37 PM |#10  
UndisputedGuy's Avatar
Senior Member
Thanks Meter: 214
 
More
Quote:
Originally Posted by jrsalda

Totally disappointing experience. Browsing is a nightmare on my tf300t device. it's slightly better than tegra 2 devices (acer a500 and asus tf100), however still not ready for prime time.

Why? Do you think this will improve through updates?

Sent from my R800i using XDA
10th May 2012, 03:33 AM |#11  
Account currently disabled
Flag Baltimore
Thanks Meter: 71
 
More
Quote:
Originally Posted by jblah

i'm using chrome and dolphin HD and it seems to be working fine. why would you all use stock browser anyways?

Safari stock browser is flawless! That's not a good enough reason for me.

Sent from my HTC Sensation 4G with Beats Audio using xda premium

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes