XDA LG Development Challenge Winners

Almost 3months ago, we set out with LGto findtwo amazing apps that developers could put together … more

Wearable Apps w/ Andreas Göransson – XDA:DevCon 2014

XDA:DevCon 2014 in Manchester, UK featured quite a few interesting topics as … more

Browse Your Files with Ease using MK Explorer

Google has made quite an effort in perfecting the powerful and multi-faceted OS that we know as … more

How to Fix the Nexus Available Storage Bug – XDA TV

Is your Nexus device only showing half of the available storage as it should? Many … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Guide]For people with white screen

OP Sneaky4296

10th May 2012, 04:15 PM   |  #1  
Sneaky4296's Avatar
OP Member
Thanks Meter: 18
 
73 posts
Join Date:Joined: Mar 2012
More
If your xperia play (Doesn't matter which model, it affects all plays) is getting this white screen here:

The problem that you are facing is a busted flex cable. I'm posting this thread because I have seen in the past week at least 5 people ask what the white screen is, and how to fix it. Here is a video on how to take apart your play: http://www.youtube.com/watch?v=-3n5ZfkqhzE and here is a link to where you can buy a new flex cable: http://www.ebay.com/itm/Flex-Cable-R...ht_1547wt_1185

The only way you can avoid the flex cable damage is to keep from sliding your gamepad in and out all the time. So basically, just try to do it if you are actually going to be playing a game, not just something you do because you are bored.

I hope this helps anyone with that problem!
Last edited by Sneaky4296; 10th May 2012 at 04:17 PM. Reason: Didn't tag title
The Following 5 Users Say Thank You to Sneaky4296 For This Useful Post: [ View ]
11th May 2012, 06:26 PM   |  #2  
Senior Member
Thanks Meter: 97
 
793 posts
Join Date:Joined: Oct 2011
More
Thanks. Does this mean sliding up slowly as well yeah ?
11th May 2012, 08:12 PM   |  #3  
savage24x's Avatar
Senior Member
Thanks Meter: 90
 
597 posts
Join Date:Joined: Jul 2011
More
Quote:
Originally Posted by sufy1000

Thanks. Does this mean sliding up slowly as well yeah ?

Not necessarily. Just don't do it too often. Mines lasted me since june 2011 so far.

Sent from my R800x using XDA
11th May 2012, 10:08 PM   |  #4  
Sneaky4296's Avatar
OP Member
Thanks Meter: 18
 
73 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by sufy1000

Thanks. Does this mean sliding up slowly as well yeah ?

Basically It's every time it slides. Just don't sit there rapidly opening and closing it.

Sent from my R800x using XDA
13th May 2012, 04:41 AM   |  #5  
VictoryStar's Avatar
Member
Flag Évora
Thanks Meter: 4
 
69 posts
Join Date:Joined: Jan 2012
Donate to Me
More
I have that problem. It still works perfectly when I open the gamepad, so I don't care.
13th May 2012, 06:28 AM   |  #6  
Sneaky4296's Avatar
OP Member
Thanks Meter: 18
 
73 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by VictoryStar

I have that problem. It still works perfectly when I open the gamepad, so I don't care.

I'd order a new one soon, because eventually it breaks with it open too.
14th May 2012, 09:31 PM   |  #7  
crispyduckling's Avatar
Senior Member
Flag nether whitacre
Thanks Meter: 8
 
178 posts
Join Date:Joined: Nov 2010
Donate to Me
More
Unhappy
i have a different problem
first my screen would come on but the phone was on and working etc
but the screen stayed black
if i kept pressing power on button or the hardware keys it would come back on sometimes
or if i restarted the phone
but now the screen wont come on at all, i power the fone on and it vibrates
and then it vibrates again and power buttons goes blue for a short time i think to signal that doom kernel has loaded and that u can go to recovery
but that it.
phone is dead
14th May 2012, 10:06 PM   |  #8  
Nextil's Avatar
Junior Member
Thanks Meter: 6
 
27 posts
Join Date:Joined: Dec 2010
More
Wow, this is a huge problem. Is this happening to a lot of launch-buyers?
16th May 2012, 04:17 PM   |  #9  
Sneaky4296's Avatar
OP Member
Thanks Meter: 18
 
73 posts
Join Date:Joined: Mar 2012
More
I don't know what your problem is...It might be your LCD
16th May 2012, 09:17 PM   |  #10  
KeiranFTW's Avatar
Recognized Developer
Flag Sunderland
Thanks Meter: 2,728
 
2,639 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Ah, I have this, but its only partially down the left side of the screen, about 20px

Sent from my Xperia Play using Tapatalk 2

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes