Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,761 Members 42,286 Now Online
XDA Developers Android and Mobile Development Forum

[I9001][ICS][28 JUL] Camera Development

Tip us?
 
oisis
Old
#511  
oisis's Avatar
Senior Member
Thanks Meter 2106
Posts: 1,251
Join Date: Oct 2008
Location: Out of nowhere
OT:
Put this to yours /system/etc/ and say goodbye to ads .

We can try GPU libs from Sony Ericsson Xperia PLAY because it is phone for games so maybe GPU drivers will be better.

Sorry for OT.
The Following User Says Thank You to oisis For This Useful Post: [ Click to Expand ]
 
crazybasss
Old
#512  
crazybasss's Avatar
Member
Thanks Meter 11
Posts: 49
Join Date: May 2010
Quote:
Originally Posted by Xistance View Post
Is it just me but after doing this it made the camera lens really hot? Might just be me O.o

Sent from my GT-I9001 using xda premium
I noticed that to! strange thing...
 
texten
Old
(Last edited by texten; 24th May 2012 at 11:58 PM.)
#513  
texten's Avatar
Senior Member - OP
Thanks Meter 1539
Posts: 1,276
Join Date: Apr 2012

 
DONATE TO ME
i think i will flash cm9 again right now and will test some camera.apk's and camera tweaks


what can i also do?
give me some homework oisis, i have some hours time to test

edit:
i made this command with logcat:
type logcat.txt | findstr camera > nwelogcat.txt

is that output right?

Code:
W/PackageManager(  289): Package com.android.camera desires unavailable shared library com.google.android.media.effects; ignoring!

I/ActivityManager(  289): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.camera/.Camera bnds=[0,556][120,707]} from pid 600

I/ActivityManager(  289): Start proc com.android.camera for activity com.android.camera/.Camera: pid=964 uid=10008 gids={1006, 1015}

I/ActivityManager(  289): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.camera/.Camera bnds=[0,556][120,707]} from pid 600

E/AndroidRuntime(  964): 	at com.android.camera.CameraErrorCallback.onError(CameraErrorCallback.java:31)

W/ActivityManager(  289):   Force finishing activity com.android.camera/.Camera

W/ActivityManager(  289): Activity pause timeout for ActivityRecord{4105dca0 com.android.camera/.Camera}

I/ActivityManager(  289): Process com.android.camera (pid 964) has died.

I/WindowManager(  289): WIN DEATH: Window{41090f30 com.android.camera/com.android.camera.Camera paused=false}

I/ActivityManager(  289): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.camera/.Camera bnds=[0,556][120,707]} from pid 600

I/ActivityManager(  289): Start proc com.android.camera for activity com.android.camera/.Camera: pid=1035 uid=10008 gids={1006, 1015}

I/ActivityManager(  289): START {act=android.media.action.VIDEO_CAMERA flg=0x6000000 cmp=com.android.camera/.VideoCamera} from pid 1035

W/ActivityManager(  289): Activity destroy timeout for ActivityRecord{4105dca0 com.android.camera/.Camera}

I/InputDispatcher(  289): Application is not responding: Window{410bfe68 com.android.camera/com.android.camera.VideoCamera paused=false}.  7538.5ms since event, 5062.9ms since wait started

I/QualcommCameraHardware( 1107): getCameraInfo: loading libqcamera at 0xb000ed0c

I/QualcommCameraHardware( 1107): camera_id: 0

I/QualcommCameraHardware( 1107): camera_id: 1

V/QualcommCameraHardware( 1107): getCameraInfo: dlclose(libqcamera)

I/CameraHAL( 1107): camera_get_number_of_cameras: number:2

W/PackageManager( 1135): Package com.android.camera desires unavailable shared library com.google.android.media.effects; ignoring!
been there, done that.
 
BzArEx
Old
(Last edited by BzArEx; 24th May 2012 at 11:57 PM.)
#514  
Senior Member
Thanks Meter 77
Posts: 300
Join Date: Nov 2011
Location: Rzeszow
Quote:
Originally Posted by Xistance View Post
Is it just me but after doing this it made the camera lens really hot? Might just be me O.o

Sent from my GT-I9001 using xda premium
Lens heating up really, I didn't use camera much and I can't tell, but maybe this is normal. But probably not.
OP please add a specific warning to 1st post that could be dangerous to device itself.

Sent from my GT-I9001 using xda premium
 
texten
Old
(Last edited by texten; 25th May 2012 at 12:05 AM.)
#515  
texten's Avatar
Senior Member - OP
Thanks Meter 1539
Posts: 1,276
Join Date: Apr 2012

 
DONATE TO ME
Quote:
Originally Posted by BzArEx View Post
Lens heating up really, I didn't use camera much and I can't tell, but maybe this is normal. But probably not.
OP please add a specific warning to 1st post that could be dangerous to device itself.

Sent from my GT-I9001 using xda premium
can confirm.
i will try with another cpu setup.
edit: seems to be better with max 1200 and powersave

edit:
(all tests will be without gapps and simcard)
here is a first logcat (logcat01.txt), after fresh install and flash of experimental_cam-01
bootup, open cam, switch to video, press record button... racording starts, force close / reboot of bootanimation while tried to stop the record..

logcat01.txt

taking panorama pictures with stock cam works without any issues (logcat02.txt):

logcat02.txt
been there, done that.
 
sqnyster
Old
#516  
Member
Thanks Meter 10
Posts: 72
Join Date: Jul 2009
On GB, lens, after a few minutes of camera use, is getting warmish, but not hot.
 
RavoxX
Old
#517  
RavoxX's Avatar
Senior Member
Thanks Meter 101
Posts: 225
Join Date: Nov 2011
Quote:
Originally Posted by oisis View Post
OT:
Put this to yours /system/etc/ and say goodbye to ads .

We can try GPU libs from Sony Ericsson Xperia PLAY because it is phone for games so maybe GPU drivers will be better.

Sorry for OT.
If libs are not the same as drivers, I'm sorry, but Arco already included the drivers made directly by Qualcomm for ICS so they will probably the same as ours.
 
texten
Old
(Last edited by texten; 25th May 2012 at 03:09 AM.)
#518  
texten's Avatar
Senior Member - OP
Thanks Meter 1539
Posts: 1,276
Join Date: Apr 2012

 
DONATE TO ME
Quote:
Originally Posted by oisis View Post
snipped..
EDIT1:
This combination with libs and Arco "wrapper" will work also on i8150. Thanks for Arco of course, well done.
yes, and i think they have to replace the firmware folder and the mdia_profile.xml withe the ones of their latest gingerbread ...




Quote:
Originally Posted by oisis View Post
In ICS we have only:
-rw-r--r-- root root 131416 2008-08-01 14:00 libcamera.so
-rw-r--r-- root root 129856 2008-08-01 14:00 libcamera_client.so
-rw-r--r-- root root 55424 2008-08-01 14:00 libcameraservice.so
-rw-r--r-- root root 582228 2008-08-01 14:00 liboemcamera.so
So maybe try to add missing libs . And logcat .
Quote:
Originally Posted by mobuch View Post
Copied all *camera* and *vi* files grepped out of GBS but ICS is stuck on boot.
Will restore and copy only those non-existing to see if it blows up.

Restored ics libs, copied missing GB libs, behaviour is as without those files: can take shots with camerazoomfx and puddingcam (back camera) but fc on video and freezes on switching to front cam. Time to bed... will try to play a little tomorrow, upload logs an stuff..


added these attached files to ics.
nothing new. after reboot, started cam (no picture visibile) switched to frontcam -> camera not found. (logcat03.txt)

----
i have also tried some other camera apk's from htc desire s, from sony xperia mini,mini pro, neo etc and from u8860... they all shows blackscreen or fc's (only with camera_experimental-01.zip)

kamera ics+ from google play store works like the stock cam very unstable, there is no need to buy this


i think we should try some media_profile.xml
been there, done that.
The Following User Says Thank You to texten For This Useful Post: [ Click to Expand ]
 
texten
Old
(Last edited by texten; 25th May 2012 at 04:13 AM.)
#519  
texten's Avatar
Senior Member - OP
Thanks Meter 1539
Posts: 1,276
Join Date: Apr 2012

 
DONATE TO ME
i have added the camera.apk and from cm7 to /system/app
videorecording is successfully working only on frontcamera(it is also unstable, for example sometimes the rotation is wrong).

when switching to backcam the camera is not found but sometimes the app starts directly with backcam and you can record videos, but you can not stop the recording, fc. (just another advice that maybe the media_profile.xml is not the best)

here is a logcat with videorecording on backcam and fc ... and successfully recording with frontcam with cm7 camera apk and missed kqb libs for ics (from post above) (logcat10.txt):

..............

edit: logcat20.txt with replaced media_profile.xml from cm7 and camera from cm7 and missed kqb libs for ics (from post above) ... first try successfuly recording video with frontcamera, after that switch to backcam - camera not found

we need a camera.apk and a media_profile.xml from a working ics from a similar device - just for testing

.............

edit: here is my last logcat so far. for the next days i can't test....
added missed kqb libs for ics (from post above) and i have replaced the media_profile.xml and the camera.apk with the ones of italianguy.
i was testing a little bit, it seems the autofocus is working... (the focus frame is not red, it is green)
ok, but it was always unstable. so no logcat of these tests.

but one logcat with these files and these steps -> switching to front cam camera not found, second try open the camera app, camera not found (logcat30.txt)

......
sorry, my concentration is gone, i'm tired. good night.
Attached Files
File Type: txt logcat10.txt - [Click for QR Code] (249.1 KB, 2 views)
File Type: txt logcat20.txt - [Click for QR Code] (245.0 KB, 2 views)
File Type: txt logcat30.txt - [Click for QR Code] (176.4 KB, 3 views)
File Type: rar cm7files.rar - [Click for QR Code] (328.0 KB, 11 views)
been there, done that.
The Following User Says Thank You to texten For This Useful Post: [ Click to Expand ]
 
oisis
Old
(Last edited by oisis; 25th May 2012 at 07:16 AM.)
#520  
oisis's Avatar
Senior Member
Thanks Meter 2106
Posts: 1,251
Join Date: Oct 2008
Location: Out of nowhere
Quote:
Originally Posted by texten View Post
i think i will flash cm9 again right now and will test some camera.apk's and camera tweaks


what can i also do?
give me some homework oisis, i have some hours time to test

edit:
i made this command with logcat:
type logcat.txt | findstr camera > nwelogcat.txt

is that output right?

Code:
W/PackageManager(  289): Package com.android.camera desires unavailable shared library com.google.android.media.effects; ignoring!

I/ActivityManager(  289): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.camera/.Camera bnds=[0,556][120,707]} from pid 600

I/ActivityManager(  289): Start proc com.android.camera for activity com.android.camera/.Camera: pid=964 uid=10008 gids={1006, 1015}

I/ActivityManager(  289): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.camera/.Camera bnds=[0,556][120,707]} from pid 600

E/AndroidRuntime(  964): 	at com.android.camera.CameraErrorCallback.onError(CameraErrorCallback.java:31)

W/ActivityManager(  289):   Force finishing activity com.android.camera/.Camera

W/ActivityManager(  289): Activity pause timeout for ActivityRecord{4105dca0 com.android.camera/.Camera}

I/ActivityManager(  289): Process com.android.camera (pid 964) has died.

I/WindowManager(  289): WIN DEATH: Window{41090f30 com.android.camera/com.android.camera.Camera paused=false}

I/ActivityManager(  289): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.camera/.Camera bnds=[0,556][120,707]} from pid 600

I/ActivityManager(  289): Start proc com.android.camera for activity com.android.camera/.Camera: pid=1035 uid=10008 gids={1006, 1015}

I/ActivityManager(  289): START {act=android.media.action.VIDEO_CAMERA flg=0x6000000 cmp=com.android.camera/.VideoCamera} from pid 1035

W/ActivityManager(  289): Activity destroy timeout for ActivityRecord{4105dca0 com.android.camera/.Camera}

I/InputDispatcher(  289): Application is not responding: Window{410bfe68 com.android.camera/com.android.camera.VideoCamera paused=false}.  7538.5ms since event, 5062.9ms since wait started

I/QualcommCameraHardware( 1107): getCameraInfo: loading libqcamera at 0xb000ed0c

I/QualcommCameraHardware( 1107): camera_id: 0

I/QualcommCameraHardware( 1107): camera_id: 1

V/QualcommCameraHardware( 1107): getCameraInfo: dlclose(libqcamera)

I/CameraHAL( 1107): camera_get_number_of_cameras: number:2

W/PackageManager( 1135): Package com.android.camera desires unavailable shared library com.google.android.media.effects; ignoring!
This log is also interesting, camera is looking for libqcamera.so and we do not have it. So let somebody try to find it in Italian guy or stock rom.
Checked one more time and I don't have this library after clean installation alpha3 and camera experimental.

Sent from my GT-I9001 using XDA

The Following User Says Thank You to oisis For This Useful Post: [ Click to Expand ]
Tags
camera fix, cyanogenmod, development, don't mess with the best - eat this, f u c k i n g shit, galaxy s plus, ics, im a handsome guy, oisis ftw!, sgs+ cam is shy
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes