Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,428 Members 47,093 Now Online
XDA Developers Android and Mobile Development Forum

[ROM] Unofficial CyanogenMod 9 [BLECM9 0.02]

Tip us?
 
Blefish
Old
(Last edited by Blefish; 10th January 2013 at 05:30 PM.) Reason: Update status
#1  
Blefish's Avatar
Senior Member - OP
Thanks Meter 1769
Posts: 768
Join Date: Aug 2011
Location: Paluküla, Hiiumaa

 
DONATE TO ME
Default [ROM] Unofficial CyanogenMod 9 [BLECM9 0.02]

Current status: CM10.1 in the works and this version will not be updated.

Got started with the project in January, I'm now ready to present you my first custom ROM (and kernel) - BLECM9!

First of all - BACKUP! This is not stable for everyday use just yet.

It also includes my own kernel, based on the latest CAF source code (ics_chocolate). The kernel gets frequent updates from CAF and me. Kernel version is 3.0.8. It's not as stable in the beginning but a better choice in the long term.

It won't include Google Apps, you need to manually install gapps package, as any other CM rom is by default.
Prequisites
  • U8800 upgraded to 2.3
  • ClockworkMod Recovery v5.5.0.4, not tested in v5.0.2.7
Instructions for Installing
  1. Download the latest version of BLECM9 (Downloads below).
  2. Copy the package to your internal/external SD card.
  3. Reboot to recovery.
  4. Flash the update package.
    Optional: Install Gapps package (Downloads below).
  5. Reboot and wait. The first boot takes around 2 minutes.
Downloads
Additional Notes
  • Report issues.
  • Changelog.
  • No, this won't work on U8800-51 or U8800Pro.
  • Atmel TS users, 0.02 will not work for you. I am establishing a new driver, to make the driver standard. Please standby as this is my top priority.
  • Everybody, send me logs if something does not work. This kernel is under heavy development. On computer with ADB set up: "adb shell dmesg > dmesg.log" and send the dmesg.log
Major Bugs
  • No Atmel TS support.
  • RIL issues (does not detect all SIMs)
  • NT35510 seems to have issues when turning on the screen (confirm?)
  • Unstable backlight on low values.
  • Wifi MAC address is 00:11:22:33:44:55
  • No Camera.
  • No Bluetooth.
  • No FM radio.
  • No audio (except ringtone/alarm)
  • Sometimes glitchy hardware acceleration.
  • No sensors.
  • More...
Credits: Huge thanks to dzo - without the proprietary blobs from him, this would've not been possible.

This is not just a work of mine, recently another developer joined the process and we are working together.
Collaborators: asm19

Feel free to contact me and also - contribute! Links for the source code is up on my GitHub (signature).
Follow my Twitter to see my development progress.
The Following 54 Users Say Thank You to Blefish For This Useful Post: [ Click to Expand ]
 
brdnacer
Old
(Last edited by brdnacer; 22nd May 2012 at 02:46 PM.)
#2  
brdnacer's Avatar
Senior Member
Thanks Meter 9
Posts: 126
Join Date: Jan 2011

 
DONATE TO ME
awesome. lets try :P

edit: when i try to write wifi password... see attachement. i can still write password, but i can't see what i am writing. everything works good in messeges

2nd edit: common cm problem... error while searching for network
Attached Thumbnails
Click image for larger version

Name:	DSC00488.jpg
Views:	3745
Size:	216.1 KB
ID:	1074858  
 
john9
Old
#3  
Account currently disabled
Thanks Meter 269
Posts: 1,587
Join Date: Oct 2011
Thanks for sharing.Looks good.
 
axistr
Old
#4  
Member
Thanks Meter 15
Posts: 64
Join Date: Jul 2011
Been waiting for this. I will try it asap. I'm sure it will be get better day by day. Many thanks.
 
Loureiro
Old
#5  
Loureiro's Avatar
Senior Member
Thanks Meter 240
Posts: 631
Join Date: Aug 2011
Location: Alentejo
First of all Thank you!

First Impressions:
Touchscreen feels really responsive.
Rom feels very fast too.
Wifi is working good.

Bugs that I've found:
Screen flickering (unstable backlight)
Can't mount SDCard.
RIL isn't working on my u8800.

Overall it looks very promising!

Logs attached.
Attached Files
File Type: zip CM9logs(loureiro).zip - [Click for QR Code] (57.7 KB, 69 views)

Phone: Galaxy Nexus "Maguro"
Rom: 4.2
Kernel: 4.2
Recovery: TWRP
 
Loureiro
Old
#6  
Loureiro's Avatar
Senior Member
Thanks Meter 240
Posts: 631
Join Date: Aug 2011
Location: Alentejo
Quote:
Originally Posted by brdnacer View Post
awesome. lets try :P

edit: when i try to write wifi password... see attachement. i can still write password, but i can't see what i am writing. everything works good in messeges
Yes, It's related to HW acceleration, causing some UI glitches.

Phone: Galaxy Nexus "Maguro"
Rom: 4.2
Kernel: 4.2
Recovery: TWRP
 
FlashTH
Old
#7  
FlashTH's Avatar
Senior Member
Thanks Meter 56
Posts: 288
Join Date: Jul 2011
Have been waiting for this for a long time, even if can't even use it because of Amtel TS.

Keep up with this awesome work
 
forumber2
Old
#8  
Senior Member
Thanks Meter 1212
Posts: 865
Join Date: Feb 2012
Location: Kocaeli - Gebze
Thanks for this!

I'm using b518 and my phone is multibooting.My phone has recovery made by VICTOR TEAM (genokolar) .This ROM can be a problem for me in terms of Multiboot?Because you writed this in changelog;

Quote:
New Partition Table.
Thank you in advance for the answer to my question!

Best regards...
 
fjsferreira
Old
#9  
fjsferreira's Avatar
Senior Member
Thanks Meter 873
Posts: 1,768
Join Date: Nov 2009
Location: Ponta Delgada
Great! Been waiting for CM9 a long time ago too... Blefish, you should post some rules as to what we should and how to post in this thread, maybe instructions on how to post specific logs and what kind of info you need. The rest of the discussion should be posted in the general section. I would really hate for this thread to become a mess like Aurora's...

Sent from my U8800
You still don't use Dropbox? WTF?
Install it here and both of us receive 500Mb free.
The Following 5 Users Say Thank You to fjsferreira For This Useful Post: [ Click to Expand ]
 
elexogic
Old
#10  
Junior Member
Thanks Meter 12
Posts: 21
Join Date: Nov 2011
I flashed 0.02, touchscreen didn't work. Then flashed Atmel-test2, touchscreen still doesn't work. Also phone reboots randomly.

Tags
blecm9, cm9, u8800, unofficial
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes