Post Reply

A Tale of Two EVO 4G LTEs: Yellow Screens, Light Leakage, and Stickers

OP ahecht

7th June 2012, 04:23 AM   |  #1  
ahecht's Avatar
OP Senior Member
Thanks Meter: 230
 
407 posts
Join Date:Joined: Oct 2010
I had Sprint sent me a replacement EVO 4G LTE because I had a piece of dust trapped in between the gorilla glass and the LCD (visible in the first picture below) and I had really bad light leakage from the home button (second picture below). However, when I was taking pictures side-by-side to show how much better the light leakage was on the new phone, I noticed that the screen on the new phone has a much yellower tint than the old phone (third picture below). The new phone is on the left, the old one is on the right. Both phones are showing the same image at exactly the same brightness levels.





Another interesting note is that the box from my first phone was sealed with a 2" diameter clear sticker, while the second was sealed with a 0.75" diameter sticker (picture below). Both say "Made in Taiwan", but I'm thinking they must've been from different facilities.



There are three takeaways from this:
* There are at least two production lines producing the phones
* There are some yellower screens (perhaps a different supplier or assembly line)
* Not all phones have the home button light leakage problem, so you DON'T have to live with it.

That said, I'd rather have the yellow screen than the light leakage.
Attached Thumbnails
Click image for larger version

Name:	P1060667.s.jpg
Views:	2248
Size:	192.4 KB
ID:	1112055   Click image for larger version

Name:	P1060662.s.jpg
Views:	2262
Size:	32.8 KB
ID:	1112056   Click image for larger version

Name:	P1060665.s.jpg
Views:	706
Size:	29.9 KB
ID:	1112057   Click image for larger version

Name:	P1060677.s.JPG
Views:	2231
Size:	61.9 KB
ID:	1112058  
Last edited by ahecht; 7th June 2012 at 06:13 AM. Reason: updated yellow image to a better one
The Following User Says Thank You to ahecht For This Useful Post: [ View ]
7th June 2012, 04:33 AM   |  #2  
Doomstang's Avatar
Senior Member
Flag St. Louis, Missouri
Thanks Meter: 279
 
511 posts
Join Date:Joined: Aug 2010
More
Wow those are some major differences. I never had light leakage with my original Evo or my 3D but I do have some minor leakage with my LTE. It's only noticeable on black screens and isn't as bad as the one in your picture but still kinda sucks.

Edit: I just checked my box...it was a bigger sticker one. It seems like the one with problems for you also had the big sticker. Perhaps we can get more people to give a larger sample size.
Last edited by Doomstang; 7th June 2012 at 04:41 AM.
7th June 2012, 04:59 AM   |  #3  
Senior Member
Thanks Meter: 141
 
663 posts
Join Date:Joined: Jul 2007
More
When I 1st got my EVO LTE I thought the Screen was yellow as well, but then I remembered the iPhone having the same problem and it was a issue dealing with Glue not yet dry. I waited a couple of days and I have a perfect color screen. I am not saying this is the case with yours just letting you know my experience.

Sent from my EVO LTE
7th June 2012, 05:03 AM   |  #4  
Cherokee4Life's Avatar
Senior Member
Flag Chicagoland, Illinois
Thanks Meter: 30
 
207 posts
Join Date:Joined: Feb 2011
Donate to Me
More
I have none of those issues and have the little sticker seal... hmmm I have Hardware Version 003

Ironically my HTC EVO 4G had version 003 as well! lucky # 3
7th June 2012, 05:06 AM   |  #5  
ImaWinRAR's Avatar
Senior Member
Flag Chicago
Thanks Meter: 163
 
738 posts
Join Date:Joined: Sep 2011
More
the first LTE that I had had a loose vibrating motor (you could hear it rattle if you shook it) and a faulty camera button, it didn't have dual action like it was suppose to - this one had a big sticker on it. I had BB replace it after they got another shipment after launch day, very minor light leakage but no major problems - this one had a small sticker

coincidence?

I think not
7th June 2012, 05:13 AM   |  #6  
Cuppeerr's Avatar
Senior Member
Flag Grapevine, Texas
Thanks Meter: 821
 
2,766 posts
Join Date:Joined: Mar 2010
Donate to Me
More
I have 2 and they both have big stickers and they're perfectly fine
7th June 2012, 05:31 AM   |  #7  
ticklemepinks's Avatar
Senior Member
Thanks Meter: 438
 
1,164 posts
Join Date:Joined: Feb 2008
Quote:
Originally Posted by -Cupper-

I have 2 and they both have big stickers and they're perfectly fine

pow pow! lol
7th June 2012, 05:33 AM   |  #8  
ahecht's Avatar
OP Senior Member
Thanks Meter: 230
 
407 posts
Join Date:Joined: Oct 2010
Both phones are hardware rev 3. I changed the yellow screen picture in my post above to one that better shows the tint. Hopefully it will go away as the glue dries -- this post about the One X seems to indicate that it will: http://forum.xda-developers.com/show....php?t=1649434

EDIT: This thread seems to make a lot of sense -- either the screens will have light bleed, or they use more glue which will be yellow until it cures: http://forum.xda-developers.com/show...4&postcount=19
Attached Thumbnails
Click image for larger version

Name:	P1060681.s.jpg
Views:	2165
Size:	191.9 KB
ID:	1112250  
Last edited by ahecht; 7th June 2012 at 05:47 AM.
The Following User Says Thank You to ahecht For This Useful Post: [ View ]
7th June 2012, 05:52 AM   |  #9  
raiderep's Avatar
Senior Member
Flag Nor Cal
Thanks Meter: 237
 
1,412 posts
Join Date:Joined: Feb 2010
More
Hardware version 003, big sticker here and no issues at all...love this device.

Sent from my EVO
7th June 2012, 05:59 AM   |  #10  
Senior Member
Thanks Meter: 900
 
3,605 posts
Join Date:Joined: Jan 2010
More
This is interesting and that is some aweful.light leakage I wonder what the other guy had that had a whole led dead on the bottom lol.

Sent from my EVO using xda premium

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes