Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,174 Members 36,245 Now Online
XDA Developers Android and Mobile Development Forum

Finally! A Solution for "Data Call Failure" or Error 67

Tip us?
 
erikivy
Old
#1  
Senior Member - OP
Thanks Meter 113
Posts: 557
Join Date: May 2010
Location: Central VA
Default Finally! A Solution for "Data Call Failure" or Error 67

First of all, proceed at your own risk. Poking around in your phone can cause problems if you're not careful.

I'm posting this because I spent quite a bit of time searching, but could find nothing that worked. I tried resets, updating profile/PRL, etc and none of them helped. I finally bit the bullet and called Sprint. After a short discussion about everything I had tried, a nice lady named Rachel had me update my data profile, which is apparently different than resetting it. You need to get into the SCRTN menu and the required EPST code is ##72786#, which is one that I did lot have in my handy list of useful codes.

After entering the code, you are presented with a password prompt, which is where you input your MSL.


After doing so, you are at the SCRTN main menu.


When you tap "Menu" in the upper right hand corner, one of the two options presented is "Reset".


Tap that bad boy and you get this confirmation message.


When you tap ok, it does it's thing and then reboots. When it finishes rebooting, it should start the handsfree activation process and then all will be right with the world....or at least it was for me.
The Following 14 Users Say Thank You to erikivy For This Useful Post: [ Click to Expand ]
 
mrrogers1
Old
#2  
mrrogers1's Avatar
Senior Member
Thanks Meter 2,428
Posts: 2,901
Join Date: Jun 2007
Location: NEEEEBRASKA
Just wanted to say THANK YOU! Activating my "old" LTE which was already rooted and got this. Took an hour with a CSR and getting disconnected for me to do a quick search to find this thread. I called back, got my MSL and did this and BAM!

Thanks a ton for sharing this.
 
detcup4evr
Old
(Last edited by detcup4evr; 28th June 2012 at 07:37 AM.)
#3  
detcup4evr's Avatar
Senior Member
Thanks Meter 314
Posts: 655
Join Date: Jun 2010
Location: Commerce Twp
Thanks a bunch, I am running stock Rom, but could get error 67 to go away with sprint tether. So I ran this and voila looks like that fixed my error 67 tether issue. Which also fixed my media link error 67 message


**edit**
The error came back after a reboot, I will fiddle with it more later see if I can make it stick
Sent from my GT-I9300 using xda app-developers app
 
wuestsider
Old
#4  
wuestsider's Avatar
Senior Member
Thanks Meter 41
Posts: 203
Join Date: May 2010
Location: Rancho Cordova, CA
A week ago I was getting the error code 67, as well as no data what-so-ever. No matter what I did (the ##72786# data reset as well as the ##986# hard reset) still no data connection (error code 67).

So I took it to Sprint, they couldn't fix it and ended up giving me a new phone. Basically, nothing helped. The Sprint tech. really couldn't answer what was wrong, so his fall back excuse for the issue was installing an unstable ROM.

Which was not true, I had ViperRom installed on the phone for about 2 1/2 weeks before my phones data took a crap on me

WUESTSIDER!

Sent with my rEVOLTe, the Family JEWEL!
 
chazybaz13
Old
#5  
chazybaz13's Avatar
Senior Member
Thanks Meter 27
Posts: 142
Join Date: Dec 2008
Location: Spokane

 
DONATE TO ME
An easy fix is ##DATA# enter msl, click data and edit the Active Profile from 0 to 1, commit and reboot. No one at Sprint or anywhere could help me. I got calls and texts fine, but data was a no go until I changed that value.

Sent from my EVO using Tapatalk 2
The Following User Says Thank You to chazybaz13 For This Useful Post: [ Click to Expand ]
 
gpz1100
Old
#6  
gpz1100's Avatar
Senior Member
Thanks Meter 284
Posts: 2,040
Join Date: Nov 2009
It should be noted that all of these ## codes ONLY work on sense roms, not aosp.
Page Plus Flashing - True 3G (evdo)
Free Page Plus Ports/Activation - PM for more info

Vzw Samsung S4 - Page Plus
 
cobraboy85
Old
#7  
Account currently disabled
Thanks Meter 1,252
Posts: 2,471
Join Date: Aug 2011
not sure if anybody here is wondering how to get there MSL number without calling sprint, but use this app.... worked on the 3D, also works on the LTE...

https://www.dropbox.com/s/jotxjcq0wj...ode.msl_15.apk
 
sanmanc
Old
#8  
Member
Thanks Meter 16
Posts: 96
Join Date: Oct 2008
Location: San Antonio, TX
Quote:
Originally Posted by cobraboy85 View Post
not sure if anybody here is wondering how to get there MSL number without calling sprint, but use this app.... worked on the 3D, also works on the LTE...

https://www.dropbox.com/s/jotxjcq0wj...ode.msl_15.apk
MSL Reader is available in the Play Store. That's what I use.

https://play.google.com/store/search?q=msl+reader
 
mrrogers1
Old
#9  
mrrogers1's Avatar
Senior Member
Thanks Meter 2,428
Posts: 2,901
Join Date: Jun 2007
Location: NEEEEBRASKA
Quote:
Originally Posted by sanmanc View Post
MSL Reader is available in the Play Store. That's what I use.

https://play.google.com/store/search?q=msl+reader
That's the app he posted, just from his drop box.

Sent from my EVO LTE using XDA premium
 
mroppolo
Old
#10  
mroppolo's Avatar
Junior Member
Thanks Meter 2
Posts: 11
Join Date: Dec 2010
Location: Boston, MA
Man, I have tried everything i order to get native HotSpot working. Hee are the steps, as I know them:
  • Modify build.prop, adding the command ro.tether.denied=false
  • Reboot to recovery
  • Use TeamWin to wipe both Cache and Dalvik
  • Reboot normally
  • USB Tether
  • Turn on HotSpot

Still getting Error 67 every 15 seconds. Let it wait for 5 few minutes; no joy

I even turned off LTE (since it doesn't exist), nada.

Anyone with additional ideas ?

Thanks !

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Windows Developers Rejoice! Dev Program’s $99 Yearly Fee is No More!

Microsoft rule in the mobile market, much like the giant dinosaurs … more

Add the Xperia Z2 Lock Screen to Your Favorite KitKat ROM

Almost every OEM adds its own unique flair to their stock firmwares. While some of … more

Android App Review: Control Your Phone with Quick Control Panel – XDA Developer TV

Your Android smart device has many features that you … more

Play Music on Android Wear with Stellio Music Player

Android Wear smartwatchesare growing inpopularity every day. Some devices have already … more