Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

"there is a problem parsing the package"

OP sebastienbo

27th June 2012, 10:05 PM   |  #1  
OP Member
Thanks Meter: 1
 
45 posts
Join Date:Joined: Jul 2010
Guys,

I'm so angry , I just rooted the nook glowlight and am unable to install any apk files.

I'm always getting "there is a problem parsing the package", whatever I found on the internet

Is there no file explorer by default on it ? And why this parse error ?

And most websites just crash, grrr

Anyone, anyone please anyone : HELP MEEEE
27th June 2012, 11:12 PM   |  #2  
Renate NST's Avatar
Recognized Contributor / Recognized Developer
Boston
Thanks Meter: 814
 
1,999 posts
Join Date:Joined: Feb 2012
Do you have ADB working? Can you see a logcat?
Do you know that these APKs are actually good and designed for API level 7?
28th June 2012, 10:59 AM   |  #3  
Senior Member
Thanks Meter: 201
 
773 posts
Join Date:Joined: Feb 2011
Also, is installation of apps from unknown sources enabled in nook color tools? Most (all?) of the NST rooting packages include it, but you do have to set the flag to get packages found via the internet (rather than the google store) and copied to the device to install.
The Following User Says Thank You to roustabout For This Useful Post: [ View ]
30th June 2012, 09:18 PM   |  #4  
Member
Flag NJ
Thanks Meter: 4
 
33 posts
Join Date:Joined: Oct 2010
I get that error sometimes when downloading .apk files from some sites. Your browser might not be downloading the file with the correct filetype suffix. Can you see if it has the .apk suffix on it? I've found that some browsers do better than others with handling this file-type. If you can get xScope browser or Opera Mobile I think those were better. It's also possible that a retry of the download will work, or that the file itself is just bad.
The Following User Says Thank You to glowco For This Useful Post: [ View ]
27th August 2012, 03:41 AM   |  #5  
Senior Member
Thanks Meter: 3
 
282 posts
Join Date:Joined: Jun 2009
I get the same error on my nook simple touch.
the same apk's work on my galaxy nexus.

Anyone knows what might be the problem and how to solve it?
27th August 2012, 03:57 AM   |  #6  
Renate NST's Avatar
Recognized Contributor / Recognized Developer
Boston
Thanks Meter: 814
 
1,999 posts
Join Date:Joined: Feb 2012
A logcat will tell you exactly what the problem is.
Use ADB and get a logcat.
27th August 2012, 03:21 PM   |  #7  
Senior Member
Thanks Meter: 138
 
479 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by xd4d3v

I get the same error on my nook simple touch.
the same apk's work on my galaxy nexus.

Anyone knows what might be the problem and how to solve it?

Are you sure these apks are compatible with Android 2.1 Eclair? Not everything will work. Which programs are you trying to install specifically?
19th September 2012, 02:10 PM   |  #8  
Senior Member
Thanks Meter: 3
 
282 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by bobstro

Are you sure these apks are compatible with Android 2.1 Eclair? Not everything will work. Which programs are you trying to install specifically?

I haven't thought of that. but you're probably right.
I'm surprised the error message is not more obvious though.
25th December 2012, 05:50 PM   |  #9  
Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Dec 2012
Unhappy
Quote:
Originally Posted by xd4d3v

I haven't thought of that. but you're probably right.
I'm surprised the error message is not more obvious though.





guys
I've got motorola xt800 (milestone/ glam)
I am getting the same error " parsing error "

There is a problem parsing the package

its on Android 2.1 eclair

and its not rooted

what should i do ?

pls reply

I cant even access market ... cant download any apk files
The Following User Says Thank You to jaybhatia999 For This Useful Post: [ View ]
25th December 2012, 06:01 PM   |  #10  
osowiecki's Avatar
Senior Member
Flag Poznań
Thanks Meter: 124
 
258 posts
Join Date:Joined: Feb 2012
Donate to Me
Quote:
Originally Posted by jaybhatia999

guys
I've got motorola xt800 (milestone/ glam)
I am getting the same error " parsing error "

There is a problem parsing the package

its on Android 2.1 eclair

and its not rooted

what should i do ?

pls reply

I cant even access market ... cant download any apk files


Wrong forum.

Try installing any other package with requirements : 2.1+

In Settings check "Allow Installation of Non-Market Apps" .
Install apk from SDCARD.
I'm 90% sure you are just trying to install a package not compatible with A 2.1.
Last edited by osowiecki; 25th December 2012 at 06:04 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes