FORUMS
Remove All Ads from XDA

Adb will not find Motorola Droid Razr

57 posts
Thanks Meter: 7
 
By arsenik13, Member on 11th July 2012, 03:22 AM
Post Reply Email Thread
Question for the community:
I have recently joined the Droid Razr community as a previous Droid Charge owner. I've been having a horrible time getting my device to root. (I've never had issues with any other device).

I installed the motorola drivers for Windows 7.
I am using a Verizon XT912 running android 4.0.4 ICS.

When using any of the auto-root scripts here I get "device not found".

Upon researching further into the situation, I have attempted downloading the android SDK and using the adb that comes with it. I've uninstalled all other phone drivers from Windows 7. I restarted/uninstalled motorola drivers/restarted and adb still finds no devices.

EDIT: I've also tried all the different USB ports on my computer.

I can verify adb doesn't find the droid razr by typing "adb devices" at the command prompt. Windows 7 Device Manager shows Droid Razr installed with a working driver.

Any help would be appreciated.

SOLUTION: I read the thread here http://forum.xda-developers.com/show...oot+ota&page=2 after doing three million different things to my phone. Finally, I did a factory reset. When my phone reset, I did NOT set up my google account. I then made sure the USB mode was in PTP camera mode and USB debugging was on. I installed the motorola drivers from this thread http://forum.xda-developers.com/show....php?t=1539192 !!! DO NOT INSTALL THE ONES FROM MOTOROLA's website, they are pure garbage !!!. adb now recognizes my device.

A big shout out to clifference for posting what worked for him. And a big thumbs down to motorola for posting horrible drivers on their website.

This was such a large problem that I have documented it on my blog. Fix adb Droid Razr Problems
The Following 4 Users Say Thank You to arsenik13 For This Useful Post: [ View ] Gift arsenik13 Ad-Free
 
 
6th August 2012, 05:37 PM |#2  
JPtheSmith's Avatar
Junior Member
Thanks Meter: 4
 
More
THANK YOU
Have been beating my head against this issue for weeks (ever since the ICS OTA update). I was on the verge of reinstalling Windows, but this fixed the issue completely. THANK YOU!!!!!

Quote:
Originally Posted by arsenik13

Question for the community:
I have recently joined the Droid Razr community as a previous Droid Charge owner. I've been having a horrible time getting my device to root. (I've never had issues with any other device).

I installed the motorola drivers for Windows 7.
I am using a Verizon XT912 running android 4.0.4 ICS.

When using any of the auto-root scripts here I get "device not found".

Upon researching further into the situation, I have attempted downloading the android SDK and using the adb that comes with it. I've uninstalled all other phone drivers from Windows 7. I restarted/uninstalled motorola drivers/restarted and adb still finds no devices.

EDIT: I've also tried all the different USB ports on my computer.

I can verify adb doesn't find the droid razr by typing "adb devices" at the command prompt. Windows 7 Device Manager shows Droid Razr installed with a working driver.

Any help would be appreciated.

SOLUTION: I read the thread here http://forum.xda-developers.com/show...oot+ota&page=2 after doing three million different things to my phone. Finally, I did a factory reset. When my phone reset, I did NOT set up my google account. I then made sure the USB mode was in PTP camera mode and USB debugging was on. I installed the motorola drivers from this thread http://forum.xda-developers.com/show....php?t=1539192 !!! DO NOT INSTALL THE ONES FROM MOTOROLA's website, they are pure garbage !!!. adb now recognizes my device.

A big shout out to clifference for posting what worked for him. And a big thumbs down to motorola for posting horrible drivers on their website.

This was such a large problem that I have documented it on my blog. Fix adb Droid Razr Problems

27th October 2012, 05:56 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Keeps disappearing
Resetting worked for me... for minutes. Then the phone didn't show again.
I'm on a Mac, there are no drivers. Simply keeps disappearing after the first time it works, and then I have to reset again.
There also is an official thread on Motodev community.
4th February 2013, 07:47 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by arsenik13

Question for the community:
I have recently joined the Droid Razr community as a previous Droid Charge owner. I've been having a horrible time getting my device to root. (I've never had issues with any other device).

I installed the motorola drivers for Windows 7.
I am using a Verizon XT912 running android 4.0.4 ICS.

When using any of the auto-root scripts here I get "device not found".

Upon researching further into the situation, I have attempted downloading the android SDK and using the adb that comes with it. I've uninstalled all other phone drivers from Windows 7. I restarted/uninstalled motorola drivers/restarted and adb still finds no devices.

EDIT: I've also tried all the different USB ports on my computer.

I can verify adb doesn't find the droid razr by typing "adb devices" at the command prompt. Windows 7 Device Manager shows Droid Razr installed with a working driver.

Any help would be appreciated.

SOLUTION: I read the thread here http://forum.xda-developers.com/show...oot+ota&page=2 after doing three million different things to my phone. Finally, I did a factory reset. When my phone reset, I did NOT set up my google account. I then made sure the USB mode was in PTP camera mode and USB debugging was on. I installed the motorola drivers from this thread http://forum.xda-developers.com/show....php?t=1539192 !!! DO NOT INSTALL THE ONES FROM MOTOROLA's website, they are pure garbage !!!. adb now recognizes my device.

A big shout out to clifference for posting what worked for him. And a big thumbs down to motorola for posting horrible drivers on their website.

This was such a large problem that I have documented it on my blog. Fix adb Droid Razr Problems

Big thanks from me! I worked on this all weekend and could NOT figure out why I could never see device as ADB. Factory Reset and immediately connecting worked long enough to get me rooted
6th December 2013, 06:45 AM |#5  
vazersecurity's Avatar
Senior Member
Flag Payson, UT
Thanks Meter: 45
 
More
Quote:
Originally Posted by arsenik13

Question for the community:
I have recently joined the Droid Razr community as a previous Droid Charge owner. I've been having a horrible time getting my device to root. (I've never had issues with any other device).

I installed the motorola drivers for Windows 7.
I am using a Verizon XT912 running android 4.0.4 ICS.

When using any of the auto-root scripts here I get "device not found".

Upon researching further into the situation, I have attempted downloading the android SDK and using the adb that comes with it. I've uninstalled all other phone drivers from Windows 7. I restarted/uninstalled motorola drivers/restarted and adb still finds no devices.

EDIT: I've also tried all the different USB ports on my computer.

I can verify adb doesn't find the droid razr by typing "adb devices" at the command prompt. Windows 7 Device Manager shows Droid Razr installed with a working driver.

Any help would be appreciated.

SOLUTION: I read the thread here http://forum.xda-developers.com/show...oot+ota&page=2 after doing three million different things to my phone. Finally, I did a factory reset. When my phone reset, I did NOT set up my google account. I then made sure the USB mode was in PTP camera mode and USB debugging was on. I installed the motorola drivers from this thread http://forum.xda-developers.com/show....php?t=1539192 !!! DO NOT INSTALL THE ONES FROM MOTOROLA's website, they are pure garbage !!!. adb now recognizes my device.

A big shout out to clifference for posting what worked for him. And a big thumbs down to motorola for posting horrible drivers on their website.

This was such a large problem that I have documented it on my blog. Fix adb Droid Razr Problems

Good to know the solution works. I had to use it. I was never aware that you had to have your device in camera mode when connected to your PC. That's what was screwing me..
6th January 2014, 11:45 PM |#6  
JoLoLo's Avatar
Junior Member
Thanks Meter: 0
 
More
Unhappy Losing hope...
Quote:
Originally Posted by vazersecurity

Good to know the solution works. I had to use it. I was never aware that you had to have your device in camera mode when connected to your PC. That's what was screwing me..

I have the similar issue... just my problem is much more complex since I cant enter the Android or do anything with the phone. My phone keep on restarting every 1 min while showing dead android picture in a meantime.

I cant use RSD Lite and fastboot new android on my phone, since phone isnt connected with computer and computer always keep on showing me message:
The last USB device conected to this computer is malfunctioned windows can not recognize it.
Recommendation:
Try reconnecting device. If Windows stil does not recognize it, your device may not work properly.


I tried installilng new drivers million times. I tried using motohelper drivers but still the same. Also I changed PC but again the same!!!!

I cant use ADB since my phone isnt connected with computer, same issue.

While watching dead android picture I can just enter recovery mode where I have these options:

-reboot system now
-apply update from external storage
-apply update from ADB
-wipe data/factory reset
-wipe cache partition


I tried wipe options but nothing. While I cant update from ADB.

I really dont know what to do...
10th January 2014, 06:03 PM |#7  
vazersecurity's Avatar
Senior Member
Flag Payson, UT
Thanks Meter: 45
 
More
Quote:
Originally Posted by JoLoLo

I have the similar issue... just my problem is much more complex since I cant enter the Android or do anything with the phone. My phone keep on restarting every 1 min while showing dead android picture in a meantime.

I cant use RSD Lite and fastboot new android on my phone, since phone isnt connected with computer and computer always keep on showing me message:
The last USB device conected to this computer is malfunctioned windows can not recognize it.
Recommendation:
Try reconnecting device. If Windows stil does not recognize it, your device may not work properly.


I tried installilng new drivers million times. I tried using motohelper drivers but still the same. Also I changed PC but again the same!!!!

I cant use ADB since my phone isnt connected with computer, same issue.

While watching dead android picture I can just enter recovery mode where I have these options:

-reboot system now
-apply update from external storage
-apply update from ADB
-wipe data/factory reset
-wipe cache partition


I tried wipe options but nothing. While I cant update from ADB.

I really dont know what to do...

So you can't get the computer to connect to the phone while it's in fastboot mode?
10th January 2014, 11:37 PM |#8  
JoLoLo's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by vazersecurity

So you can't get the computer to connect to the phone while it's in fastboot mode?

First the problem was somehow with drivers, but I got advice to uninstall all drivers (Motorola, Nokia, Samsung) which I had on my PC, and to reinstall just motorola drivers, and that fixed problem.

After that I got new problem with empty battery, so my phone was completely briced, but creating a factory cable solve everything
11th January 2014, 09:58 AM |#9  
vazersecurity's Avatar
Senior Member
Flag Payson, UT
Thanks Meter: 45
 
More
Quote:
Originally Posted by JoLoLo

First the problem was somehow with drivers, but I got advice to uninstall all drivers (Motorola, Nokia, Samsung) which I had on my PC, and to reinstall just motorola drivers, and that fixed problem.

After that I got new problem with empty battery, so my phone was completely briced, but creating a factory cable solve everything

Okay, good to know you got the problem solved.
6th August 2014, 04:32 PM |#10  
Junior Member
Flag Cuiabá
Thanks Meter: 2
 
More
tks
this helped a lot!! tkss
30th January 2015, 08:47 PM |#11  
Junior Member
Thanks Meter: 0
 
More
Smile Slightly Alternative Solution
Quote:
Originally Posted by arsenik13

Question for the community:

SOLUTION: I read the thread here http://forum.xda-developers.com/show...oot+ota&page=2 after doing three million different things to my phone. Finally, I did a factory reset. When my phone reset, I did NOT set up my google account. I then made sure the USB mode was in PTP camera mode and USB debugging was on. I installed the motorola drivers from this thread http://forum.xda-developers.com/show....php?t=1539192 !!! DO NOT INSTALL THE ONES FROM MOTOROLA's website, they are pure garbage !!!. adb now recognizes my device.

I had this problem with the Motorolla Turbo. To fix it I did two of the things you suggested and one third not listed here.
1.) Download the drivers from http://forum.xda-developers.com/show....php?t=1539192
2.)Made sure the USB mode was in PTP camera mode.
3.) I manually installed the adb drivers on the phone by following the steps in this tutorial.
http://visualgdb.com/tutorials/andro...ualinstall.php

Hopefully this information will help someone who needs it.
Post Reply Subscribe to Thread

Tags
adb, device not found, droid razr

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes