Post Reply

Google wallet fix for SGS3 US variants AT&T, T-MOBILE, US Cellular, VERIZON, etc

OP ogdobber

13th July 2012, 04:20 AM   |  #21  
Senior Member
Thanks Meter: 12
 
116 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by ogdobber

not the build prop. you need cm9 libs for aokp

I can get google wallet to accept the phone, however, NFC no longer shows in my settings
13th July 2012, 04:25 AM   |  #22  
Senior Member
Flag Seattle
Thanks Meter: 39
 
161 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by ogdobber

you did the one line edit? which one? model? I can adjust the op...

No, I did all 3 lines as described in the OP. Manny05 said "htc_jewell" in his post and I wanted to emphasize the proper string only has 1 L at the end.
The Following User Says Thank You to FreydNot For This Useful Post: [ View ]
13th July 2012, 04:25 AM   |  #23  
ogdobber's Avatar
OP Recognized Developer
Thanks Meter: 1,792
 
3,248 posts
Join Date:Joined: Nov 2008
Donate to Me
More
Quote:
Originally Posted by EvilEvo

Nope. Stock rom, just debloated some myself and some other apps frozen.

maybe a typo on the build.prop edit? It has been confirmed working on stock

*edit you must either use root explorer to edit or pull/push it and edit on computer
ES explorer was hammermans problem (it does not save correctly), and not Diet rom
Last edited by ogdobber; 13th July 2012 at 04:41 AM.
13th July 2012, 04:31 AM   |  #24  
ogdobber's Avatar
OP Recognized Developer
Thanks Meter: 1,792
 
3,248 posts
Join Date:Joined: Nov 2008
Donate to Me
More
Quote:
Originally Posted by meccanikal

I can get google wallet to accept the phone, however, NFC no longer shows in my settings

like I said, for aokp you need cm9 nfc libs. when you try to use samsung libs, it breaks your nfc on your cm9 based rom (not build.prop related)

nandroid back back to your orig aokp and then just push the wallet app to system/app, most likely it already has the correct libs...if not it will hang on activating, if it does that, grab the libs from a cm9 rom and you will be good
13th July 2012, 04:33 AM   |  #25  
Senior Member
Flag Seattle
Thanks Meter: 39
 
161 posts
Join Date:Joined: Jun 2010
More
I would be surprised if the CM9 NFC libs support the USA versions of the Galaxy S3. Is the necessary NFC source code available to compile against?
13th July 2012, 04:33 AM   |  #26  
Idan73's Avatar
Senior Member
Thanks Meter: 459
 
1,971 posts
Join Date:Joined: Jul 2010
More
Was about to make these instructions, as I promised last night in the other thread as I made it work on my Canadian Rogers version few days ago. Simply did not have time.
Difference being I used latest nfc apk from i9300 version and just copied it over with root explorer. That takes care of getting stuck at first screen. The modded wallet apk although does not check the country still will not add the card without using market enabler, switched to tmobile or sprint from Canada and elsewhere in the world.
If it still errors out on adding card, the htc_jewel build.prop edit is needed as well cause there are reports that wallet is down or blacklisted for sgs3 except for sprint version.

Good job ogdobber!

Sent from my GT-I9300
Last edited by Idan73; 13th July 2012 at 04:36 AM.
The Following User Says Thank You to Idan73 For This Useful Post: [ View ]
13th July 2012, 04:37 AM   |  #27  
Junior Member
Thanks Meter: 1
 
14 posts
Join Date:Joined: Jul 2012
Will the CM9 libs work for the international model? And if so, could someone please provide a link and brief instructions? Would be greatly appreciated. Thanks
13th July 2012, 04:44 AM   |  #28  
Idan73's Avatar
Senior Member
Thanks Meter: 459
 
1,971 posts
Join Date:Joined: Jul 2010
More
Quote:
Originally Posted by Whitehorse1

Will the CM9 libs work for the international model? And if so, could someone please provide a link and brief instructions? Would be greatly appreciated. Thanks

R u running cm9 or stock. If on stock UK or French latest firmware (xxlfb) , you don't need libraries, nfc apk has already been upgraded on that one. You just need build.prop edit if in states and market enabler if outside.

Sent from my GT-I9300
13th July 2012, 04:47 AM   |  #29  
Junior Member
Thanks Meter: 1
 
14 posts
Join Date:Joined: Jul 2012
I'm running stock, not exactly sure which firmware version. Full name is I9300TDUALF2_I9300TTELALF2_I9300TDULF2_HOME. Thanks for your help
13th July 2012, 04:50 AM   |  #30  
Senior Member
Thanks Meter: 12
 
116 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by ogdobber

like I said, for aokp you need cm9 nfc libs. when you try to use samsung libs, it breaks your nfc on your cm9 based rom (not build.prop related)

nandroid back back to your orig aokp and then just push the wallet app to system/app, most likely it already has the correct libs...if not it will hang on activating, if it does that, grab the libs from a cm9 rom and you will be good

My NFC works fine but google wallet won't accept my device. I change the build.prop file and google wallet works but can't accept the terms and conditions because NFC is off. I go and try to turn them on and NFC is gone from my settings.

Using htc_jewel as the device name

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in AT&T Galaxy S III General by ThreadRank