Post Reply

[WIP][CM10] CyanogenMod 10 Alpha | tutorial (7/22/12)

OP sk8erwitskil

15th July 2012, 10:24 PM   |  #1  
sk8erwitskil's Avatar
OP Recognized Contributor
Flag San Jose
Thanks Meter: 2,635
 
1,362 posts
Join Date:Joined: Apr 2010
Donate to Me
More
This is built straight from the cm10 repo. ill update this as commits get pushed to the CM repo.

- format data factory reset
- format /system
- format dalvik cache
- format /cache
- install rom

Hercules users use this rotation fix (thanks JPOKeefe):
http://forum.xda-developers.com/show...2#post28931172

Working:
- data
- bluetooth
- gapps-jb-20120717.zip
- adb (you must turn on developer options)
- messaging
- wifi
- root (flash this HERE)
- sound
- mic (sorta)
- new bootanimation (http://forum.xda-developers.com/show...php?p=28984583) (thanks to whosgotlag for the tip and nozerogravity for making it)
- BLN

Issues:
- switching to landscape in youtube app while watching a video causes a reboot
- camera
- in-call echo
- pretty much anything else. its alpha.....

DOWNLOAD


Credit goes to cyanogenmod team for getting these fixes so fast!

HOW TO BUILD!


Download repo script:
Code:
mkdir ~/bin
PATH=~/bin:$PATH
curl https://dl-ssl.google.com/dl/googlesource/git-repo/repo > ~/bin/repo
chmod a+x ~/bin/repo
Create CM10 directory:
Code:
mkdir ~/cm10
cd ~/cm10
repo init -u git://github.com/CyanogenMod/android.git -b jellybean
repo sync -j16 (this will take a few hours)
wget http://sk8erwitskil.com/guest/skyrocket/CM10/extras/local_manifest.xml -O .repo/local_manifest.xml
repo sync -j16
Build:
Code:
. build/envsetup.sh (notice the period and space)
vendor/cm/get-prebuilts
repo sync -j16
CM_EXTRAVERSION=-yourname CM_SNAPSHOT=1 brunch cm_skyrocket-userdebug
Last edited by sk8erwitskil; 23rd July 2012 at 07:51 PM.
The Following 112 Users Say Thank You to sk8erwitskil For This Useful Post: [ View ]
15th July 2012, 10:25 PM   |  #2  
Senior Member
Flag London
Thanks Meter: 63
 
394 posts
Join Date:Joined: Dec 2011
More
First ! Flashing soon thanks sk8er

Sent from my SAMSUNG-SGH-I727 using Tapatalk 2
The Following User Says Thank You to ckck543 For This Useful Post: [ View ]
15th July 2012, 10:25 PM   |  #3  
sk8erwitskil's Avatar
OP Recognized Contributor
Flag San Jose
Thanks Meter: 2,635
 
1,362 posts
Join Date:Joined: Apr 2010
Donate to Me
More
im building a rom that fixes sdcard mounting issue
The Following 7 Users Say Thank You to sk8erwitskil For This Useful Post: [ View ]
15th July 2012, 10:32 PM   |  #4  
BaconStep's Avatar
Senior Member
Flag Las Vegas
Thanks Meter: 1,487
 
3,201 posts
Join Date:Joined: Jan 2012
Donate to Me
More
If you guys are thinking of flashing please take the name of this thread seriously.
15th July 2012, 10:38 PM   |  #5  
Senior Member
Thanks Meter: 146
 
436 posts
Join Date:Joined: Jan 2007
Donate to Me
More
Quote:
Originally Posted by BaconStep

If you guys are thinking of flashing please take the name of this thread seriously.

Let us know when calling is fixed.
15th July 2012, 10:45 PM   |  #6  
sk8erwitskil's Avatar
OP Recognized Contributor
Flag San Jose
Thanks Meter: 2,635
 
1,362 posts
Join Date:Joined: Apr 2010
Donate to Me
More
can someone test if the the latest build that i just uploaded like 30 seconds ago has working sdcard mounting?
The Following 3 Users Say Thank You to sk8erwitskil For This Useful Post: [ View ]
15th July 2012, 10:47 PM   |  #7  
Senior Member
Thanks Meter: 34
 
204 posts
Join Date:Joined: Apr 2010
More
Pre-Pre-Pre Alpha good stuff. Hopefully they can get the majority of the major things working soon. I'm so anxious to use this
15th July 2012, 11:21 PM   |  #8  
lovepump's Avatar
Senior Member
Flag Port Townsend
Thanks Meter: 33
 
115 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by sk8erwitskil

can someone test if the the latest build that i just uploaded like 30 seconds ago has working sdcard mounting?

I'm testing the DL from the OP, I'll find out soon if that is the new one or old one lol

---------- Post added at 03:18 PM ---------- Previous post was at 03:09 PM ----------

Quote:
Originally Posted by sk8erwitskil

can someone test if the the latest build that i just uploaded like 30 seconds ago has working sdcard mounting?

I can confirm internal mounting is working, external is not at the moment.

---------- Post added at 03:21 PM ---------- Previous post was at 03:18 PM ----------

Can also confirm, no reboot on unplug from PC. So far going on 30 seconds lol Wifi is working also, going outside to test cell-data
15th July 2012, 11:25 PM   |  #9  
Senior Member
Thanks Meter: 19
 
226 posts
Join Date:Joined: Jan 2010
anyone know if this works on T989?
The Following User Says Thank You to piecemakr9 For This Useful Post: [ View ]
15th July 2012, 11:33 PM   |  #10  
thatlonedude's Avatar
Senior Member
Thanks Meter: 49
 
187 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by piecemakr9

anyone know if this works on T989?

Should work but rotation will wonky

Sent from my SAMSUNG-SGH-I727

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in AT&T Samsung Galaxy S II Skyrocket Android Development by ThreadRank