Post Reply

[Discussion][ROM][S4][WIP] CM10 on HTC One S [Nightlies] PLEASE READ FAQ in the OP

OP fipsib

18th July 2012, 03:52 PM   |  #1  
fipsib's Avatar
OP Senior Member
Flag Munich
Thanks Meter: 693
 
589 posts
Join Date:Joined: Jan 2011
More
(all credit goes to xkonni, intervigil & the others behind CM10!)


Quote:


FAQ / Q&A

Some known problems/bugs & their (hopefully working) workarounds:
Note: before complaining, please try a clean (wipe everything at least 3 times) installation first!
& PLEASE READ AT LEAST THE LAST 5 PAGES OF THIS THREAD!
  1. Wi-Fi is not working:
    • Make sure you flashed the right boot.img with fastboot
    • if your Wi-Fi Channel is higher than 10, try a lower one
    • try changing your wifi country code in Settings / Wifi / Menu / Advance to e.g. Europe or US
  2. App-Switch is no longer "Menu" by default:
    • go to Settings - System - Hardware keys
    • configure it like you want
  3. Do I need to flash the boot.img manually in fastboot?:
    • No, if you're using TWRP and are on a Hboot-version lower than 1.13
    • Yes, if you're using any other recovery (like CWM)
    • Yes, if you're using TWRP and your ville has the Hboot-version 1.13 or higher
  4. Phone doesn't boot beyond the CM-Bootanimation:
  5. Notification LED's don't work:
    • go to Settings - Display - Notification Light - Use custom values
    • Set it (green/red) for every app just like you want it to be
  6. App XY doens't work:
    • try clearing cache or/and data
    • try fixing permissions
  7. Massive battery drain & device is getting hot: (should not happen anymore)
    • enable 2G only
    • update to the latest radio, fix permissions and clear the caches
    • try a simple reboot
    • turn off Google Now & location history (you will still get the answercards when using voice search)
    • reboot everytime after you are using camera or gallery
    • turn off/disconnect GPS Services, reboot & keep them unconnected/turned off (thanks to djsubtronic)
    • [advanced: deactivate gallery & try e.g. Quickpic & ICS Camera (don't forget to reboot after using camera)]
    • turn off WiFi if you don't need it and you're not connected
    • adjust the screen-off time & the brightness
    • recalibrate battery
  8. "SIM Network Unlock PIN" gets asked for: (should not happen anymore)
    • just hit "Dismiss"
  9. only a handful of ringtones are shown: (should not happen anymore)
    • download the app zedge
    • download & set the ringtones you like just as you like
  10. Sound/Music/whatever only plays through the speakers: (should not happen anymore)

Please tell me what to add/delete!






hey folks,

I decided (& asked for xkonnis permission) to open a new thread where we can talk about the new features and things that (don't) work yet to keep the original CM10 DEVELOPMENT Thread clean!

Nightlies can be found here:
http://get.cm/?device=ville
[watch out that you DON'T FLASH CM9 OVER CM10!]


please note that atm these builds (& the nightlies!) are not stable, & you should only flash this if you are REALLY comfortable with it.
You should also be experienced in flashing & fastboot, adb & other stuff.
If you aren't then better read, read & read!
Nobody is responsible if this breaks or bricks your phone other than yourself!!!


a short statement from xkonni in another thread
Quote:
Originally Posted by xkonni

About this ROM
Community effort to bring CyanogenMod to the HTC One S aka Ville.

Disclaimer

Code:
This is no finished rom!
It has bugs and issues that still need to be fixed.
[...]
CM10
We are working on CM10. This is all you get. No ETA, no 'will feature xy be merged' nothing.

Gapps can be found here: http://goo.im/gapps
For a changelog visit github & gerrit
Submit your Logcats here:
http://paste.giev.de (select logcat for highlighting!)
or: in the official Development Thread for CM10 on the Ville




Quote:
Originally Posted by dc211

Here are the radios for CM10. Remember these don't change the radio version as reported in hboot. Rather they change the radio version used in CM10 under settings -> about phone.

EU_0.16 Radio
EU_1.06s Radio
EU_1.06es Radio
TMoUS_0.16
TMoUS_1.08ts Radio











Quote:

So who tried it? what is working & what isn't?

working:
  • mostly everything
  • Camera wakelock is fixed
  • appearance of the SIM unlock message is fixed
  • Headphones/-sets are recognized & work even in calls
  • In-Call Echo Fixed (once again)
  • Grafical glitches (e.g. for notifications) are fixed
  • WiFi-Hotspot
  • Receiving/answering calls
  • WiFi
  • Sending/Receiving a mms & sms
  • GPS seems to lock/work
  • Touchscreen
  • Google Now (also starting from the lockscreen)
  • Data & Network (for some users it seems to drop once in a while)
  • SD card
  • Sound
  • CRT-Screen-off animation
  • USB Mass Storage
  • ADB
  • Bluetooth, Bluetooth tethering & Bluetooth Audio
  • Quick toggles in navigationbar
  • Notification LED / LED in general
  • Lockscreen
  • Button Layout configurable
  • & of course: Google Now & Project Butter (& all the other sweets that come with 4.1(.1))
WHEN YOU ARE REPORTING SOMETHING WHICH IS WORKING PLEASE ADD THE EXACT NAME OF THE BUILD YOU ARE ON!
Not working:
  • swiping from the screen to the softkeys activates them
  • Headset icon doesn't show.
WHEN YOU ARE REPORTING SOMETHING WHICH IS NOT WORKING PLEASE ADD THE EXACT NAME OF THE BUILD YOU ARE ON!









a little video, thanks to hansthegeek:



Screenshots:






(thanks to nicxus & hansthegeek)

(all credit goes to xkonni, intervigil & the others behind CM10!)
Please think about DONATING TO XKONNI & intervigil!
Last edited by fipsib; 26th November 2012 at 09:35 PM.
The Following 34 Users Say Thank You to fipsib For This Useful Post: [ View ]
18th July 2012, 04:16 PM   |  #2  
zaxondis's Avatar
Senior Member
Flag New York City
Thanks Meter: 70
 
425 posts
Join Date:Joined: Aug 2010
More
Thanks for setting this up. Going to play with this build now (once my nandroid completes). Will report back and let you know how successful it is.
18th July 2012, 04:23 PM   |  #3  
Senior Member
Thanks Meter: 93
 
669 posts
Join Date:Joined: Jan 2011
just tried the latest JB build
stuck at the cm9 bootscreen
is this only happening to me ?


flashed boot img and rom

just tried this
http://forum.xda-developers.com/show....php?t=1775954

working

oh wow haha if u can see my smile
thank you google for making this as fast as iOS and wp7
of course like any early build almost nothing is working wifi / data/ calls etc

PS
is it made by the same people ?
Last edited by qwerty warrior; 18th July 2012 at 04:42 PM. Reason: had a revelation
18th July 2012, 04:29 PM   |  #4  
BiteBlaze's Avatar
Senior Member
Flag Wisconsin
Thanks Meter: 967
 
1,174 posts
Join Date:Joined: Mar 2012
Donate to Me
More
Quote:
Originally Posted by qwerty warrior

just tried the latest JB build
stuck at the cm9 bootscreen
is this only happening to me ?


flashed boot img and rom

Same here. Doesn't boot.

Sent from my HTC One S using xda premium
18th July 2012, 04:32 PM   |  #5  
Bohemus's Avatar
Senior Member
Flag Phoenix, AZ
Thanks Meter: 13
 
216 posts
Join Date:Joined: Apr 2010
More
Anyone else have issues with restoring a nandroid after testing jb? I use twrp and the restore goes fine but after booting the restored rom the microphone won't work and data becomes very flaky.

Sent from my HTC One S using xda app-developers app
The Following User Says Thank You to Bohemus For This Useful Post: [ View ]
18th July 2012, 04:34 PM   |  #6  
fipsib's Avatar
OP Senior Member
Flag Munich
Thanks Meter: 693
 
589 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by Bohemus

Anyone else have issues with restoring a nandroid after testing jb? I use twrp and the restore goes fine but after booting the restored rom the microphone won't work and data becomes very flaky.

Sent from my HTC One S using xda app-developers app

did you delete everything before restoring? perhaps JB adds things that are not overwritten by an ICS backup?
18th July 2012, 04:57 PM   |  #7  
zaxondis's Avatar
Senior Member
Flag New York City
Thanks Meter: 70
 
425 posts
Join Date:Joined: Aug 2010
More
Tried installing the build with today's date, and it won't boot like everyone else reported.

Going to try yesterday's build and see if there's a difference. Will post another update with the results.

---------- Post added at 11:57 AM ---------- Previous post was at 11:36 AM ----------

Got yesterday's build to boot.

No data or other radios (of course).

Most other things seemed to work. Butter is very nice and I love that lockscreen.

The auto-re sizing widgets didn't work, that is: When you try to put a widget on a page that has some space, but not enough for the widget in it's native form, it didn't re-size automatically.

--------UPDATE--------
Installed today's build over yesterday's and wiped cache/dalvik and it boots and it looks like I have a cell signal! I'll report back shortly!

Also meant to add, I am using TWRP and did NOT flash a boot image.

Will make this a rolling update as I'm still playing around. Will try installing today's build on top of this to see if that's successful.
Last edited by zaxondis; 18th July 2012 at 05:08 PM.
The Following 2 Users Say Thank You to zaxondis For This Useful Post: [ View ]
18th July 2012, 05:15 PM   |  #8  
Bohemus's Avatar
Senior Member
Flag Phoenix, AZ
Thanks Meter: 13
 
216 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by fipsib

did you delete everything before restoring? perhaps JB adds things that are not overwritten by an ICS backup?

Yes, did a full factory reset wipe in twrp prior to the restore.

Sent from my HTC One S using xda app-developers app
18th July 2012, 05:23 PM   |  #9  
Brandonrz's Avatar
Senior Member
Flag Reno
Thanks Meter: 427
 
773 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Does it have the gapps built in?? Or do i just flash gapps-jb.zip in twrp?
18th July 2012, 05:24 PM   |  #10  
Senior Member
Thanks Meter: 80
 
435 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by Bohemus

Anyone else have issues with restoring a nandroid after testing jb? I use twrp and the restore goes fine but after booting the restored rom the microphone won't work and data becomes very flaky.

Sent from my HTC One S using xda app-developers app

Tried fastboot flashing the kernel you had before trying JB? Or maybe its just some butter leftovers smeared into the mic opening

Post Reply Subscribe to Thread

Tags
cm10, experimental, intervigil, jelly bean, jellybean, rom, unstable, xkonni
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in One S General by ThreadRank