FORUMS

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

[Q] Nexus 7 Dynamic WiFi 802.1X EAP (PEAP+MSCHAPv2) Not connecting

9 posts
Thanks Meter: 0
 
By jonnyg000, Junior Member on 19th July 2012, 09:04 PM
Post Reply Subscribe to Thread Email Thread
Overview: Using stock Nexus 7 to connect to wireless network; not acting like pre-ICS devices.

Can connect using my EVO4G (CM7.2) and my TF101 (Revolver 3.7), using the "WiFi Advanced Configuration Editor" tool on the market.

For the above devices, the WiFi SSID shows as "Work" (Secured with WEP), with WiFiAdvanced on the device, i would:
1) In Settings/Wireless & Networks: select the network: "Work" (Secured with WEP)
2) enter some garbage text as the key, click connect
3) turn off/on the WiFi
4) open WiFiAdvanced and select the "Work" connection and change the settings (as listed below)
5) then within 5-20 seconds the device would connect (and stay connected) to the network without issue
This procedure is SOP for every non-ICS Android device at the company and works flawlessly.
Additionally, I've used other procedures for attempting to configure the network using the "Add network" button in the Wi-Fi settings area with the same SSID name "Work"; however these settings do not appear to stay in place, as the wireless network "Work" still shows as "Secured with WEP" and will not connect using the 802.1x EAP settings.

However after asking around the office (I work in the Infrastructure team with the Network Admins - one of which has a HTC One X that appears to be having similar connectivity issues to this specific network) turns out that most other ICS devices, and specifically for my new Nexus 7 (Stock 4.1.1, not rooted), the "Work" (Secured with WEP) network is never replaced with the 802.1x EAP version; And after adding the new network or setting up via WiFiAdvanced there is a duplicate "Work" network that shows as "out of range".

On the duplicate network listing, when clicking on the "out of range" "Work" network, it shows Security 802.1x EAP in the details (but no option to Connect). I have more than 2 bars on over 6 WAP's in the distributed wireless network (Cisco wireless devices configured to use rotating keys and assign via DHCP) and have full signal on all my devices.

My Nexus 7 does work very well at my home, running WPA2 (TKIP + AES) at 150MBPS (138mbps reported), and at the coffee shop next to work; leading me to believe it is not a functionality issue with the wireless adapter.



WiFiAdvanced settings for the "Work" network:
SSID:
SSID: Work
BSSID: [no change]
Hidden SSID: [unchecked]
Configuration:
Key Management: [None, IEEE8021X]
Auth Protocols: [Open, Shared]
Group Ciphers: [WEP40, WEP104, TKIP, CCMP]
Pairwise Cipher: [None, TKIP, CCMP]
Security Protocols: [WPA, RSN]
Enterprise Configuration:
EAP: [PEAP]
Phase2: [auth=MSCHAPV2]
Identity: [my domain/username]
AnonymousIdentity: [empty/no-change]
Password: [my domain password]
Client Certificate: [empty]
CA Certificate: [empty]
Private Key: [empty]


Yes, i know there are other threads out there, I've spent the majority of my day researching and testing - to no avail.

Can anyone suggest steps that may assist in getting the Nexus7 able to connect to this network?


UPDATE:
Asof Oct 15, 2012: This issue has been fixed in the 4.1.2 OTA.
Last edited by jonnyg000; 22nd October 2012 at 04:37 PM. Reason: Update with Fix info
 
 
19th July 2012, 09:59 PM |#2  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by jonnyg000

Overview: Using stock Nexus 7 to connect to wireless network; not acting like pre-ICS devices.

Can connect using my EVO4G (CM7.2) and my TF101 (Revolver 3.7), using the "WiFi Advanced Configuration Editor" tool on the market.

For the above devices, the WiFi SSID shows as "Work" (Secured with WEP), with WiFiAdvanced on the device, i would:
1) In Settings/Wireless & Networks: select the network: "Work" (Secured with WEP)
2) enter some garbage text as the key, click connect
3) turn off/on the WiFi
4) open WiFiAdvanced and select the "Work" connection and change the settings (as listed below)
5) then within 5-20 seconds the device would connect (and stay connected) to the network without issue
This procedure is SOP for every non-ICS Android device at the company and works flawlessly.
Additionally, I've used other procedures for attempting to configure the network using the "Add network" button in the Wi-Fi settings area with the same SSID name "Work"; however these settings do not appear to stay in place, as the wireless network "Work" still shows as "Secured with WEP" and will not connect using the 802.1x EAP settings.

However after asking around the office (I work in the Infrastructure team with the Network Admins - one of which has a HTC One X that appears to be having similar connectivity issues to this specific network) turns out that most other ICS devices, and specifically for my new Nexus 7 (Stock 4.1.1, not rooted), the "Work" (Secured with WEP) network is never replaced with the 802.1x EAP version; And after adding the new network or setting up via WiFiAdvanced there is a duplicate "Work" network that shows as "out of range".

On the duplicate network listing, when clicking on the "out of range" "Work" network, it shows Security 802.1x EAP in the details (but no option to Connect). I have more than 2 bars on over 6 WAP's in the distributed wireless network (Cisco wireless devices configured to use rotating keys and assign via DHCP) and have full signal on all my devices.

My Nexus 7 does work very well at my home, running WPA2 (TKIP + AES) at 150MBPS (138mbps reported), and at the coffee shop next to work; leading me to believe it is not a functionality issue with the wireless adapter.



WiFiAdvanced settings for the "Work" network:
SSID:
SSID: Work
BSSID: [no change]
Hidden SSID: [unchecked]
Configuration:
Key Management: [None, IEEE8021X]
Auth Protocols: [Open, Shared]
Group Ciphers: [WEP40, WEP104, TKIP, CCMP]
Pairwise Cipher: [None, TKIP, CCMP]
Security Protocols: [WPA, RSN]
Enterprise Configuration:
EAP: [PEAP]
Phase2: [auth=MSCHAPV2]
Identity: [my domain/username]
AnonymousIdentity: [empty/no-change]
Password: [my domain password]
Client Certificate: [empty]
CA Certificate: [empty]
Private Key: [empty]


Yes, i know there are other threads out there, I've spent the majority of my day researching and testing - to no avail.

Can anyone suggest steps that may assist in getting the Nexus7 able to connect to this network?


I'm afraid this is a Jelly Bean bug and not an issue with your particular device. You can see one of the many bug reports here: h t t p://code.google.com/p/android/issues/detail?id=34212 (forum wont let me post links yet ). The link provided has a flashable fix that I can confirm works for the Verizon Galaxy Nexus, but does not seem to work on the Nexus 7 based on the posts.

We basically have to wait for Google to fix this or for another dev to write a Nexus 7 compatible fix. Lastly, this bug fix is not included in custom ROMs, so you have to run it yourself either way. Very annoying on Google's part to break this.
The Following User Says Thank You to crobles81 For This Useful Post: [ View ]
20th July 2012, 03:10 AM |#3  
OP Junior Member
Flag Seacoast, NH
Thanks Meter: 0
 
More
Quote:
Originally Posted by crobles81

I'm afraid this is a Jelly Bean bug and not an issue with your particular device. You can see one of the many bug reports here: h t t p://code.google.com/p/android/issues/detail?id=34212 (forum wont let me post links yet ). The link provided has a flashable fix that I can confirm works for the Verizon Galaxy Nexus, but does not seem to work on the Nexus 7 based on the posts.

We basically have to wait for Google to fix this or for another dev to write a Nexus 7 compatible fix. Lastly, this bug fix is not included in custom ROMs, so you have to run it yourself either way. Very annoying on Google's part to break this.

Thanks for the response. That bug looks exactly like the problem.
Apparently this bug has been open for 2 weeks without a fix, not boding well for JellyBean as an iOS competitor.
challa3223
20th July 2012, 03:43 AM |#4  
Guest
Thanks Meter: 0
 
More
i uses wifi tether for root and worked with infuse hspa+
20th July 2012, 05:08 PM |#5  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by jonnyg000

Thanks for the response. That bug looks exactly like the problem.
Apparently this bug has been open for 2 weeks without a fix, not boding well for JellyBean as an iOS competitor.

The bug report has been updated with some permissions info that will make it work for the Nexus 7.
20th July 2012, 08:55 PM |#6  
biggiestuff's Avatar
Senior Member
Thanks Meter: 251
 
More
Quote:
Originally Posted by crobles81

The bug report has been updated with some permissions info that will make it work for the Nexus 7.

So should we flash it or copy it to the system/bin like the one post at the bottom says using root explorer? Do we need to rename that file at all or download as is?

Thanks,
20th July 2012, 11:22 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Same problem here. Works fine on ICS device, but no go with 4.1.1 Nexus 7.
21st July 2012, 12:40 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Verified permission....still doesn't work
I verified that the wpa_supplicant in /system/bin has the rwxr-xr-x permission.
Still doesn't work the EAP-TLS
22nd July 2012, 05:25 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Nexus 7 Network Configuration problems
From a less technical standpoint, similar issues:
Clear Wireless Internet Service at office and home.
New Nexus 7 16GB tablet.
No problem with initial network configuration at office. I entered the PW in the identified network and was instantly online.
Network at home, also Clear Wireless, with different name and PW, gave me long delay and repeatedly "Authentication Problem" failure. Two other devices (Android phone and Windows laptop) continued to function normally on the home network.
Call center wasted about an hour and wanted me to call the device manufacturer (ASUS) help call center, which I declined to do. Supervisor was better at English but not at network configuration. A trip to the Clear Wireless brick & mortal location and a temp tech rep there resulted in his ordering a new (replacement) modem for home use.
I could not delete or 'forget' the home network on my Nexus 7 to rescan for a new network configuration for the home network.
Took the Nexus 7 to the office and it again signed me on without a problem, but the home network disappeared while many other nearby business networks showed up.
My next step is to take the device back home and hope that a re-scan of the available networks will re-create a home network that will not result in the "Authentication Problem" failure from what I believe to be its faulty configuration that I was previously unable to modify, delete or 'forget'. I assume that "forget" means to delete or remove.
From the process of elimination, it appears to me that the home network configuration that was automatically created by the device is flawed and unless I can remove or re-configure it am at an impasse. Reconfiguration or removal for a re-scan were not available options when first attempted, unless and until, I get it home and am permitted to do so this time, I may have to return the device to Google under warranty.
Any related or similar problems or suggestions from others would be appreciated.
Thanks
23rd July 2012, 07:37 PM |#10  
OP Junior Member
Flag Seacoast, NH
Thanks Meter: 0
 
More
Quote:
Originally Posted by crobles81

The bug report has been updated with some permissions info that will make it work for the Nexus 7.

In order to apply the "working" patch from the thread, you need an unlocked bootloader with CWR or to manually install the file in the filesystem with "root" (Superuser) access; either way, you're breaking the stock-ness of the device (not a cool thing to do in a corporate environment that prohibits such actions).

In order for most corporate users (which this bug almost exclusively affects) to use any Android 4.1+ device on the WiFi at their offices, Google will need to fix this with an OTA, and FAST.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes