Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,477 Members 40,192 Now Online
XDA Developers Android and Mobile Development Forum

[APN][AT&T][MMS][HSPA+] Single APN for HSPA+ Speeds AND MMS - (Updated 1/1)

Tip us?
 
stratatak7
Old
(Last edited by stratatak7; 2nd January 2013 at 03:25 AM.)
#1  
stratatak7's Avatar
Recognized Contributor / Swappa Representative - OP
Thanks Meter 2,505
Posts: 1,556
Join Date: Jun 2011
Location: Blacksburg, VA

 
DONATE TO ME
Default [APN][AT&T][MMS][HSPA+] Single APN for HSPA+ Speeds AND MMS - (Updated 1/1)

Hey everyone,

As many of you know, APN switching can be a sporadic mess in AOSP roms. We've either had to deal with it or have a single APN at standard HSPA speeds. The following is a SINGLE APN solution that has been working after hours of trial and error and testing. I can't guarantee it will work for everyone, but please use this as a reference for future builds. So far so good.

APN: phone
mmsc: http://mmsc.mobile.att.net
mms proxy: proxy.mobile.att.net
MMS port: 80
MCC:310
MNC:410
APN type: default,supl,mms,hipri


After hours of testing on many ROM's, I feel like these are appropriate APN settings that everyone can use. I've gotten my best data speeds ever AND MMS to work without having to worry about APN switching. Thanks to all the testers! This has been officially moved to the development thread as a reference to AOSP and AT&T phone developers.

Disclaimer: May not work for everyone





Instructions for editing APN:
1. Menu
2. Settings
3. Wireless and Networks
4. Mobile Networks
5. Access Point Names
6. BACK UP EVERYTHING. Write it down, Screen capture, Do something! I am not responsible for you losing your settings.
7. Individually delete ALL APN's
8. Menu
9. New APN
10. Enter the above settings and make sure you hit menu>save when you're done!
11. Select your newly created APN
12. Reboot and enjoy!

Update 7-24: It has also come to my attention that port 8080 works. I am under the impression that it is higher security for sending MMS messages. Thanks!

Update 2 7-24: User xxxSuperserieSxxx has reported the following working from an AT&T Infuse to and from another AT&T phone. I need testers for this fix as well for MMS messages to users on OTHER carriers (T-Mobile, Sprint, Verizon, etc). Thanks guys.


Quote:
Originally Posted by xxxSuperserieSxxx View Post
I found out this one also working

APN: phone
mmsc: http://mmsc.mobile.att.net
mms proxy: 66.209.11.32
MMS port: 8080
MCC:310
MNC:410
APN type: default,supl,mms,hipri
Update 8-13: For One X users only! Try changing "APN" to pta and add "fota" to APN type. Then make a second APN with the above settings. pta is for LTE, but you need a fallback when you aren't in an LTE covered area I believe. If I had an LTE phone i could test this, but sadly I don't yet.

Update 8-17: I'm now supporting ANY AT&T device on this thread. If I don't already have it listed, I will find a setting that works for you and test it with anyone who needs me to do so and asks nicely.

Update 8-21: For Inspire 4G owners only! You may want to include "fota" and "admin" in APN Type, separated by commas. For example, yours would read something like: APN type: default,supl,mms,hipri,admin,fota.

Update 9-15: For AT&T Samsung Galaxy S3 owners only! Use the following to achieve LTE speeds and mms functionality:
APN: pta
mmsc: http://mmsc.mobile.att.net
mms proxy: proxy.mobile.att.net
MMS port: 80
MCC:310
MNC:410
APN type: default,supl,mms,hipri


Update 1-1: It seems a though AT&T is switching to a unified APN for all phones. This is the "phone" APN in the OP. This should be the default for all newer AT&T phones, whether they are LTE or not. This includes the Nexus 4 as well. Try it! Bottom line: Use the APN in the pictures above.

Report feedback to this thread. I will try my best to answer when possible
The Following 87 Users Say Thank You to stratatak7 For This Useful Post: [ Click to Expand ]
 
stratatak7
Old
(Last edited by stratatak7; 24th July 2012 at 06:42 PM.)
#2  
stratatak7's Avatar
Recognized Contributor / Swappa Representative - OP
Thanks Meter 2,505
Posts: 1,556
Join Date: Jun 2011
Location: Blacksburg, VA

 
DONATE TO ME
This is the old single APN HSPA method if the above settings are giving you difficulty. Data speeds are slower, but it seems to be old reliable.

APN: wap.cingular
mmsc: http://mmsc.cingular.com
mms proxy: 66.209.11.32
mms port: 80
MCC: 310
MNC: 410
APN type: default,supl,mms,hipri



The Following 12 Users Say Thank You to stratatak7 For This Useful Post: [ Click to Expand ]
 
jmoss1972
Old
#3  
jmoss1972's Avatar
Senior Member
Thanks Meter 51
Posts: 251
Join Date: Feb 2012
Location: Fort Worth, TX
Ok just tried it again with the change you suggested in your second post, and I can confirm it works, I was able to send a picture
The Following User Says Thank You to jmoss1972 For This Useful Post: [ Click to Expand ]
 
adfurgerson
Old
#4  
Senior Member
Thanks Meter 601
Posts: 1,657
Join Date: Jan 2011
I googled for an answer but gave up. So, if someone could tell me what h+ speeds are as opposed to 3g I would be thankful to them. I have a single apn that works well on my s2 but not sure if the speeds are right. My infuse is on cm 10 or I would test with that .
 
stratatak7
Old
#5  
stratatak7's Avatar
Recognized Contributor / Swappa Representative - OP
Thanks Meter 2,505
Posts: 1,556
Join Date: Jun 2011
Location: Blacksburg, VA

 
DONATE TO ME
Quote:
Originally Posted by jmoss1972 View Post
Ok just tried it again with the change you suggested in your second post, and I can confirm it works, I was able to send a picture
Really, jmoss? And phone is your only APN? Did you include a port as well? If this works, we've saved a lot of people a headache!
The Following User Says Thank You to stratatak7 For This Useful Post: [ Click to Expand ]
 
stratatak7
Old
#6  
stratatak7's Avatar
Recognized Contributor / Swappa Representative - OP
Thanks Meter 2,505
Posts: 1,556
Join Date: Jun 2011
Location: Blacksburg, VA

 
DONATE TO ME
Quote:
Originally Posted by adfurgerson View Post
I googled for an answer but gave up. So, if someone could tell me what h+ speeds are as opposed to 3g I would be thankful to them. I have a single apn that works well on my s2 but not sure if the speeds are right. My infuse is on cm 10 or I would test with that .
Well to put it simply, HSPA+ is a lot faster than regular HSPA. HSPA is what most people know as 3G. HSPA+ is what AT&T called "4G" before LTE. HSPA+ is capable of WAY faster speeds. For example, both the S2 and the Infuse are capable of 21Mbps HSPA+ with the exception of t-mobile which is capable of 42. Now in real life on HSPA is get around 3-4Mbps DL's. On HSPA+ I've seen anywhere from 7-11 at max. I hope this helps. This is actually a good read if you want more specific information on HSPA+ http://en.wikipedia.org/wiki/Evolved_HSPA
The Following 3 Users Say Thank You to stratatak7 For This Useful Post: [ Click to Expand ]
 
jmoss1972
Old
#7  
jmoss1972's Avatar
Senior Member
Thanks Meter 51
Posts: 251
Join Date: Feb 2012
Location: Fort Worth, TX
Quote:
Originally Posted by stratatak7 View Post
Really, jmoss? And phone is your only APN? Did you include a port as well? If this works, we've saved a lot of people a headache!
I only have the one APN and it's the one you have in your first post, the only thing I changed was the alternate mmsc setting you had listed. Other than that everything else is unchanged.
 
stratatak7
Old
#8  
stratatak7's Avatar
Recognized Contributor / Swappa Representative - OP
Thanks Meter 2,505
Posts: 1,556
Join Date: Jun 2011
Location: Blacksburg, VA

 
DONATE TO ME
Quote:
Originally Posted by jmoss1972 View Post
I only have the one APN and it's the one you have in your first post, the only thing I changed was the alternate mmsc setting you had listed. Other than that everything else is unchanged.
I'll be slapping your thanks button at the end of the day (used all mine on JT last night). Thanks for testing!
 
jmoss1972
Old
#9  
jmoss1972's Avatar
Senior Member
Thanks Meter 51
Posts: 251
Join Date: Feb 2012
Location: Fort Worth, TX
Quote:
Originally Posted by stratatak7 View Post
I'll be slapping your thanks button at the end of the day (used all mine on JT last night). Thanks for testing!
No problem, glad I could contribute. I wish I could have more input when it comes to the data speeds but my connection here at work sucks.
The Following User Says Thank You to jmoss1972 For This Useful Post: [ Click to Expand ]
 
prive8pierce
Old
#10  
Junior Member
Thanks Meter 4
Posts: 17
Join Date: Dec 2011
Location: Surfside Beach, SC

 
DONATE TO ME
Default thanks will test

as soon as i can get out of work today i'll work on testing this some. my mms had just started working in CM9 and then i moved to CM10 last night and have not been getting MMS. i hope your consolidation works. thanks.

The Following User Says Thank You to prive8pierce For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes