FORUMS

Nexus & Cookies: A More Focused Direction?

It is that time of the year again, and we are approaching the day where Android fans all over … more

LG G4 US Carrier Release Dates

The LG G4 was announced on April 29th with its Snapdragon 808 SoC, a welcomed change from its higher-end … more

Microsoft Reaches Pre-Install Agreement With New OEMs

As of late, Microsoft has been making a subtle but widespread play into the … more

Discover XDA: Discover Greater

We’ve all been there at some point in our XDA lives; we used to spend hours browsing over the … more
Post Reply Subscribe to Thread Email Thread

App Sideloading & Play Store Attempt

7th May 2013, 06:40 AM |#1  
Paulenski's Avatar
OP Senior Member
Flag Glendale, AZ
Thanks Meter: 44
 
More
So I got my ouya just today, took a while just getting the ADB to work. Now I managed to install Superuser, by pushing all the pieces but I don't think it's working as intended.

I pushed Gapps, got framework and Google services to work. I managed to sign-in and all, but Play Store crashes on me when I launch. Thats what I'm trying to see wrong with it.

I've already sideloaded Root Explorer and Crunchyroll(this one is still being weird as its forced in portrait mode)

There is hope for this device, I just hope to have some experienced dev's have an whack at it lol
 
 
7th May 2013, 07:14 AM |#2  
Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by Paulenski

So I got my ouya just today, took a while just getting the ADB to work. Now I managed to install Superuser, by pushing all the pieces but I don't think it's working as intended.

I pushed Gapps, got framework and Google services to work. I managed to sign-in and all, but Play Store crashes on me when I launch. Thats what I'm trying to see wrong with it.

I've already sideloaded Root Explorer and Crunchyroll(this one is still being weird as its forced in portrait mode)

There is hope for this device, I just hope to have some experienced dev's have an whack at it lol

any particular guide u use for this?
7th May 2013, 07:46 AM |#3  
Paulenski's Avatar
OP Senior Member
Flag Glendale, AZ
Thanks Meter: 44
 
More
Quote:
Originally Posted by Ozz465

any particular guide u use for this?

https://devs.ouya.tv/developers/docs/setup

To get ADB to recognize my device, you need to have the Environmental Path in place when you do the echo part of that setup for windows. Also, you need to make sure you open the SDK Manager and let it download Google Drivers, then you need to Add to the inf file under Extras/Google/USB_Driver/WinUSB.inf, to the x86 or AMD64, depending on your OS. I'll just include attachment to my inf file for it.

;OUYA
%SingleAdbInterface% = USB_Install, USB\VID_2836&PID_0010
%CompositeAdbInterface% = USB_Install, USB\VID_2836&PID_0010&MI_00

From there, I downloaded gapps for 4.1.2(remove SetupWizard.apk before you try pushing folders over). You need to get into ADB, get su, change mount to R/W then set up new permissions. I don't know what it is but the folders seem so locked down. Trying to install and launch certain things, it just fails because it has no access. I'm amatuer at this so I'm not sure why it seems so annoying, but I pushed Gapps like that, mounting r/w for like /system -/apps and folders needed, then pushing it all. I needed to r/w /data and /data/apps to get Crunchyroll to work and that also stopped my process closed errors on Play Store, but it still doesn't launch.

At the moment, I was going to push over Airdroid, XBMC, YouTube, Netflix, Hulu, MXPlayer and a few smaller apps, I'll see how things go.
Attached Files
File Type: zip android_winusb.zip - [Click for QR Code] (1.2 KB, 18 views)
Last edited by Paulenski; 7th May 2013 at 07:54 AM.
11th May 2013, 03:55 AM |#4  
I have all Google Apps running on the OUYA except Google Play, I get error com.google.android.finsky.services.DailyHygiene in the logcat...seems I am very close, yet very far lol
12th May 2013, 07:39 AM |#5  
Paulenski's Avatar
OP Senior Member
Flag Glendale, AZ
Thanks Meter: 44
 
More
Let me know if you get it working, I would like to have YouTube to work correctly. Might need instructions on how you got the Google services to work correctly, because adding accounts work but any syncing just errors on connecting to them inside apps, YouTube, gmail etc

Sent from my GT-P1000 using Tapatalk HD
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes